Subject: Re: [Extra] Fwd: I-D Action: draft-melnikov-extra-sieve-action-registry-00.txt

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 19 Aug 2021 22:07:26 +1000

Oh hey - I missed this back in the day too.

Yes please Alexey, just upload this without the melnikov in it, the doc idea was already accepted.

Bron.

On Tue, Mar 23, 2021, at 21:07, Alexey Melnikov wrote:
> Hi Ken,
> 
> On 22/03/2021 18:08, Ken Murchison wrote:
>> Looks good so far.  I caught one typo in Section 2, item 3): "one of more document" -> "one or more documents"
>> 
> Thanks, fixed in my copy.
> 
>> Is the thought behind including the capability name(s) just so that we don't have to look it up in the relevant spec?
>> 
> Yes.
> 
>> Looking forward to the initial contents to see how the interactions field gets filled in.
>> 
>> BTW, hasn't (the idea for) this doc already been accepted by the WG, hence no need for "-melnikov" in the doc name?
>> 
> I hope so, but I didn't want to presume until the official pronouncement by WG chairs :-).
> 
> Best Regards,
> 
> Alexey
> 
>> 
>> 
>> On 3/22/21 1:55 PM, Alexey Melnikov wrote:
>> 
>>> Hi all,
>>> 
>>> I submitted the initial bare-bones version of the draft for IANA registry of Sieve actions. Your comments/reviews are welcome!
>>> 
>>> Best Regards,
>>> Alexey
>>> 
>>> -------- Forwarded Message -------- 
>>> Subject:
>>> I-D Action: draft-melnikov-extra-sieve-action-registry-00.txt
>>> Date:
>>> Mon, 22 Mar 2021 10:31:12 -0700
>>> From:
>>> [email-masked]
>>> Reply-To:
>>> [email-masked]
>>> To:
>>> [email-masked]
>>> 
>>> 
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>> 
>>> 
>>> Title : IANA registry for Sieve actions
>>> Author : Alexey Melnikov
>>> Filename : draft-melnikov-extra-sieve-action-registry-00.txt
>>> Pages : 4
>>> Date : 2021-03-22
>>> 
>>> Abstract:
>>> This document creates a registry of Sieve (RFC 5228) actions in order
>>> to help developers and Sieve extension writers track interactions
>>> between different extensions.
>>> 
>>> 
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-melnikov-extra-sieve-action-registry/
>>> 
>>> There are also htmlized versions available at:
>>> https://tools.ietf.org/html/draft-melnikov-extra-sieve-action-registry-00
>>> https://datatracker.ietf.org/doc/html/draft-melnikov-extra-sieve-action-registry-00
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>> 
>>> 
>>> _______________________________________________
>>> I-D-Announce mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/i-d-announce
>>> Internet-Draft directories: http://www.ietf.org/shadow.html
>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>> 
>>> _______________________________________________
>>> Extra mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/extra
>>> 
>> -- 
>> Kenneth Murchison
>> Senior Software Developer
>> Fastmail US LLC
>> 
>> _______________________________________________
>> Extra mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/extra
>> 
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 19 Aug 2021 13:34:15 +0100

Hi Bron,

> doc idea was already accepted.

I just posted it. It requires chairs' approval.

Best Regards,

Alexey

>>> Looks good so far.  I caught one typo in Section 2, item 3): "one of 
>>> more document" -> "one or more documents"
>>>
>>> Is the thought behind including the capability name(s) just so that 
>>> we don't have to look it up in the relevant spec?
>>>
>> Yes.
>>
>>> BTW, hasn't (the idea for) this doc already been accepted by the WG, 
>>> hence no need for "-melnikov" in the doc name?
>>>
>>>> I submitted the initial bare-bones version of the draft for IANA 
>>>> registry of Sieve actions. Your comments/reviews are welcome!
>>>>
>>>> Best Regards,
>>>> Alexey
>>>>
>>>> 	[email-masked] <mailto:[email-masked]>
>>>> Reply-To:
>>>> 	[email-masked] <mailto:[email-masked]>
>>>> To:
>>>> 	[email-masked] <mailto:[email-masked]>
>>>>
>>>>
>>>>
>>>>
>>>> <https://datatracker.ietf.org/doc/draft-melnikov-extra-sieve-action-registry/>
>>>>
>>>> <https://tools.ietf.org/html/draft-melnikov-extra-sieve-action-registry-00>
>>>> <https://datatracker.ietf.org/doc/html/draft-melnikov-extra-sieve-action-registry-00>
>>>>
>>>>
>>>> <ftp://ftp.ietf.org/internet-drafts/>
>>>>
>>>>
>>>> [email-masked] <mailto:[email-masked]>
>>>> <https://www.ietf.org/mailman/listinfo/i-d-announce>
>>>> <http://www.ietf.org/shadow.html>
>>>> <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>
>>>>
>>>> [email-masked]  <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/extra  <https://www.ietf.org/mailman/listinfo/extra>
>>>>
>>> -- 
>>> Kenneth Murchison
>>> [email-masked]  <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/extra  <https://www.ietf.org/mailman/listinfo/extra>
>>>
>> [email-masked] <mailto:[email-masked]>
>> <https://www.ietf.org/mailman/listinfo/extra>
>>
>
> --

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 20 Aug 2021 00:09:47 +1000

> I just posted it. It requires chairs' approval.

Done.  I assume it's going to need to be filled out with an initial set of registry entries and references to all the existing methods specified in existing drafts?

Bron.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 19 Aug 2021 15:13:40 +0100

Hi Bron,

On 19/08/2021 15:09, Bron Gondwana wrote:
> Done.  I assume it's going to need to be filled out with an initial 
> set of registry entries and references to all the existing methods 
> specified in existing drafts?

I think this is up to the WG to decide.

My current [minor] preference is to list suggested additions in the 
draft, but strip them before the RFC is published. This is so that the 
final RFC doesn't contain stale information.

Similar approach was taken with the language-tag registry and possibly 
others.

Best Regards,

Alexey

---

From: Ken Murchison <[email-masked]>
Date: Thu, 19 Aug 2021 10:26:14 -0400

> final RFC doesn't contain stale information.

Then how does the registry get populated with the current set of 
actions?  Would the initial set be put into the IANA section of this 
draft and acted upon after IESG approval?

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 19 Aug 2021 15:28:55 +0100

Hi Ken,

On 19/08/2021 15:26, Ken Murchison wrote:
>> draft, but strip them before the RFC is published. This is so that 
>> the final RFC doesn't contain stale information.
>>
Yes, with an RFC Editor note asking to remove it just before publication.

Best Regards,

Alexey

>> Similar approach was taken with the language-tag registry and 
>> possibly others.
>>
>> Best Regards,
>>
>> Alexey
>>