Subject: Fax processing confirmation

From: MAEDA toru <[email-masked]>
Date: Wed, 14 Feb 2001 19:26:50 +0900

Hi, Folks

I want discuss about the Fax processing confirmation for
which I asked to issue the Internet Draft in ITU-T SG16
meeting last November.

The notification of success/failure of document
processing and page by page status are very important
feature for not only the classic fax but also the internet fax.
My idea is to add Fax-Report field in the MDN extension
field as follows.

MDN extension field:
Fax-Report: Fax-Results = code
           ; Fax-Pages = received page number
           ; Fax-Errorpage = error page number

After we agreed to add the filed, the field will be registered to
IANA under the registration procedure written in RFC2434.

There will be another method to add the Fax processing
confirmation in MDN.

Your comments are well come,

Toru Maeda

--------------------
MAEDA TORU
MIE Development Div. 2
CANON Inc.
--------------------

---

From: Dan Wing <[email-masked]>
Date: Wed, 14 Feb 2001 09:21:17 -0800 (PST)

> feature for not only the classic fax but also the internet fax.

If "internet fax" is:

  1)

   scanner -> ifax ------------> ifax -> printer
                       ^
                       ^
                      SMTP

how would page-by-page confirmation be useful?  The only way a page could
fail is if the printer jammed or ran out of paper or the receiving ifax
crashed or lost power.  All of these are exceptional conditions and are
solved with buffering in the ifax, UPS (uninterruptable power supply) --
that is, they're solved today with traditional fax machines.

I don't see a need for page-by-page confirmation unless there is a
transmission over analog lines -- such as over PSTN.

If you see a need for page-by-page confirmation, please provide a scenario
where a specific intermediate page could fail when the protcols involved
are TCP and SMTP.

-Dan Wing

---

From: Hiroshi Tamura <[email-masked]>
Date: Thu, 15 Feb 2001 10:20:40 +0900 (JST)

Maeda-san,

I have some comments for your two proposals.
Before I do, I ask one basic question.

Do "Terminal mode" proposal and "Fax processing confirmation" one
have to go together in your idea? Or, separate(independent) ones?
Can "Fax processing confirmation" also be used in Eifax or Fullmode
in your idea? Please explain.

Regards,
--
Hiroshi Tamura, Ricoh Company, LTD.
E-mail: [email-masked]

---

From: MAEDA toru <[email-masked]>
Date: Fri, 16 Feb 2001 12:53:27 +0900

Tamura-san

My opinion is that the fax status confirmation must be mandatory for
Full Mode and Terminal Mode.

Full Mode (FFPIM) should be updated to use "Fax processing confirmation",
after WG agreed to use it in Full Mode.

EIFAX will be updated to use it as optional.

Terminal Mode will refer "Fax processing confirmation",
if WG agreed to use it.

Regards,

Toru MAEDA

>in your idea? Please explain.

-----------------------------------
キヤノン株式会社
映像事務機MIE推進センター
映像事務機MIE第２開発部
前田　徹
146-8501　東京都大田区下丸子３−３０−２
電話　03-3757-9738、FAX　03-3757-8205
-----------------------------------

---

From: MAEDA toru <[email-masked]>
Date: Fri, 16 Feb 2001 18:57:14 +0900

Wing-san

How much confidence of ifax transmission in Simple Mode ?
Does no response mean a good confirmation ?

I want to add Fax processing confirmation in Full Mode.
In Full Mode, the image file is send as TIFF file over SMTP.
There will be some possibilities to fail to print or process
the TIFF file by some reasons.  These reasons may be
incorrect TIFF parameter for the receiver
or out of capabilities TIFF parameter for the receiver.

When you put the 10 pages of document on the scanner
and send by ifax Full Mode and you get the confirmation sheet
with  9 pages received successfully, you will find something
wrong with the scanner or the transmission.  You will check
the scanner or the system and may ask to the user of the receiver.

Comparing to the E-mail system, you can not get information about
how many pages the receiver successfully printed but just received.
You may find that the attached file is not be able to be processed
nor printed by the Email receiver with your inspiration.

The user of Full Mode ifax will have confidence of the ifax
transmission when the transmitter prints confirmation sheet
with the number of pages printed on the receiver and also
the number of page in error.

Any comments?

Regards,

Toru Maeda

---

From: Dan Wing <[email-masked]>
Date: Fri, 16 Feb 2001 10:26:02 -0800 (PST)

> the number of page in error.

IPP provides this sort of confirmation today.  Why not use IPP?

-d