Subject: goals for Terminal Mode

From: MAEDA toru <[email-masked]>
Date: Thu, 01 Feb 2001 21:08:44 +0900

Hi, forks

I explained about Terminal Mode in the fax wg at San Diego on December,
that ITU-T requested to consider adding a new charter about Terminal Mode.

I tried to define the goals for Terminal Mode as follows.
This is just beginning of discussion.
I want have creative discussion about Terminal Mode
over mailing list before the Minneapolis IETF meeting on March.

Regards,

Toru MAEDA
CANON Inc.

Goal for Terminal Mode

1. Introduction
The specification defines Terminal mode carriage of
facsimile data over the Internet, and its functionality necessary
for achieving reliability, timeliness and capability negotiation for
Internet mail that is on a par with classic T.30 facsimile.

Terminal Mode is intend to implement features of all classic T.30 facsimile 
over
Internet, providing a level of service that approximates the level
currently enjoyed by fax users, and providing all fax-specific features
that will be implemented in an embedded fax device software working on
G3 fax based system with limited memory size and CPU performance.
These fax specific features to be supported are Polling, Subaddress,
Password, senders ID, Internet Selective Polling address, Internet Routing 
address and
Double Side Printing, which will be easy to develop gateway function
between G3 fax and Terminal Mode Internet fax.

Also new features are designed such as (1) legal support by fax header or
cover page with sender's ID and Time&date, (2) end to end SMTP session
and (3) One SMTP session for capability exchange/image 
transmission/confirmation.

2. Goals for Terminal Mode
Those are goals for Terminal Mode

Easy to Implement
Interworking with G3 fax, IFAX Simple Mode and EIFAX
Features shared with G3 fax

Proof of delivery/receipt
Capability Exchange
Timely Delivery

Data Format Support
Cover Page and Fax Header
Date and Time Information
Legal Issue
Legal Identity Exchange
Quality of output

Addressing Support

Use of Existing Infrastructure
Reliably in the global Internet

Security

--------------------
MAEDA TORU
MIE Development Div. 2
CANON Inc.
--------------------

---

From: Hiroshi Tamura <[email-masked]>
Date: Wed, 07 Feb 2001 14:19:56 +0900 (JST)

Folks,

Our group was requested to reply to ITU-T SG16. Next SG16 meeting
will be held at the end of May. We have time to consider.
But, at Minneapolis meeting, I would like to have some directions.

I think Maeda-san is preparing two I-Ds. One is about the terminal mode,
which he writes below. The other is about ifax status information.

About the terminal mode, we already have a letter from ITU-T and
He writes his goals below. If there are comments, please kindly say in ML.
Any comment are welcome by him.

W.R.T. the ifax status information, there are no information.
We wait for his I-D or something.

Regards,
--
Hiroshi Tamura, Co-chair of IETF FAX WG
E-mail: [email-masked]

From: MAEDA toru <[email-masked]>
Subject: goals for Terminal Mode
Date: Thu, 01 Feb 2001 21:08:44 +0900