Subject: RE: Fax processing confirmation

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 17 Feb 2001 12:59:22 -0800

Hi Dan and IFax folks,

Please note that IPP notifications (in-band via IPP channel
or out-of-band via SMTP or 'reverse' HTTP) are still
work-in-progress in the IETF IPP WG.

IPP native protocol itself does NOT provide confirmation that
any pages have actually been printed without polling (by the
IPP Client) of the IPP Printer.

The IEEE/ISTO PWG (Printer Working Group) has chartered IPPFax
project, but it isn't very far along yet.  The IETF declined
to charter IPPFax as an IETF WG, so this is probably quite
far away from an IETF 'standards track' RFC.

Cheers,
- Ira McDonald, consulting architect at Sharp and Xerox
  (active member of IETF IPP WG, author of 'ipp:' URL scheme)
  High North Inc

-----Original Message-----
From: Dan Wing [mailto:[email-masked]]
Sent: Friday, February 16, 2001 10:26 AM
To: MAEDA toru
Cc: [email-masked]; Claudio Allocchio; Hiroshi Tamura
Subject: Re: Fax processing confirmation

On Fri, 16 Feb 2001 18:57 +0900, MAEDA toru wrote:

> Wing-san
> 
> How much confidence of ifax transmission in Simple Mode ?
> Does no response mean a good confirmation ?
> 
> I want to add Fax processing confirmation in Full Mode.
> In Full Mode, the image file is send as TIFF file over SMTP.
> There will be some possibilities to fail to print or process
> the TIFF file by some reasons.  These reasons may be
> incorrect TIFF parameter for the receiver
> or out of capabilities TIFF parameter for the receiver.
> 
> When you put the 10 pages of document on the scanner
> and send by ifax Full Mode and you get the confirmation sheet
> with  9 pages received successfully, you will find something
> wrong with the scanner or the transmission.  You will check
> the scanner or the system and may ask to the user of the receiver.
> 
> Comparing to the E-mail system, you can not get information about
> how many pages the receiver successfully printed but just received.
> You may find that the attached file is not be able to be processed
> nor printed by the Email receiver with your inspiration.
> 
> The user of Full Mode ifax will have confidence of the ifax
> transmission when the transmitter prints confirmation sheet
> with the number of pages printed on the receiver and also
> the number of page in error.
> 
> Any comments?

IPP provides this sort of confirmation today.  Why not use IPP?

-d

---

From: MAEDA toru <[email-masked]>
Date: Tue, 20 Feb 2001 18:42:52 +0900

Ira-san

Thank you very much for detailed information about the IPP notification
that it does not support page by page confirmation from the receiver.
Fax wg should discuss about fax processing status.
PWG IPP FAX WG may discuss about the fax processing status also.

Regards.

Toru Maeda

>IPP provides this sort of confirmation today.  Why not use IPP?

--------------------
MAEDA TORU
MIE Development Div. 2
CANON Inc.
--------------------