Subject: Question on SIP/T.38 call flow mapping

From: Umang Choudhary <[email-masked]>
Date: Fri, 9 Feb 2001 13:12:07 -0500 (EST)

Hi,
I have a question on SIP/T.38 call flow mapping. The draft SIP T.38 call flow examples
and Best Current Practices <draft-mule-sip-t38callflows-00.txt> uses SIP
to do call signalling for a T.38 fax call. 
It addresses the SIP exchanges needed for initial call setup, when a
CED/Preamble or end of fax tone is detected. Does this mean that all
the other T.38 messages like DIS, DCS, CFR/FTT, MPS, etc. should be
transmitted without using SIP, although they are not actual fax images?
Is there any draft/paper that might address these issues.
Thanks,
Umang Choudhary
University of Maryland, Baltimore County

---

From: Hiroshi Tamura <[email-masked]>
Date: Wed, 14 Feb 2001 18:28:20 +0900 (JST)

Umang,

I am not familiar with SIP in T.38.
But SIP is only used for call-setup in T.38, I believe.

> transmitted without using SIP, although they are not actual fax images?

So, My answer is Yes.

There are two call-setups in T.38. One is H.323 call-setup,
and the other is SIP/MGCP call-setup. Even if H.323 call-setup
is used, T.30 signals as well as image data are transmitted
without H.323 definitions. Only T.38 definitions(T.38 Annex A etc.)
can be used. Also, T.30 signals such as DIS and DCS are defined in Annex A.

I think the use of SIP must be the same.

> Is there any draft/paper that might address these issues.

Please see the latest version T.38, including Annex and Appendix.

If I am wrong, please correct me, folks.

Regards,
--
Hiroshi Tamura, Ricoh Company, LTD.
E-mail: [email-masked]