Subject: RE: No description for image/tiff in Impl-Guide

From: James Rafferty <[email-masked]>
Date: Tue, 18 Dec 2001 09:19:55 -0500

Tamura-san,  

Some related edits could be:  

5.4 Content-Type for the file format

The content-type "image/tiff" should only be used for Profiles S and F.
Some existing implementations based on [RFC 2301] may use "image/tiff" for
other Profiles.
However, this usage is now deprecated.   Instead, the content-type
"image/tiff-fx" whose
registratin is being defined in [TIFF-FX-REG} should be used.    
Also, "image/tiff-fx" may be used for Profile S and F.

BTW, is the last sentence true, or would image/tiff always be used for S and
F?

James

> -----Original Message-----
> From: Hiroshi Tamura [mailto:[email-masked]]
> Sent: Tuesday, December 18, 2001 6:36 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: No description for image/tiff in Impl-Guide
> 
> 
> 
> Claudio,
> 
> Thanks for your comment.
> 
> > As I already said, the exact procedures for single cases 
> will be decided 
> > by IESG and IAB, as we know the situation for this case is 
> "very peculiar"
> 
> > The important action on us as a WG is to check now where 
> updates and 
> > clarifications are needed, and poit out immediately the new text.
> 
> OK. I will include something about content-type.
> I hope I can edit it by this month.
> 
> New-section:
> 
> -------------------------------------------------------------------
> 5.4 Content-Type for the file format
> 
> The content-type "image/tiff" should be only used for Profile S and F.
> Old implementations might use "image/tiff" for other Profiles.
> But, it should be avoided. The content-type "image/tiff-fx" 
> should be used
> for them. Also, "image/tiff-fx" can be used for Profile S and F.
> 
> -------------------------------------------------------------------
> 
> If anybody has good description about it, please let me know.
> Are the 2nd and the 3rd sentence unnecessary?
> 
> Regards,
> --
> Hiroshi Tamura, Ricoh Company, LTD.
> E-mail: [email-masked]
>

---

From: Hiroshi Tamura <[email-masked]>
Date: Wed, 19 Dec 2001 11:34:29 +0900 (JST)

James,

Thanks for your comment.

(I changed "Subject".)

> Also, "image/tiff-fx" may be used for Profile S and F.

Very good!

> BTW, is the last sentence true, or would image/tiff always be used for S and

"draft-ietf-fax-tiff-fx-11.txt"

-------------------------------------------------------------------------

9. MIME content-types image/tiff and image/tiff-fx

<snip>

   within an image/tiff or image/tiff-fx content type. The image/tiff
   content type should be used when black-and-white image data is
   encoded using TIFF-FX (RFC 2301 "File Format for Internet Fax")
   Profiles S or F, or a subset. The image/tiff-fx content type must be
   used when black-and-white or color image data is encoded using TIFF-
   FX Profiles J, C, L or M and any future TIFF-FX extensions, or a
   subset. The image/tiff-fx content type may be used when black-and-
   white image data is encoded using TIFF-FX Profiles S or F, or a 
   subset.

-------------------------------------------------------------------------

So, I think it is true.

Anyway, thanks.

Regards

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 18 Dec 2001 23:48:21 -0800

> BTW, is the last sentence true, or would image/tiff always be used
> for S and F?

If you you're only sending Profile S or F, I don't see a need to "scare"
a receiver into thinking you're sending a higher-complexity TIFF.

So, I would recommend striking the last sentence above and replacing it
with:

  To achieve the highest amount of interworking with devices only
  capable of rendering Profile S or F, "image/tiff-fx" SHOULD NOT
  be used for Profile S or F; rather, "image/tiff" SHOULD be used.

Note that in IETF standards language, implementations can ignore
"SHOULD" requirements if they desire.

-d

---

From: Hiroshi Tamura <[email-masked]>
Date: Thu, 20 Dec 2001 07:46:20 +0900 (JST)

Dan,

Thanks for your comment.

>   be used for Profile S or F; rather, "image/tiff" SHOULD be used.

I do not have my strong opinion about it.
As I quoted, draft tiff-fx-11 says image/tiff-fx may be used for S or F.
So, at first, I included it.

But, This is the **Guide** for Ifax. For implementers, it may better.
OK. I agree to it.

> "SHOULD" requirements if they desire.

Right.

Regards,

---

From: Hiroshi Tamura <[email-masked]>
Date: Wed, 19 Dec 2001 11:34:29 +0900 (JST)

James,

Thanks for your comment.

(I changed "Subject".)

Very good!

<snip>

So, I think it is true.

Anyway, thanks.

Regards