Subject: draft minutes at Minneapolis meeting

From: Hiroshi Tamura <[email-masked]>
Date: Fri, 05 Apr 2002 18:01:51 +0900 (JST)

Folks,

Attached is the draft minutes at our Minneapolis meeting.
I use most of the "spell checked minutes" by Claudio,
although I add some sentences a little on the whole,
considering the comments on ML.

If there are comments, please say!
I would like to submit it by Apr 11 (JST).

Thanks again, Claudio.

Regards,
--
Hiroshi Tamura, Co-chair of IETF-FAX WG
E-mail: [email-masked]

---

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Mon, 08 Apr 2002 20:30:32 +0900

Tamura-san,

In the minutes 
 3 The I-Ds that IESG is reviewing (Before IETF Last Call)

 <snip>

 Ned confirmed that the request for the IETF last Call for
 - draft-ietf-fax-esmtp-conneg-01.txt
 - draft-ietf-fax-timely-delivery-05.txt
 has been sent to the Secretariat, but there are currently more than 30
 requests in the queue.

But, I can't find "draft-ietf-fax-esmtp-conneg-01.txt" 
in the queue of "IESG Status of Items". 
Would you ask Freed-san to check it? 

Regards,

>I would like to submit it by Apr 11 (JST).

Kiyoshi Toyoda

---

From: "Larry Masinter" <[email-masked]>
Date: Wed, 10 Apr 2002 08:27:42 -0700

A minor edit:

Change the word 'products' to 'implementations':

> which are intended to be Internet Fax products. He objects that
testing
< which are intended to be Internet Fax implementations. He objects that
testing

> but only specific "Internet Fax" products which have this MIME
capability.
< but only specific "Internet Fax" implementations which have this MIME
capability.

> these features will be then tested also by the products conformant to
< these features will be then tested also by the implementations
conformant to 

since that is the word I used in my slides, talk, and which
occurs in RFC 2026.

Larry
-- 
http://larry.masinter.net

---

From: Hiroshi Tamura <[email-masked]>
Date: Thu, 11 Apr 2002 09:50:25 +0900 (JST)

Folks,

As the draft minutes says,

> Ned Freed reminded that the IESG is following closely this problem and in
> particular the TIFF-FX issue. Thus the IESG, having received Larry's
> objections, will put a careful consideration to verify if the raised
> points are consistent or not. It is thus strongly suggested to the editors
> and the WG to make any possible additional effort to clarify these points.

In the meeting, Ned did not say clearly that it is necessary
to do the testing for TIFF-FX format.
But, after the meeting, Ned, Claudio and I talked about
how to deal with the Draft Standard process as smoothly as possible.
In the event, it was agreed that the re-testing is necessary.
If the situation is not changed, the same objection would be done again.
We are not in court, but, in order to clear the doubts, we agreed we should
do the re-testing.

I must say, Japanese manufactures already had the testing
in 1999 thru 2001, regarding Profile S and F. We already have the report:
http://www.ciaj.or.jp/ciaj/ciaj-e/quart/vol-19/1903.html.
It is the report in 1999 and one of the reports. There is another report,
but it is not written in English.

My Japanese colleagues and I can modify the report for Draft Standard
consideration and submit it to IETF.
Also, I must say, the report does not have anything to do with
http://www.ietf.org/IESG/Implementations/TIFF-FAX-implementation.txt.

Thus, I propose the new testing should be done for Profile J, C, L and M.
Ned and Claudio already accepted it.

Anyway, I encourage all of you to attend the testing again.
The exact schedule is not decided yet, but, if possible,
it is better to do it before the next IETF meeting.

Now, I am trying to find the implementation information in Japan.
It surely can be done for Profile J and C. There are two independent
implementations. Regarding Profile L and M implementations in Japan,
now, I am collecting the information. There was surely the implemenations.

If you have the implementation information for Profile J, C, L and M,
please say here. Any information is appreciated.

Also, I would like to say, Service I-D wating for Draft Standard
is dependent on TIFF-FX. For the I-D, we need to make it to be
Draft Standard.

Please understand the situation, everyone.

Claudio,
if there are something you should follow, please comment!

Regards,

---

From: "Larry Masinter" <[email-masked]>
Date: Thu, 11 Apr 2002 11:04:13 -0700

Since there will be new interoperability testing, could those
doing the testing please save some of the test messages/files?
It would be useful for others who might want to test
interoperability later; it can also validate the range
of options tested.

I asked back in September for test messages or test files,
but didn't get any response, and I can't find any test messages
or files anywhere, not even for TIFF S or F. Most useful,
I would think, would be an archive of samples, reachable
from the  http://www.imc.org/ietf-fax/ .

There are some differences between RFC 2301 and
draft-ietf-fax-tiff-fx-11.txt. Will the tests cover
the areas of difference (e.g., use of the optional
GlobalParametersIFD in profiles S and F)?

Larry

---

From: Hiroshi Tamura <[email-masked]>
Date: Mon, 15 Apr 2002 11:20:54 +0900 (JST)

> interoperability later; it can also validate the range

It would be useful, but, I do not think it is necessary
in implementation reports.
It would be like including all the protocol header or format.

> GlobalParametersIFD in profiles S and F)?

There are slight differences. But, I do not think there are 
not large difference technically, regarding the file format,
as I roughly see the revision.

To the Editors:
If it is not correct, please comment.

Anyway, the format of the implementation report will be
similar to the previous one that we already have in IETF site.

---

From: John Perkins <[email-masked]>
Date: Tue, 16 Apr 2002 18:03:02 +1000

It would be appeciated if the TIFF files used in constructing a further
implememtation report could be referenced along with the report so that
those who may subsequently wish to replicate their own tests are able to do
so. Thank you.

John

---

From: Hiroshi Tamura <[email-masked]>
Date: Thu, 18 Apr 2002 08:21:27 +0900 (JST)

John,

> those who may subsequently wish to replicate their own tests are able to do

As it is not required to attach files or protocol formats
in the implementation report, basically, I do not do them.
Please mail to the contact people in the report, after the submision.
If they receive lots of request, there would be something to consider.

If you need the sample of my company, please contact me.

But, I understand the situation. I looked for the sites that have
some files. It seems that ITU-T has some of them.
Please visit http://www.itu.int/ITU-T/1997-2000/com08/tiff-fx/send2.html.
I believe it meets your requrest.

Regards,

---

From: John Perkins <[email-masked]>
Date: Thu, 18 Apr 2002 20:06:07 +1000

Tamura-san

Thank you for your ITU-T reference to sample TIFF files. This is a useful
reference but contains the file names only, without any description of the
profiles they represent. It is of course possible to interrogate the Tags
in order to deduce the proflie, however I believe it would be of assistance
to implementors to have reference files with descriptions.

regards

John

>I believe it meets your requrest.
--------------------------------------------------------
John Perkins	
Exfax Technologies Pty Ltd
PO Box 6004    Melbourne    Australia  3004
Tel +61 3 9534 5495	Fax +61 3 9534 8994
http://www.exfax.com
--------------------------------------------------------