Subject: Re: Please consider last call on draft-ietf-forces-framew ork-02.t xt

From: Alex Vasquez <[email-masked]>
Date: Thu, 10 Oct 2002 15:31:12 -0400

All,
I do not think we should be mixing logical entities with physical ones.
There should not be off-loading CE functions onto FE, this contradicts
current CE and FE definitions.  CE and FE  are logical entities with
concrete responsibilities. I can see that one can off-load a CE function
into a physical entity that can perform that CE functions. I can also see
that the same physical entity performing FE functions. Both, CE and FE,
running in the same physical entity should interact similarly as if they
were running in different physical entities. Thoughts?

Cheers,

Alex

> The information contained in this e-mail is LVL7
> Confidential.  Any use except that authorized by LVL7 is
> prohibited. If you get this in error, please notify sender
>         and delete this e-mail.
>

-----Original Message-----
From: Yang, Lily L [mailto:[email-masked]]
Sent: Thursday, October 10, 2002 12:29 PM
To: [email-masked]
Subject: Re: Please consider last call on draft-ietf-forces-framew
ork-02.t xt

Jeelani --
That is a very good point. I have been thinking about it lately. The concept
and practice of "off-loading CE functions onto FE" or "split control plane"
challenge ForCES's way of defining FE and CE -- our terminology has been
that FE and CE are both "logical" entities -- but what really is the
boundary here? Is it logical boundary or physical boundary? Our goal is to
strive for physical sepration. So I think it is actually the physical
boundary that defines CE and FE. Maybe we should revise the definition to
reflect this. What do people think?

I was keenly aware of the fact that this was not addressed in the framework.
I was not sure where this should be addressed. I think you just point out a
good place to me.
I will get that fixed soon.

Thank you for your comment,
Lily

> -----Original Message-----
> From: Syed, Jeelani [mailto:[email-masked]]
> Sent: Thursday, October 10, 2002 7:27 AM
> To: [email-masked]
> Subject: Re: Please consider last call on draft-ietf-forces-framew
> ork-02.t xt
>
>
> Yep that's exactly what i was gettin at, Thanx Patrick.
> Don't you think that the section  "5.6. Application Layer -- Routing
> Protocols"
> in framework draft is missing or ignoring that requirement.
> Just a concern.
>
> Regards
> -jeelani.sm
>
> -----Original Message-----
> From: Patrick Droz [mailto:[email-masked]]
> Sent: Thursday, October 10, 2002 10:08 AM
> To: [email-masked]
> Subject: Re: Please consider last call on
> draft-ietf-forces-framework-02.t xt
>
>
> Jeelani,
>
> there are some statments about this in the requirements
> draft.
> http://www.ietf.org/internet-drafts/draft-ietf-forces-requirem
> ents-06.txt
> Section 6.5.  Point 8) Off-load Functions
>
> Regards,
> Patrick
>
>
> Syed, Jeelani wrote:
> > Hi,
> >
> > Sometimes you may have to run protocol counterparts(agents) on
> > FEs for protocols running on CEs to avoid packet latencies and
> > increase scalability. This draft doesn't talk abt that,
> > Is it because its too soon to talk abt it?
> >
> > regards,
> >
> > -jeelani.sm
> >
> > -----Original Message-----
> > From: Yang, Lily L [mailto:[email-masked]]
> > Sent: Wednesday, October 09, 2002 8:11 PM
> > To: [email-masked]
> > Subject: Please consider last call on
> draft-ietf-forces-framework-02.txt
> >
> >
> > Hi,
> > We just submitted a new version of the ForCES framework draft.
> > Several people on the list have given us comments on the
> previous (ver01)
> > draft and we've incorporated all into this version.
> >
> > Most of the change are minor, including:
> >         1) fixing Fig 6 (a) to make it really full mesh
> >         2) Moving the Abstract and Table of Contents to the front.
> >         3) Other editorial changes to improve clarity
> throughout the draft
> >
> > A more significant modification is in section  5.7.
> "Application Layer --
> > Network Management Protocol". Per comments from T. Sridhar,
> when we talk
> > about how SNMP is supported in ForCES, we suggest that
> "AgentX framework
> > defined in RFC2741 may be applied here such that CEs act in
> the role of
> > master agent to process SNMP protocol messages while FEs
> act in the role
> of
> > subagent to provide access to the MIB objects residing on
> FEs. AgentX
> > protocol messages between the master agent (CE) and the
> subagent (FE) are
> > encapsulated and transported via ForCES, just like data
> packets from any
> > other application layer protocols."
> >
> > Accordingly, a new reference to RFC2741 is also added in
> the "normative
> > reference" section.
> >
> > As always, comments are welcome.
> >
> > The co-authors feel that this framework draft has been
> through several
> > iterations and seems pretty stable now. So we would like
> the working group
> > chairs to consider last call on this version.
> >
> >
> > Thanks,
> > Lily
> >
> >
> >  <<draft-ietf-forces-framework-02.txt>>
> >
> >
>
>
> --
>    Dr. Patrick Droz                     | [email-masked]
>    IBM Zurich Research Laboratory       |
> http://www.zurich.ibm.com/~dro
>    Saumerstrasse 4                      | Tel. +41-1-724-85-25 CH-8803
>    Rueschlikon/Switzerland              | Fax. +41-1-724-85-78
>

---

From: Vip Sharma <[email-masked]>
Date: Fri, 11 Oct 2002 09:21:43 -0400

All,
        I agree with Alex's comments... CE and FE are logical entities
.. Where they are physically located, though interesting from OEM point
of view, is not very germane. Wherever they are located they interact in
the "same" way...

vip

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Alex Vasquez
Sent: Thursday, October 10, 2002 3:31 PM
To: [email-masked]
Subject: Re: Please consider last call on draft-ietf-forces-framew
ork-02.t xt

All,
into a physical entity that can perform that CE functions. I can also
see

Cheers,

Alex

-----Original Message-----
From: Yang, Lily L [mailto:[email-masked]]
Sent: Thursday, October 10, 2002 12:29 PM
To: [email-masked]
Subject: Re: Please consider last call on draft-ietf-forces-framew
ork-02.t xt

Jeelani --
That is a very good point. I have been thinking about it lately. The
concept
and practice of "off-loading CE functions onto FE" or "split control
plane"
challenge ForCES's way of defining FE and CE -- our terminology has been
that FE and CE are both "logical" entities -- but what really is the
boundary here? Is it logical boundary or physical boundary? Our goal is
to
strive for physical sepration. So I think it is actually the physical
boundary that defines CE and FE. Maybe we should revise the definition
to
reflect this. What do people think?

I was keenly aware of the fact that this was not addressed in the
framework.
I was not sure where this should be addressed. I think you just point
out a
good place to me.
I will get that fixed soon.