Subject: Re: architecture draft comments

From: "Yang, Lily L" <[email-masked]>
Date: Fri, 11 Oct 2002 14:51:37 -0700

Jamal --
Thanks for the comments! Itemized responses or further questions below ...

> -paragraph under fig. 5 describes an example of how CE1
> remains in sync with
> CE2 via  a CE-CE protocol. I dont see it happening this way

Could you elaborate on how you think it works?

> - section 4.1.2 and how the FE tells the FE manager of it FE
> ID. An alternate
> is for the FE to be told what its FE (perhaps by the CE via
> CE Manager to FE
> Manager). There are other ways.

I guess that you meant FE can be assigned FE ID by its FE manager? I agree
there are many ways go about doing that. It is outside ForCES anyway.

> -Fig 9: I could see msg 2 "Let me join" or "I wish to
> register" as being the
> first msg.

Absolutely.

> There should be clear text that indicates that the
> architecture examples are
> just that - mere examples; that try to describe from a
> sky-high view the
> concepts that might be employed.

Agree. Will make sure such text is there.

Lily

> -----Original Message-----
> From: Jamal Hadi Salim [mailto:[email-masked]]
> Sent: Friday, October 11, 2002 6:49 AM
> To: [email-masked]
> Subject: architecture draft comments
>
>
>
> I realize that examples in the draft are just that, examples;
> however, I am a
> little concerned about some of the "suggestions" made and and
> how they may be
> interpreted as the way the protocol should behave. For instance:
>
> -paragraph under fig. 5 describes an example of how CE1
> remains in sync with
> CE2 via  a CE-CE protocol. I dont see it happening this way
> - section 4.1.2 and how the FE tells the FE manager of it FE
> ID. An alternate
> is for the FE to be told what its FE (perhaps by the CE via
> CE Manager to FE
> Manager). There are other ways.
> -Fig 9: I could see msg 2 "Let me join" or "I wish to
> register" as being the
> first msg.
>
> I could go on but hopefully with those few examples i have
> illustrated my
> concern.
> There should be clear text that indicates that the
> architecture examples are
> just that - mere examples; that try to describe from a
> sky-high view the
> concepts that might be employed.
> I just scanned the draft, so if that text is already there
> then ignore me.
>
> cheers,
> jamal
>
>
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 13 Oct 2002 06:36:17 -0700

> Could you elaborate on how you think it works?

Here's the wording i was refering to:
"... FE1 and FE2 can be configured to accept commands from both the primary
CE (CE1) and the backup CE (CE2). At the beginning, CE1 issues commands to
FEs while CE2 silently remains in sync with CE1 via CE to CE protocol over
Fr reference point. Before CE2 starts issuing commands to the FEs, it
might need to recheck the FEs' state and instruct FEs whether or not it
is ok to preserve their current state."

1st sentence uses the word "configured" to say somehow both CEs will send
commands to the FEs. It doesnt say what configured means; therefore it
doesnt describe the how - i am happy with this. The second and third
sentence go into unnecessary details of the "how".

How i think it should work is unimportant really since this is beyond
forces scope; as far as i am concerned it could be proprietary. The
danger is in making "suggestions" in a blackbox document.
Since both yourself and Alex asked this same question i am going to assume
you have come to the conclusion the way it is worded right now is "how it
should work" ;-)
Heres one of ways it could work as well:
Assume communication between CEs and FEs is visible to both CEs. Maybe a
mcast channel. They can both see the transactions/results, although only
one is active. In this case synchronization is continual as opposed using
a "CE to CE protocol over Fr reference point".
I could describe two other ways (and i am sure there are 101 ways) to do
it, but thats beside the point.

I think you have enough material on the Fr point of reference that you
dont need those two extra sentences above; so please consider deleting
them and replacing with:
"Upon detection of CE1 failure, perhaps across the Fr reference point, CE2
is configured to take over activities of CE1. This is beyond the scope of
Forces and is not discussed further".

cheers,
jamal