Subject: Re: Pre-association phase and the Forces protocol

From: "Yang, Lily L" <[email-masked]>
Date: Wed, 20 Aug 2003 14:14:32 -0700

Hi, Avri -- Thanks for your thoughtful comments. 
You are absolutely right that pre-association phase can be still on-going even in the post-assocaition phase. FE topology can change as a result of that. As long as ForCES can deal with asynchronous event notice from FE so that CE can be informed of such change, I don't see any real issue. 
It is also true, like you pointed out, that an external entity or FE virtualization can cause dynamic resource change on FE -- again, as long as FE model is flexible enough to allow and deal with such change, and CE can be informed of such change via ForCES, I think we are fine. 

But I agree that framework draft can call this out more explicitly.

I would like to propose the following changes:

3.2 End of first paragraph: 
[old] "FE virtualization should occur only in the pre-association phase and 
    hence has no impact on ForCES."
[new] "If FE virtualization occur only in the pre-association phase, it has no impact on ForCES. However, if FE virtualization results in dynamic resource change on FE during post-associaiton phase, the FE model needs to be able to report such capability and the ForCES protocol needs to be able to inform the CE of such change via asynchrounous messages."

4.3.2 Add a sentence at the end of the first paragraph:
[new] "When an FE leaves or join an existing NE that is already in post-association phase, the CE needs to be aware of the impact on FE topology and deals with the change accordingly. "

Do you think the proposed change address your concern adequately?

Lily

> -----Original Message-----
> From: avri [mailto:[email-masked]]
> Sent: Monday, August 18, 2003 11:35 PM
> To: [email-masked]
> Subject: Pre-association phase and the Forces protocol
> 
> 
> Hi,
> 
> In reading the framework and in listening to conversations about
> pre-association phase, something has been concerning me.    and it has
> taken me a while to start focusing in on it.
> 
> While it is true that ForCES WG is not currently responsible for
> discussing what happens in the pre-association phase, I think there is
> something that is being overlooked.  The pre association 
> phase does not
> occur only at t0, or during re-association after a disruption in
> association,  in the operation of a NE.   Once a first CE (or a number
> of CEs) and a first FE (or a number of FEs) are associated, it is
> possible for more forces protocol elements to be added to the mix.
> Thus while the post-association phase in ongoing in one part of the
> system the pre-association phase can be  ongoing in another.
> 
> For example in the Framework, in section 3, it is discussed 
> that the FE
> and CE managers only have a function in the pre-association phase
> (something in itself I am not sure about - discussed below) and
> therefore are not further considered.  Yet, the effect on the 
> entire NE
> of FEs being added and thus changing the FE topology needs to be
> considered.  Likewise, if the capabilities of a FE is changed once it
> is in operation by action from an external source (e.g. a CE 
> manager or
> some other management entity) the CE set must be informed (req 14).
> while this is briefly mentioned in the Framework (4.3.2), I don't
> believe the full effect of the ongoing pre-association phase under the
> conditions of dynamic leaving and rejoining (req 5 - 12) has been
> adequately described.
> 
> In regards to  the FE and CE manager only being involved during the
> Pre-association phase.  While the requirements only state that that
> they operate in the pro-association phase, I see no limitation on them
> also having a management relation to the FPEs during the
> post-association phase.  In fact if we look forward to a future with
> dynamic re-association of resources and partitioning of 
> resources, this
> post-association management activity will need to be part of the
> architecture.  Note, it is not just well defined CE and FE managers
> that can affect the NE, but the omnipresent CLI as well.
> 
> 
> a.
>

---

From: "Wang,Weiming" <[email-masked]>
Date: Mon, 25 Aug 2003 15:34:50 +0800

Hi all,

Since the draft "Topology representation for ForCES FE model" was posted, some comments have been received. 
As the author, I would like to thank Alex and Alan very much for their valuable comments. 

The draft can be found in ForCES informational page, or just click the link,
http://www.ietf.org/internet-drafts/draft-wang-forces-model-topology-00.txt 

In order to improve the draft, the author asks for more comments. The author is grateful to any of them. Comment 
topics may include but not at all limited to that like:

1. the comments and evaluations on the effectiveness; 
2. the comparison with other approaches to topology representation for ForCES model;
3. any unseen technical problems.

Because the part in the draft regarding "match block" seems not fit in the draft contents, the author has decided to remove the part 
in the followed version. 

Thank you very much.

draft author
Weiming Wang

---

From: avri <[email-masked]>
Date: Tue, 26 Aug 2003 09:29:31 +0900

On måndag, aug 25, 2003, at 16:34 Asia/Seoul, Wang,Weiming wrote:
>
> Because the part in the draft regarding "match block" seems not fit in 
> the draft contents, the author has decided to remove the part
> in the followed version.
>
>

As I mentioned to the author privately, I think it was a pity the 
matching block concept was so quickly removed from the draft.    I 
would like to keep the option of including a rule based block notion on 
the table for inclusion in the model.

a.

---

From: avri <[email-masked]>
Date: Tue, 26 Aug 2003 09:38:38 +0900

Hi Lily,

Thanks for the proposed changes. While I do believe that the details of
the  model of the asynchronous event notification and topology
realignment to support changes in virtualization will not be at all
straightforward, I do think your proposed changes to the framework doc
address the concern adequately.

thanks
a.

On torsdag, aug 21, 2003, at 06:14 Asia/Seoul, Yang, Lily L wrote:

> You are absolutely right that pre-association phase can be still
> on-going even in the post-assocaition phase. FE topology can change as
> a result of that. As long as ForCES can deal with asynchronous event
> notice from FE so that CE can be informed of such change, I don't see
> any real issue.
> It is also true, like you pointed out, that an external entity or FE
> virtualization can cause dynamic resource change on FE -- again, as
> long as FE model is flexible enough to allow and deal with such
> change, and CE can be informed of such change via ForCES, I think we
> are fine.
>
> [new] "If FE virtualization occur only in the pre-association phase,
> it has no impact on ForCES. However, if FE virtualization results in
> dynamic resource change on FE during post-associaiton phase, the FE
> model needs to be able to report such capability and the ForCES
> protocol needs to be able to inform the CE of such change via
> asynchrounous messages."
>
> [new] "When an FE leaves or join an existing NE that is already in
> post-association phase, the CE needs to be aware of the impact on FE
> topology and deals with the
> change accordingly. "
>

---

From: Alan DeKok <[email-masked]>
Date: Tue, 26 Aug 2003 11:08:47 -0400

> the table for inclusion in the model.

  That's what the "classifier" block is for.

  Alan DeKok.