Subject: Re: framework draft v07 uploaded to IETF

From: "Putzolu, David" <[email-masked]>
Date: Mon, 4 Aug 2003 08:40:40 -0700

Hi Jamal.

ForCES will run between CEs and FEs.  The decision
of actual hardware components used to construct the
CEs and FEs in a ForCES-compliant network element
is up to the implementer.  Building CEs and FEs using
general purpose processors is certainly a possible 
implementation.  One could even imagine building a 
FE and a CE on a single processor in separate 
processes using a localhost socket, which, while odd,
should not be precluded in ForCES.  This would be 
the ultimate "very close" scenario!

-David

> -----Original Message-----
> From: Jamal Hadi Salim [mailto:[email-masked]] 
> Sent: Monday, July 28, 2003 1:04 AM
> To: [email-masked]
> Subject: Re: [FORCES] framework draft v07 uploaded to IETF
> 
> 
> Alex,
> 
> If you dont have much processing horsepower, true.
> I have basic PPC 8245 on the line cards here(which may be 
> considered by some to be "powerful") and i think in a small setup i
should 
> be able to happily use them as a loosely coupled CE while the line
card fabric is
> used to forward packets.
> 
> I still need an answer: Is this out of scope for Forces? I think
> implicitly it is within. Am i correct?
> 
> cheers,
> jamal
> 
> On Mon, 2003-07-28 at 17:00, Alex Audu wrote:
> > Well,..normally the FEs are specialized for forwarding and 
> their hardware
> > requirements are quite different from those of CEs. In that 
> case, you
> > can't just make any FE into a CE.
> >
> > Regards,
> > Alex.
> >
> > Jamal Hadi Salim wrote:
> >
> > > Alex,
> > > Think of just a chasis with no dedicated CE module. Think of line
> > > cards each equipped with some embedded processors. You could use
> > > one of the line cards as a CE. You could infact split the CE work
> > > across several line cards etc. I think it is implict right now -
> > > i just wanted to make sure other people thought the same.
> > >
> > > cheers,
> > > jamal
> > >
> > > On Mon, 2003-07-28 at 13:01, Alex Audu wrote:
> > > > Yo Jamal,
> > > >
> > > > I don't understand what you are postulating here. Are 
> you saying you can
> > > >
> > > > make a CE out of an FE?
> > > >
> > > > Regards,
> > > > Alex.
> > > >
> > > > Jamal Hadi Salim wrote:
> > > >
> > > > > BTW, One other thing which i have assumed as implicit is
> > > > > that the FE and CE maybe located in the same device. Example
> > > > > two Line cards - each with its own CPU: In such a case you
> > > > > select one of them to be the CE (selection is beyond Forces).
> > > > >
> > > > > The architecture draft doesnt show this - although it 
> is clearly
> > > > > implicit. Need validation.
> > > > >
> > > > > cheers,
> > > > > jamal
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 4 Aug 2003 10:04:09 -0700

Hi David,

I realized afterwards the architecture allows it.
For completion sake, i was refering to "legacy" standalone,
typically 1U form factor, hardware based L2/3 switches - typically these
devices have a CPU and a switch fabric of sorts. CPU acts as the CE in
each of these standalone devices. I refered to them as line cards to
simplify the question.
If i put a rackmount of such devices Forces allows me to liberate them
from a management point of view.

cheers,
jamal

---

From: Tal Lavian <[email-masked]>
Date: Mon, 4 Aug 2003 15:49:52 -0700

Hi Jamal,

This is Tal Lavian from Nortel. I was following this work, however, now,
I'm up to new things.
How can I remove myself from this mailing list?

Tal

> > > > > > > implicit. Need validation.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Tal Lavian
Advanced Technology                Nortel Networks, Inc.
  http://www.nortelnetworks.com 4655 Great America Parkway,
Santa Clara, CA 95054-8185     Mail stop SC100-6B14
[email-masked]   Phone: (408) 495-3062