Subject: FW: Mailing list for BFD

From: "Putzolu, David" <[email-masked]>
Date: Thu, 14 Aug 2003 11:21:00 -0700

All,

BFD is an effort to rapidly detect faults in failures
between forwarding engines (name collision with forces:
they mean routers or switches here).  This has design
implications for ForCES FEs and also may be of general
interest to the ForCES community, so I'm forwarding 
the info for anyone who missed it.  Here's the relevant
draft:

http://www.ietf.org/internet-drafts/draft-katz-ward-bfd-00.txt

Cheers,
David

-------------------------

This is a forwarded message
From: Alex Zinin <[email-masked]>
To: Routing Area Mailing List <[email-masked]>
Cc: [email-masked]
Date: Wednesday, August 13, 2003, 5:17:55 PM
Subject: Mailing list for BFD

===8<==============Original message text===============
Folks-

 In order to continue the discussion on draft-katz-ward-bfd in
 an organized fashion, the following mailing list has been
 established:

   List name    : [email-masked]
   List URL     : https://www1.ietf.org/mailman/listinfo/rtg-bfd
   To subscribe : URL above or [email-masked]

 Interested participants are encouraged to subscribed to the list.
   
-- 
Alex
http://www.psg.com/~zinin/

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

===8<===========End of original message text===========

---

From: John Renwick <[email-masked]>
Date: Thu, 14 Aug 2003 14:45:40 -0500

David,

I don't think there's a name collision here.  The draft says (page 3):

   BFD is designed to detect failures in communication with a data plane
   next hop.  It is intended to be implemented in some component of the
   forwarding engine of a system, in cases where the forwarding and
   control engines are separated.  This not only binds the protocol more
   to the data plane, but decouples the protocol from the fate of the
   routing protocol engine....

So "forwarding engine" means a data plane element of a router or switch,
not the whole system.  The protocol itself could be implemented entirely
in the FE.  Link failover actions with O(milliseconds) response times
might also be handled by the FEs autonomously, with the CE being notified
(ForCES protocol here) after the fact.

Regards,

John

--
John Renwick                          Agere Systems
Software Technical Manager            1230 Northland Drive
Phone: (651) 675-2986                 Mendota Heights, MN 55120
FAX:   (707) 897-7928                 Cell:  (612) 669-9397
mailto:[email-masked]             http://www.agere.com

> -----Original Message-----
> From: Forwarding and Control Element Separation
> [mailto:[email-masked]]On Behalf Of Putzolu, David
> Sent: Thursday, August 14, 2003 1:21 PM
> To: [email-masked]
> Subject: FW: Mailing list for BFD
>
>
> All,
>