Subject: Re: FE Capabilities and attributes section of the model draft

From: "Putzolu, David" <[email-masked]>
Date: Mon, 19 Jan 2004 14:16:36 -0800

I just reviewed the document and had the following comments.

Cheers,
David 

General: Is there a good cross-platform tool for
browsing and validating the schema that anyone
can recommend?

General: I noticed a few spots where comments where 
included, that is, <!-- stuff like this -->.  Is
there some sort of annotation tag that can be used
to include comments on each attribute?  It would
be nice if the schema could be self-describing and
browsable with some nice graphical tool.

Line 5: The <xsd:annotation> tag here appears to not
  be matched anywhere, causing the document to be
  invalid.  

FEDocument attribute: Why is all capabilities and
attributes optional? Seems like mandating that providing
the information should be mandatory.

1.4.1 FECapabilities should all be mandatory. E.g.
every FE should be able to indicate whether it can
support modifiable topology or not. Actually, all 
the attributes I looked at should be mandatory.  
Having defaults is good, but requiring that the FE
explicitly say what capabilities it has reduces the
chance of hard-to-diagnose bugs due to an FE implementor
assuming the default was A when in fact it was NotA,
where the implementor didn't express the attribute due
to assuming the (unexpressed) default matches their
implementation.

1.4.2.2.4/5 The CanOccur approach says that LFBs
have particular other LFBs they can follow/precede.
Why not instead define LFB connectivity according to
the type of traffic on a LFBLink?  I.e. perhaps an IPv6
forwarder LFB would only be able to accept input
from other LFBs that output IPv6 traffic.   Perhaps
consider allowing both types of constraints to be
expressed.

1.4.3.4.1 What Neighbor does the NeighborID refer 
to? Neighboring CE (within a NE), Neighboring NE (within
a network), neighboring LFB (within an FE), or 
neighboring FE (within an NE)?

(end)

---

From: Alex Audu <[email-masked]>
Date: Mon, 19 Jan 2004 16:57:53 -0600

This the same question I have in mind. May be we can have a graphical
representation
of the FECapabilities and Attributes structure itself. This will give us
something to
correlate the XML structure with.

Regards,
Alex.