Subject: Re: ForCES protocol analysis design team - Report out !

From: "Putzolu, David" <[email-masked]>
Date: Thu, 25 Mar 2004 09:34:23 -0800

On Thursday, March 25, 2004 9:11 AM Jamal Hadi Salim wrote>
> I thought we delegated things to the TML.
> Whether the TML used UDP as long as it conformed to the requirements
> it should be a non issue. In other words i think there may be 
> more than one TML defined capable of running over IP.

We could define multiple, but they would all be required to
be RFC2914 compliant.

On Thursday, March 25, 2004 9:11 AM Jamal Hadi Salim wrote>
David Putzolu wrote> >
> > When the TML is not over IP (e.g. Ethernet TML?) a non-RFC2914
> > approach could be taken, although it should be noted that even
> > in those scenarios there is a lot of reasons for using a
> > congestion-aware protocol.  Congestion can appear even on a
> > one-hop link!
> 
> So the assumption is these packets cannot escape and cause problems
> elsewhere? What is the concern about UDP packets in particular
> that is not similar in using L2 only?

From what I recall of the conversations I had in Korea with
the ADs about transport/congestion control issues,
IP can always escape and further once IETF defines it for
IP, there was a concern that people would then (mis)use it in
non-guaranteed local applications.  L2 protocols on the
other hand will only escape if they are intentionally 
tunneled, and such tunnels are explicitly setup and
congestion managed.

-David

---

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 29 Mar 2004 09:27:42 -0500

> We could define multiple, but they would all be required to

Sure the TML has to be 2914 compliant - but not the specific protocols
underneath the TML.
In  my opinion there is no single transport at the IETF that meets all
the desires for transporting Forces transactions. So this is where idea
of the TML is a good one because at least it gets us off the food fight
of which transport protocol to use.

> tunneled, and such tunnels are explicitly setup and

Is the TTL field insufficient? As you noted with L2 protocols example,
you cant protect against stupidity (you could attempt it at the cost of
making things very expensive). DoSing is not related to L2 or using UDP
or TCP.

cheers,
jamal