Subject: Re: ForCES protocol analysis design team - Report out !

From: "Putzolu, David" <[email-masked]>
Date: Wed, 24 Mar 2004 11:56:40 -0800

Hi Robert - my replies inline.

Cheers,
David

On Wednesday, March 24, 2004 10:45 AM Robert Haas wrote>
Hormuzd wrote > >
> >Issue# 4 Congestion control:-
> >General consensus was that Congestion Control (CC) is a MUST for the
> >protocol for all messages, whether Control or Data in order 
> to meet the
> >basic scalability requirement. There was also some 
> discussion around DoS
> >protection in context with CC, but this is still being discussed.
> >Note: This issue will be further addressed in context with TML
> >
> It is indeed a MUST, but it is completely superfluous if 
> there is only 1 hop ... Do you see what I mean ?

Any time ForCES packets are carried on IP (i.e. in the IP
TML), they MUST use a RFC2914 transport - even if it is just
one hop.  This is due to the fact that one can never guarantee
that IP packets will actually stay on a single hop.  For
precedent, see iSCSI.  Note that this is what I was told by 
the transport & routing area ADs,  so please don't take it as 
me pushing a particular approach - I'm just the messenger :)

When the TML is not over IP (e.g. Ethernet TML?) a non-RFC2914
approach could be taken, although it should be noted that even
in those scenarios there is a lot of reasons for using a
congestion-aware protocol.  Congestion can appear even on a
one-hop link!

Cheers,
David

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 25 Mar 2004 12:11:25 -0500

> me pushing a particular approach - I'm just the messenger :)

I thought we delegated things to the TML.
Whether the TML used UDP as long as it conformed to the requirements
it should be a non issue. In other words i think there may be more than
one TML defined capable of running over IP.

> congestion-aware protocol.  Congestion can appear even on a

So the assumption is these packets cannot escape and cause problems
elsewhere? What is the concern about UDP packets in particular
that is not similar in using L2 only?

cheers,
jamal

---

From: Patrick Droz <[email-masked]>
Date: Fri, 26 Mar 2004 09:40:56 +0100

Hi David,

let me make one comment on this which I think some people
are confused. When we talk about 1 hop - what does this
actually mean? Does this mean one interface in, one
interface out (TTL -1). If it is just box internal it is
only CP to FE which would not make a TTL -1 so this is
only 1/2 hop.

Regards,
Patrick

-- 
   Dr. Patrick Droz 			| [email-masked]
   IBM Zurich Research Laboratory 	| http://www.zurich.ibm.com/~dro
   Saumerstrasse 4 			| Tel. +41-1-724-85-25 CH-8803
   Rueschlikon/Switzerland 		| Fax. +41-1-724-85-78

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 26 Mar 2004 13:22:47 -0500

Actually, if we choose to use IP for to carry our control messages (as I
hope we will) the TTL should be decremented as it departs the CE.  Even if
the delivery target is inside the box.  Doing otherwise is an invitation to
trouble.

Yours,
Joel