Subject: Revised LFB input/output text

From: Zsolt Haraszti <[email-masked]>
Date: Wed, 14 Apr 2004 18:15:39 -0400

After the dissemination of the last model draft in February
(draft-ietf-forces-model-02.txt), we got many very useful
comments.  Thanks.  One topic that generated lots of questions
was the concept of LFB inputs and outputs.  It became obvious
to us that in 02 we did not do a good job explaining the proposed
LFB input/output model.

Attached is a fully revised version of the relevant subsections
of 02 (3.2.1 and 3.2.2).  Hopefully this text conveys the design
intent much better.

Comments are welcome!

--
Zsolt Haraszti, Ph.D.                              Tel: +1 919 472 9949
Ericsson IP Infrastructure                         Fax: +1 919 472 9999
Raleigh NC USA                       Email: [email-masked]

---

From: "Putzolu, David" <[email-masked]>
Date: Tue, 20 Apr 2004 15:54:17 -0700

Hi Zsolt.

This looks much better and makes sense to me now.

Minor nit: Should be ragged-right justification when
it is actually added to the model draft.

Cheers,
David

> -----Original Message-----
> From: Forwarding and Control Element Separation 
> [mailto:[email-masked]] On Behalf Of Zsolt Haraszti
> Sent: Wednesday, April 14, 2004 3:16 PM
> To: [email-masked]
> Subject: [FORCES] Revised LFB input/output text
>

---

From: "Cain, Gamil" <[email-masked]>
Date: Thu, 22 Apr 2004 09:16:04 -0700

Zsolt,

Finally getting around to reviewing this text.  It is much improved!!!
Thanks.

Just a clarification.  The concept of a group is really used to allow
certain variance in the *instantiations* of a particular LFB class.  An
instantiation of a particular LFB class may (or may not) only set
certain upper and lower bounds on the number of ports contained in a
group, via it's attributes.  The group concept does not allow an
instantiation of a class to dynamically grow/shrink the number of ports
in an output group beyond what can be specified by it's attributes.  Is
this a correct understanding?

Along the same lines, there is a sentence in the text that states:

"The number  of  actual input instances in the group is an attribute of
the LFB  class, which is  read-only  for  static  topologies,  and  it
is  read-write for configurable topologies."

Shouldn't that say the input instances in the group are an attribute of
an *instance* of an LFB class?

Regards,

Gamil.

Gamil Cain
Software Architect
Intel Research & Development
916.356.9153
mailto:[email-masked]

>Subject: Revised LFB input/output text
>

---

From: "Yang, Lily L" <[email-masked]>
Date: Thu, 22 Apr 2004 17:50:19 -0700

See below for my own understanding. I am sure Zsolt will correct me if I get it wrong.

> [mailto:[email-masked]]On Behalf Of Cain, Gamil
> Sent: Thursday, April 22, 2004 9:16 AM
> Subject: Re: Revised LFB input/output text
> 
> 
> Zsolt,
> 
YES.
> an *instance* of an LFB class?
YES.