Subject: I-D ACTION:draft-ansari-forces-discovery-00.txt

From: Furquan Ansari <[email-masked]>
Date: Wed, 14 Jul 2004 17:29:22 -0400

http://www1.ietf.org/mail-archive/web/i-d-announce/current/msg01304.html

--
Furquan Ansari
Bell Labs Research                      Ph : 732-949-5249
Holmdel, NJ                             Fax: 732-949-4556

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

I-D ACTION:draft-ansari-forces-discovery-00.txt

To: i-d-announce at ietf.org

Subject: I-D ACTION:draft-ansari-forces-discovery-00.txt

From: Internet-Drafts at ietf.org

Date: Wed, 14 Jul 2004 15:27:39 -0400

List-help: <mailto:[email-masked]?subject=help>

List-id: i-d-announce.ietf.org

List-post: <mailto:[email-masked]>

List-subscribe: <https://www1.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=subscribe>

List-unsubscribe: <https://www1.ietf.org/mailman/listinfo/i-d-announce>, <mailto:[email-masked]?subject=unsubscribe>

Reply-to: internet-drafts at ietf.org

Sender: i-d-announce-bounces at ietf.org

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title : ForCES Element Bindings and Topology Discovery Protocol
Author(s) : F. Ansari, et al.
Filename : draft-ansari-forces-discovery-00.txt
Pages : 15
Date : 2004-7-14

This document describes a protocol for dynamically determining CE/FE
element bindings discovery and inter-FE topology discovery and
maintenance. Such a mechanism is needed for all these elements in
the set to behave as a single network element, as required by the
ForCES architecture. The discovery protocol operates during both the
pre-association and post-association phases of ForCES protocol.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ansari-forces-discovery-00.txt

To remove yourself from the I-D Announcement list, send a message to
i-d-announce-request at ietf.org with the word unsubscribe in the body of the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
"get draft-ansari-forces-discovery-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
mailserv at ietf.org.
In the body type:
"FILE /internet-drafts/draft-ansari-forces-discovery-00.txt".

NOTE: The mail server at ietf.org can return the document in
MIME-encoded form by using the "mpack" utility. To use this
feature, insert the command "ENCODING mime" before the "FILE"
command. To decode the response(s), you will need "munpack" or
a MIME-compliant mail reader. Different MIME-compliant mail readers
exhibit different behavior, especially when dealing with
"multipart" MIME messages (i.e. documents which have been split
up into multiple messages), so check your local documentation on
how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

<ftp://ftp.ietf.org/internet-drafts/draft-ansari-forces-discovery-00.txt>

_______________________________________________
I-D-Announce mailing list
I-D-Announce at ietf.org
https://www1.ietf.org/mailman/listinfo/i-d-announce

Prev by Date:
I-D ACTION:draft-choi-pce-e2e-centralized-restoration-srlg-00.txt

Next by Date:
I-D ACTION:draft-doria-forces-protocol-01.txt

Previous by thread:
I-D ACTION:draft-choi-pce-e2e-centralized-restoration-srlg-00.txt

Next by thread:
I-D ACTION:draft-doria-forces-protocol-01.txt

Index(es):

Date

Thread

Note: Messages sent to this list are the opinions of the senders and do not imply endorsement by the IETF.

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Wed, 21 Jul 2004 13:52:23 -0700

Hi Folks,

We would appreciate any comments, suggestions on this draft

Thanks
Hormuzd 

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Furquan Ansari
Sent: Wednesday, July 14, 2004 2:29 PM
To: [email-masked]
Subject: [FORCES] I-D ACTION:draft-ansari-forces-discovery-00.txt

---

From: Alex Audu <[email-masked]>
Date: Sat, 31 Jul 2004 11:10:18 EDT

Hi Furquan and Hormuzd,

I made a quick read of this draft a few hours ago, and these are my comments:

1) Generalyy, I like the draft, but it needs to define or be aware of
interaction with
    the ForCES-pl. By that, I mean, forces-pl has topology-request messages,
and how
    this plays with the protocol you are prosposing needs to be stated
clearly.

2) How does the protocol react when FEs are removed by management with FE-DOWN
    request messages?  I would expect a graceful reaction. It shouldn't go
lunch an
    asynchronous report of neighbor unreachability to the CE, since CE
already is aware of
    the removal.

3)  This thing is going to be sending neighbor-hello messages. It will be
nice to ensure
     such messages are not too frequent; FE outage and removal is dectected
and reported
     to the CE by the protocol/transport layers already.

4) One of the proposed features of the protocol is to:
     "   . Determine respective element capabilities"
    This function is already done by  forces-pl. Why duplicate it here?

5)  I am not sure I understand the state machine,..it is missing most of the
transition
     trigger events, and the available transitions don't seem to be
transiting from the
     appropriate states.
     For example, what drives transition from  NO_BINDING state to the
pseudo-state
     where hello messages are exchanged? It looks like the "loss of
association" event
     should transit from DISCOVERY state.

Thanks,
Alex.

In a message dated 7/21/2004 3:54:49 PM Central Standard Time,
[email-masked] writes:
Hi Folks,

Thanks
Hormuzd