Subject: Re: Event Generation Conditions

From: "Putzolu, David" <[email-masked]>
Date: Thu, 12 Jan 2006 16:46:25 -0800

I wonder could a specific LFB be design to support this, 
perhaps being metadata based?

E.g. write a LFB definition that has all sorts of knobs 
for timers, and is driven by metadata being fed into it. 
Then one could use a classifier LFB to feed metadata to
the "timer LFB", which would then generate the desired
events.  Those FEs that do not have the required complex
timer capabilities would simply not expose the LFB in 
question.

-David

P.S.  I guess you where referring to something similar with
the ICMP rate limiter idea,  although I was thinking of a
specific programmable "metadata that generates events" LFB.

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Thursday, January 12, 2006 3:54 PM
To: [email-masked]
Subject: [FORCES] Event Generation Conditions

The current draft of the model provides for simple event detection
conditions.
It also provides for optional hysteresis to suppress repeated generation
of 
events.

Jamal has asked for a combined duration / count condition which will 
generate the event notification if either the event occurs enough times,
or 
enough time passes since the last generation.

While he and I disagree as to the need for this, what really matters
here 
is what the rest of the working group thinks.

My concern is that this support will require more complex timer 
capabilities in the FE.
Jamal feels the capability has more value than the complexity.

Does anyone else care?

As the old song goes, "is anybody there?"

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 12 Jan 2006 19:55:58 -0500

Yes, the alternative to adding this capability to events is that folks who 
have specific need for information with this property can use LFBs (one or 
more) to produce and limit the delivery of meta-data through the redirect 
channel.

Yours,
Joel

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 13 Jan 2006 09:45:38 -0500

> more) to produce and limit the delivery of meta-data through the redirect 

I think going into some metadata LFB only for certain events (but having
all other attributes defined some other way) is overboard almost to
implementation details.

We dont need to define timers that work with these events just a
spec that defines time. 

Folks, this is a real generic requirement to scale events. 

cheers,
jamal