Subject: Need Help ! (ForCES for my MSc dissertation)

From: Abid Ghufran <[email-masked]>
Date: Mon, 16 Jan 2006 17:17:48 -0500

Dear All,

I am doing MSc in High Speed Networks and Distributed Systems, from Oxford
Brookes University UK. For my dissertation I intend to take "something from
 the" ForCES protocol.

After going through the standard documents on this protocol, I have found it
very interesting and am therfore thinking of finally deciding for it. There
is a condition for my dissertation, that it should involve both networking
and programming related to distributed systems. I have found the ForCES
concept to be covering both of these requirements. But before I finally
decide, I would like some advise from the people on this list.

1) I have found that the protocol concept has a very extensive and a wide
scope. I shall only be having 3 months for my dissertation. Of all the
elements included in this concept of ForCES protocol, which aspect should be
mose suitable for my dissertation? In simple words there are many things
involved in the ForCES, which of them should I aim at, for my dissertation?

2) Can I consider this protocol as similar to an out-of-band signalling
model for coordination between the CE, FE and LFBs?

3) I feel that this concept will see prevalent usage in the networking
field. What do you think?

4) Are there any vendors thinking or planning to incorporate this concept?

5) What kind of language platform/functionality would be deemed suitable for
the implementation of this protocol?

6) Is it possilbe to study/analyze the protocol by simulating it? Which of
its aspect could be simulated?

I shall be most grateful if you could help me in this regard.

Thank you very much,

Abid Ghufran.

---

From: Alex Audu <[email-masked]>
Date: Wed, 18 Jan 2006 11:15:38 -0500

Hello Abid,
 
One possible approach to take is to start from the basic premise of FORCES. What were the driving forces behind ForCES model?  Some of them are:
1) Complexity of NEs as they try to cope with increasingly demanding features like policy based
    routing, firewalls, NATS, QoS-aware routing,..etc.   How does the ForCes model help in managing
    such complexity growth?  
 
2) Scalability:  The ability to cost-effectively grow a network as demand increases
 
3) Programmability: The ability to dynamically program the network for some specific services by
    programming the NEs to handle those services explicitly.
 
4) Security:  This is becoming increasingly important. What are the mechanisms in place in ForCES
    to help bolster network security?
 
5) Reliability: Service reliability is crucial in a globally networked world.  What mechanisms does
    the ForCES model provide to ensure uninteruptible service?
 
Any of these topics can be studied, and put to test with a software model.   I am not sure how
much tangible work can be done in the three months you have alloted to the project though.
 
Cheers,
Alex.
www.garlandsoftworx.com

-----Original Message-----
From: Abid Ghufran <[email-masked]>
To: [email-masked]
Sent: Mon, 16 Jan 2006 17:17:48 -0500
Subject: Need Help ! (ForCES for my MSc dissertation)

Dear All,

Thank you very much,

Abid Ghufran.