Subject: Re: [forces] LFB lib 05 version comments #1

From: "Chuanhuang Li" <[email-masked]>
Date: Fri, 23 Sep 2011 10:46:26 +0800

Hi,Jamal and Joel

>b) InvalidIPv4SrcAddrCasexxx
>I believe there are proper terms for these terms. Can we find
>the proper terms and replace these generic terms?
>Example appropriate terms are "martian" and "bogon" packets.
Forgot dealing with this issue, sorry.
There are many error cases which are revalent to the invalid source or 
destination address.  "Martian" and "Bogon" terms are not enough to 
differentiate them. I propose we simplify the definition of these errors.
We just generalize them in two classes: InvalidDstAddr, InvalidSrcAddr.
That is, we only define two ValidateErrorID to describe these error cases.

The same as ValidateErrorID. There are many execption cases which are revalent to 
the source or destination address.  
We simplify the definiton: DstAddrException, SrcAddrException

What's your opinion?

Yours,
Chuanhuang

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 23 Sep 2011 11:17:04 -0400

Hi Chuanhuang,

If nothing matches in any IETF terminology then I am fine with the
suggestion.

cheers,
jamal

---

From: "Chuanhuang Li" <[email-masked]>
Date: Tue, 27 Sep 2011 10:11:19 +0800

Hi, all

ok, the cases of ExecptionID and ValidatErrorID will be simplifed as follows.
The text in section 5.2.1.1 and 5.2.2.1 need to be modified accordingly,
and I will modify the XML file and section 10.4.

IPv4Validator LFB
  Execption:
  o Packet with expired TTL
  o Packet with header length more than 5 words
  o Packet IP head including Router Alert options
  o Packet with exceptional source address
  o Packet with exceptional destination address

   ValidateError:
   o Packet size reported is less than 20 bytes
   o Packet with version is not IPv4 
   o Packet with header length < 5
   o Packet with total length field < 20 
   o Packet with invalid checksum
   o Packet with invalid source address 
   o Packet with invalid destination address 

IPv6Validator  LFB
    Execption:
	o Packet with hop limit to zero
	o Packet with next header set to Hop-by-Hop
	o Packet with exceptional destination address
	o Packet with exceptional source address

    ValidateError:
    o Packet size reported is less than 40 bytes
    o Packet with version is not IPv6 
    o Packet with invalid source address 
    o Packet with invalid destination address

Yours,
Chuanhuang

======= 2011-09-23 23:15:20 Jamal Hadi Salim, wrote: =======

---

From: "Wang,Weiming" <[email-masked]>
Date: Wed, 28 Sep 2011 11:24:33 +0800

Chuanhuang, 
I'v updated the text accordingly with some modifications in the words. Pls checek to make some changes. Moreover, pls provide text changes to me on Section 10 IANA accordingly.

thks,
Weiming

----- Original Message ----- 
From: "Chuanhuang Li" <[email-masked]>

  o Packet with header including Router Alert option

>   o Packet with invalid destination address 

   o Packet with size reported less than 20 bytes
   o Packet with not IPv4 version 
   o Packet with header length < 5
   o Packet with total length field < 20 
   o Packet with invalid checksum
   o Packet with invalid source address 
   o Packet with invalid destination address

>    o Packet with invalid destination address

    o Packet with size reported less than 40 bytes
    o Packet with not IPv6 version
    o Packet with invalid source address 
    o Packet with invalid destination address