Subject: Re: [forces] comments #15

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 1 Sep 2011 21:35:55 +0800

Chuanhuang, pls provide response.

Weiming

----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>

>I brought this concern in version 4 of the draft and i got agreement
> to fix it. I am worried there are other things of the same nature.
> Please make sure you update everything we agree on so we dont have
> the same discussions again.
> VlanInputTableEntryType defines VLANID as 32bit.
> We need to typedef the VLANID appropriately.
> 
> cheers,
> jamal
>

---

From: "Chuanhuang Li" <[email-masked]>
Date: Fri, 2 Sep 2011 22:30:29 +0800

Hi, Jamal
    If i have lost something, pls remind me, sorry. 
It seems we hadn't got an agreement on this issue. You just say "The VlanID type looks wrong." 
in the ee-suggested.txt.
Do you mean the VlanID shouldn't be defined as "uint32", and should be defined to 12 bits?
I think we use "uint32" is enough, and 12 bits type is difficult to define.
 
Yours,
Chuanhuang

======= 2011-09-01 21:34:43 Wang,Weiming, wrote: =======

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 2 Sep 2011 13:49:08 -0400

Chuanhuang,

Yes, I meant the VlanID shouldn't be defined as "uint32".

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 2 Sep 2011 15:31:23 -0400

Chuanhuang,

To be precise, something like this in the base types:

<dataTypeDef>
     <name>vlanid</name>
     <synopsis>The VLAN ID</synopsis>
     <atomic>
      <baseType>uint16</baseType>
      <rangeRestriction>
       <allowedRange min="0" max="4095"/>
      </rangeRestriction>
     <defaultValue>0</defaultValue>
    </atomic>
   </dataTypeDef>

cheers,
jamal

---

From: "Chuanhuang Li" <[email-masked]>
Date: Sat, 3 Sep 2011 09:01:57 +0800

Hi,Jamal
   ok, it makes sense. We can use “allowedRange” tag to 
constrain the value. I'll modify the definition in XML.  At the same time, 
the type of VLAN priority is also modified. Thanks!

      <dataTypeDef>
         <name>VlanIDType</name>
         <synopsis>The type of VLAN ID</synopsis>
         <atomic>
         <baseType>uint16</baseType>
           <rangeRestriction>
              <allowedRange min="0" max="4095"/>
            </rangeRestriction>
         </atomic>
         <defaultValue>0</defaultValue>
       </dataTypeDef>
       <dataTypeDef>
         <name>VlanPriorityType</name>
         <synopsis>The type of VLAN priority.</synopsis>
         <atomic>
         <baseType>uint8</baseType>
           <rangeRestriction>
              <allowedRange min="0" max="7"/>
            </rangeRestriction>
         <defaultValue>0</defaultValue>            
         </atomic>
      </dataTypeDef> 

Yours,
Chuanhuang	

======= 2011-09-03 03:30:23 Jamal Hadi Salim, wrote: =======

---

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 22 Sep 2011 21:05:53 +0800

Chuanhuang,

Pls make sure this issue can be closed and there is no need of modification other than XML file.

thks,
weiming

----- Original Message ----- 
From: "Chuanhuang Li" <[email-masked]>

Hi,Jamal
   ok, it makes sense. We can use "allowedRange" tag to 
constrain the value. I'll modify the definition in XML.  At the same time, 
the type of VLAN priority is also modified. Thanks!

      <dataTypeDef>
         <name>VlanIDType</name>

Yours,
Chuanhuang 

>>>>> We need to typedef the VLANID appropriately.
_______________________________________________
forces mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/forces

---

From: "Chuanhuang Li" <[email-masked]>
Date: Fri, 23 Sep 2011 10:00:50 +0800

Yes, there is no need of modification in text.

Yours,
Chuanhuang

======= 2011-09-22 21:03:43 Wang,Weiming, wrote: =======