Subject: [forces] comments on EtherClassifier output port

From: "Chuanhuang Li" <[email-masked]>
Date: Thu, 1 Sep 2011 15:11:40 +0800

Hi, All
    We need add an LFB port in EtherClassifier to output the packets 
which can't be classified. They can be processed in other LFB or 
redirected to CE. Joel agree with me on this suggest. 
His opinion, this LFB port can be named "noMatchingClassification".

Joel, but I think, similar to other LFBs, it is best named "ExceptionOut". We 
can use ExceptionID to describe the packets' status, so CE can know 
how to process them.

Yours,
Chuanhuang

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 01 Sep 2011 10:00:56 -0400

I can live with treating it as an exception, and using ExceptionOut.
Yours,
Joel

---

From: "Chuanhuang Li" <[email-masked]>
Date: Fri, 2 Sep 2011 22:00:21 +0800

Hi, All
    As an conclusion,  i list the port definiton of EtherClassifier. We add an output port 
named "ExceptionOut".

Inputs:
EtherPktsIn,  single input
frameExpected: Arbitrary
metadataExpected: PHYPortID, LogicalPortID (optional, defaultValue:0)  
 
Outputs:
ClassifyOut,  group output
frameProduced: Arbitrary
metadataProduced: PHYPortID, EtherType, SrcMAC, DstMAC, LogicPortID, VlanID (availability="conditional"), VlanPriority (availability="conditional") 

ExceptionOut, single output
frameProduced: Arbitrary
metadataProduced: ExceptionID    
/*ExceptionID Type. 
     o There are no mathing in classification.
*/

The text can be modified according this definition in Data handling section. 

Yours,
Chuanhuang

======= 2011-09-01 22:00:09 Joel M. Halpern, wrote: =======

---

From: "Wang,Weiming" <[email-masked]>
Date: Mon, 19 Sep 2011 21:35:38 +0800

A paragraph is added for the exception output as below, pls respond if any question, or the issue is closed.

----Section 5.1.3.1.---------
...
The second output is a singleton output port known as "ExceptionOut",   which will output packets for which the data processing failed, along with an additional ExceptionID metadata to indicate what caused the exception. Currently defined exception types include: 
o There is no matching when classifying the packet.
Usually the exception out port may point to no where, indicating packets with exceptions are dropped, while in some cases, the output may be pointed to the path to the CE for further processing, depending on individual implementations. 
----------------

thanks,
Weiming

----- Original Message ----- 
From: "Chuanhuang Li" <[email-masked]>