Subject: [forces] general comments

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 26 Sep 2013 12:30:20 -0400

One last thing Evangelos

- Can you add xml examples for each section where you are proposing
changes? It makes it easier to visualize
- run spell checker
- section 3.1 I got lost in the need for a content key. Can you give me an
example of where this is useful?
- I think your schema at the end of the doc is valid, but for example
fig 4 and 5 use of "D/defaultValue" do not imply to the same thing.
In general if, as we normally do, you validate the schema then we would
be fine.
- For the stats properties you enumerate in section 3.6; could you remove
from the name "From/ToCE" for future-proofness? You can just say the
stats are from a point of view of a CE (in which case "received" would
imply "received from CE")

cheers,
jamal

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 27 Sep 2013 01:31:02 +0300

Greetings Jamal,

Thank you very much for all the comments (for this and the other emails), I
will incorporate required changes for the next version.

In regards to the keys, they are only there for XML validation purposes
using the schema. Not for writing the LFB Library itself.
Therefore since we now allow arrays, the first key specifies that you won't
have two equal values for content keys for the array and the second will not
allow the same component ID for struct components.
I borrowed the array definition from the previous XML schema.

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jamal Hadi Salim
> Sent: Thursday, September 26, 2013 7:30 PM
> To: Evangelos Haleplidis
> Cc: [email-masked]
> Subject: [forces] general comments
> 
> One last thing Evangelos
> 
> - section 3.1 I got lost in the need for a content key. Can you give me
> an example of where this is useful?
> - For the stats properties you enumerate in section 3.6; could you
> remove from the name "From/ToCE" for future-proofness? You can just say
> the stats are from a point of view of a CE (in which case "received"
> would imply "received from CE")
> 
> cheers,
> jamal
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sat, 28 Sep 2013 13:44:26 -0400

Evangelos,

Thanks - that clarifies it for me.

cheers,
jamal