Subject: [ftpext] draft-peterson-streamlined-ftp-command-extensions

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Sun, 28 Nov 2010 18:40:55 +0900

Hi,

> DSIZ command

If a directory specified in DSIZ command contains symbolic links,
does this command calculate linked target file, or just size of a
symbolic link file itself?

Also, if a symbolic link 'foolink' which links to directory foo is
given in DSIZ command,
does server returns 550 error because it is not directory?

>DSIZ command should not consider this in its response, instead
> leaving it up to the underlying file system to determine the number
> of octets occupied by the files.

About phrase "the number of octets occupied by the files":
Some file systems(e.g. ext4) supports sparse file, and
space that those files actually occupy are sometimes much more smaller than
 'ls' shows its file size. For those files, does DSIZ return the octets occupied
by the files? I think if the user use DSIZ instead of recursive SIZE command,
they want file size normally shown by 'ls', not occupied octets in file system.

Sorry if this has been discussed already.

Best regards,

Tatsuhiro Tsujikawa

---

From: "Mark P. Peterson" <[email-masked]>
Date: Mon, 29 Nov 2010 09:05:54 -0600

Hi Tatsuhiro,

Thank you for replying.

> symbolic link file itself?

That's an implementation decision for the server.  It can go either way, 
and could be configurable by the server administrator.

> given in DSIZ command, does server returns 550 error because
> it is not directory?

This is also an implementation decision that could go either way.

> About phrase "the number of octets occupied by the files":...

It is the actual number of bytes in the files, not the number of
bytes used by the underlying OS.

Mark P. Peterson - President
http://www.RhinoSoft.com
Voice: +1(262) 560-9627
FAX: +1(262) 560-9628  

--------------------------------------------------
From: "Tatsuhiro Tsujikawa" <[email-masked]>
Sent: Sunday, November 28, 2010 3:40 AM
To: <[email-masked]>
Subject: [ftpext]  draft-peterson-streamlined-ftp-command-extensions

Hi,

Best regards,

Tatsuhiro Tsujikawa
_______________________________________________
ftpext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ftpext