Subject: [ftpext] RFC 2640

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 22 Dec 2010 00:04:42 +0100

Hi,

We're having a discussion on how the FTP64 ALG should support RFC 2640, which allows clients and servers to negotiate a language for the free text that the FTP server sends to the client.

My opinion is that it would be ok for the ALG to create text in the default language (presumably English) even if the client and server negotiate another language. Another solution would be to block such negotiations but I don't like this extra complexity and I'm not sure that having the server's text in a non-preferred language for consistency with the ALG's text helps the user.

My questions:

- are there any RFC 2640-compliant implementations out there?

- anyone have a problem with moving RFC 2640 to historic?

Iljitsch

---

From: "TJ Saunders" <[email-masked]>
Date: Tue, 21 Dec 2010 15:42:36 -0800 (PST)

> - are there any RFC 2640-compliant implementations out there?

Yes.  ProFTPD, when built with NLS support, implements RFC 2640.

Cheers,
TJ

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

   Much of your pain is self-chosen.

     -Kahlil Gibran

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~