Subject: Re: [ftpext] Fwd: [BEHAVE] Last Call: <draft-ietf-behave-ftp64-10.txt> (An FTP ALG for IPv6-to-IPv4 translation) to Proposed Standard

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 27 Jun 2011 15:35:00 +0200

On 24 mei 2011, at 11:30, Iljitsch van Beijnum wrote:

> FYI: the BEHAVE FTP64 draft is now in IETF last call.

One comment that I got was:

> The document does not mention or discuss LPRT and LPSV. Is that intentional?
> The IANA registry says these are now obsolete, but RFC1639 is still
> experimental and no document has (formally) obsoleted these.

RFC 1639 is an experimental RFC from 1994: "FTP Operation Over Big Address Records (FOOBAR)". It predates IPv6 and thus predates RFC 2428 which has this to say:

   RFC 1639 [Pis94] specifies
   extensions to FTP to enable its use over various network protocols.
   Unfortunately, the mechanism can fail in a multi-protocol
   environment.  During the transition between IPv4 and IPv6, FTP needs
   the ability to negotiate the network protocol that will be used for
   data transfer.

I have to admit that I was unaware of RFC 1639, and to my knowledge there are no (surviving) implementations. Or does anyone know of any?

Iljitsch

---

From: Daniel Stenberg <[email-masked]>
Date: Mon, 27 Jun 2011 15:59:29 +0200 (CEST)

On Mon, 27 Jun 2011, Iljitsch van Beijnum wrote:

> I have to admit that I was unaware of RFC 1639, and to my knowledge there 
> are no (surviving) implementations. Or does anyone know of any?

curl used to support LPRT and family out of some idea of correctness but since 
we basically never saw a server support them and EPRT/EPSV were supported we 
removed support of the RFC 1639 commands again already back in January 2006...

-- 

  / daniel.haxx.se

---

From: "William F. Maton" <[email-masked]>
Date: Mon, 27 Jun 2011 10:13:03 -0400 (EDT)

On Mon, 27 Jun 2011, Daniel Stenberg wrote:

> curl used to support LPRT and family out of some idea of correctness but 
> since we basically never saw a server support them and EPRT/EPSV were 
> supported we removed support of the RFC 1639 commands again already back in 
> January 2006...

These are still supported for wu-ftpd, but like curl, EPRT/EPSV are 
favoured for a long time now.

wfms