Subject: Re: [fun] status of the homenet effort

From: Robert Raszuk <[email-masked]>
Date: Fri, 01 Jul 2011 13:45:49 +0200

While rereading the proposed charter I have two questions ..

1. Is documentation or new tools specification development for home 
network troubleshooting either manual or automated in or outside of 
charter ? How about diagnostics in reachability to internal subnets or 
different hosts on the internet ?

2. How about multihoming with seamless switchover ?

I think those will make home networking a bit easier ?

---

Example for 1: What happens if I can ping/trace a destination, browse 
it's web site just fine, but my cgi script dies ? And I have a real case 
like this which honestly I am not sure how to troubleshoot. Server side 
reports no errors at all in the log. MTU is low as it can be.

/* Well I found the solution but will not say it on this list as I am 
afraid Jari and Mark will unsubscribe me ;-) */

Cheers,
R.

---

From: Mark Townsley <[email-masked]>
Date: Fri, 1 Jul 2011 14:19:12 +0200

On Jul 1, 2011, at 1:45 PM, Robert Raszuk wrote:

> 1. Is documentation or new tools specification development for home network troubleshooting either manual or automated in or outside of charter ? How about diagnostics in reachability to internal subnets or different hosts on the internet ?

That's a pretty broad question. Let me try and answer. 

There is a prevailing notion that the home network must work well in a "not actively managed" manner. So if we met our goal perfectly, we'd need no troubleshooting or diagnostics tools. The world isn't perfect though, and where tools and such are necessary I'm sure they will spring up. I don't see these specifically as major deliverables for homenet though. 

Note that protocols themselves, in particular auto-configuration and such, are by their nature doing "automatic trouble-shooting" in one form or another, and in terms of "reachability" IPv6 has NUD built right in at least for within the home. So, in as much as this is part and parcel for the protocol to work in an "automatic" and "not actively managed" manner, sure, homenet has that. If you mean defining a "home network management" application? No, I don't think we're going there.  I could imagine a homenet-ops or some such in the future, or as part of v6ops now, that could develop these more though. 

> 2. How about multihoming with seamless switchover ?

This particular elephant has been in and out of various versions of the charter. I'll plead the 5th on this one and ask Jari to describe where we are on this, in particular in relation to mif, shim6, lisp, rrg, v6ops, or any of the other areas that are touching on this. 

Personally, I think it would be naive to not include the various possibilities of multihomed connectivity, at the vary least in describing the architecture for which we will work within. I don't think homenet is the place to solve the general issue of "seamless multihoming" at the protocol level, but perhaps we would point to what works well in a home setting... we might even agree to one way to do it if we are really, really, lucky. 

> Example for 1: What happens if I can ping/trace a destination, browse it's web site just fine, but my cgi script dies ? And I have a real case like this which honestly I am not sure how to troubleshoot. Server side reports no errors at all in the log. MTU is low as it can be.
> 
> /* Well I found the solution but will not say it on this list as I am afraid Jari and Mark will unsubscribe me ;-) */

I doubt that. 

- Mark

> 
> Cheers,
> R.
> _______________________________________________
> fun mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fun

---

From: Jari Arkko <[email-masked]>
Date: Fri, 01 Jul 2011 23:48:12 +0200

Robert,

Thank you for very interesting questions.

As Mark noted, some aspects of diagnostics and troubleshooting are 
inherent in the notion of automatic configuration. Prefix delegation, 
routing, etc. has to figure out if there is connectivity and what to do 
if there isn't. But its mostly automatic, not built for human network 
managers to play with.

Maybe the answers to your question are clearer once we have completed 
the architecture work. Maybe there are some additional diagnostics 
needs, but at this point I'll admit that I don't see them.

Whereas...

> Personally, I think it would be naive to not include the various possibilities of multihomed connectivity, at the vary least in describing the architecture for which we will work within. I don't th…

I think multihoming solutions should be out of scope. Not because they 
are uninteresting, they're not -- they are very important. And I know 
there are specific requirements for it in some home network cases. But 
it is a very complex and challenging topic by itself, and one where we 
have multiple IETF workings groups already. I agree with Mark though 
that we may point to some solutions and think about this during the 
architecture work, but even there I'd be a bit careful not to taken on 
too ambitious tasks.

Jari

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 02 Jul 2011 00:14:52 +0200

Hi Jari,

> if there isn't. But its mostly automatic, not built for human network

Well honestly while I agree that automation is great for vast majority 
of home networks, unfortunately for someone like me it is just scary - 
maybe too scary. If I buy or rent a car I always pick manual ... (maybe 
wrong comparison maybe not ... but it is just a matter of awareness of 
one's skills of control).

> I think multihoming solutions should be out of scope.

Maybe I was not sufficiently precise. I am not asking to roll-out new 
models of PIC or active/active load balancing for home networks.

I am just trying to see a room for a spec which would define what should 
be the CPE behaviour when someone connects two DSL/Cable/Mixed lines to 
it. I hope we would not prohibit it ... and if not the behaviour needs 
to be either defined here or referenced as Mark mentioned earlier to 
other documents which solve this already.

Many thx,
R.

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 3 Jul 2011 16:22:22 -0700

On Jul 1, 2011, at 3:14 PM, Robert Raszuk wrote:

> Well honestly while I agree that automation is great for vast majority of home networks, unfortunately for someone like me it is just scary - maybe too scary. If I buy or rent a car I always pick manual ... (maybe wrong comparison maybe not ... but it is just a matter of awareness of one's skills of control).

If it doesn't work without intervention by the user, then the solution adopted by the vendor will  definitely not be compliant with the specification. The condition of not requiring intervention is essentially cooked in the the commercial acceptance of products in the space.