Subject: [Geojson] Drop all CRS? (Tracker issue #94)

From: Sean Gillies <[email-masked]>
Date: Thu, 7 Jan 2016 15:55:32 -0700

We're so close to closing open tickets in the tracker! I'm bringing #94 to
the list to kick off 2016.

In https://github.com/geojson/draft-geojson/issues/94, it is suggested that

> Relative to https://www.ietf.org/id/draft-butler-geojson-06.txt
>
> Section 6.3 and 6.3
>
> As the original
> http://geojson.org/geojson-spec.html#coordinate-reference-system-objects
> is dropped from the internet draft - I am not sure why these sections
> cannot be simplified to simply stating that any and all coordinates are to
> be in EPSG:4326.
>
> Or alternatively - to introduce these - but do so wholesale and as a first
> class citizen (and allowing variant/attributed coordinates); with absence
> denoting EPSG:4326
>
I would love to drop all CRS other than the default (CRS84, to be precise,
not EPSG:4326) and have proposed that we do so in the past, but I believe
that we don't have consensus for anything other than what's in
https://tools.ietf.org/html/draft-ietf-geojson-00#section-3, a strong
recommendation against anything other than the default.

I propose to close issue 94 unless there's anything new to add to the
dicussion.

-- 
Sean Gillies

---

From: Martin Thomson <[email-masked]>
Date: Fri, 8 Jan 2016 10:02:10 +1100

> I propose to close issue 94 unless there's anything new to add to the

I don't have any opinion here, but I will note that removing CRS is
basically an irreversible decision given the extension model we've
adopted.

---

From: Dirk-Willem van Gulik <[email-masked]>
Date: Tue, 12 Jan 2016 07:45:50 +0100

> recommendation against anything other than the default.

Could you elaborate why you would want CRS84 rather than EPSG:4326 ?

Thanks,

Dw.

---

From: tõnis kärdi <[email-masked]>
Date: Tue, 12 Jan 2016 18:42:40 +0200

> Could you elaborate why you would want CRS84 rather than EPSG:4326 ?

I think it's because 4326 is a geodetic system and therefore entails
lat-lon order for coordinates. GeoJSON has the coordinates in lon-lat
order, therefore CRS84 is used.

all the best,
tõnis

---

From: Dirk-Willem van Gulik <[email-masked]>
Date: Tue, 12 Jan 2016 17:55:34 +0100

On 12 Jan 2016, at 17:42, tõnis kärdi <[email-masked]> wrote:

> I think it's because 4326 is a geodetic system and therefore entails lat-lon order for coordinates. GeoJSON has the coordinates in lon-lat order, therefore CRS84 is used.

So it is purely for the lon-lat order ? If we stick to CSR-84 — should we identify it as http://www.opengis.net/def/crs/OGC/1.3/CRS84 and refer to

	Geographic information - Well-known text representation of coordinate reference systems,
	Roger Lott, Open Geospatial Consortium,  2015-05-01, http://www.opengis.net/doc/IS/wkt-crs/1.0

And secondly - is there any need to be clear about things as to what we mean with things such as distances between two points at the same hight; now that we do not use a geodetic system; or is it fair to say that in the geojson we just defines point in space - and the lines between them have no particular shape other than interpolated within the CSR-84 space itself (and not a line as weightless `a piece of string’ between the CSR-84 endpoints).

Dw.