Subject: RE: LO Option Proposal (was: Re: I-DACTION:draft-ietf-geopriv-dhc p-lo-option-00.txt)

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 23 Jan 2003 14:35:36 -0500

This was new info to me.  I started looking.
The database can be obtained from:
http://www.ihsenergy.com/epsg/

If you load it, the table of interest is the "Coordinate Reference
System".  It has an index (Code).  

If you take the table at face value, the code can be as big as a
32766, a close to a suspiciously binary number.

Might need to delve into the EPSG procedure to know:
	Does a code EVER change (ie adding and subtracting is possible,
		but can the meaning of a specific code instance ever
change)?
	Is there a commitment to keep the maximum code less than some
		number?

There are 2597 records in this table at the moment.
I think one byte identifier is not going to work. The question is
whether a two byte identifier works, or we need 4.

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, January 23, 2003 9:58 AM
> To: Carl Reed
> Cc: Marc Linsner; [email-masked]
> Subject: Re: LO Option Proposal (was: Re:
> I-DACTION:draft-ietf-geopriv-dhcp-lo-option-00.txt)
> 
> 
> Since there's no point in having IANA duplicate the work of 
> the EPSG, it 
> makes sense to just use that database. We need a small numeric 
> identifier that can be derived from that database, e.g., by 
> subtracting 
> some fixed offset from a larger identifier.
> 
> Carl Reed wrote:
> > No, but EPSG does. The EPSG database has now become the 
> normative reference
> > for coordinate reference systems (including datums) for 
> many organizations
> > such as the petroleum industry, numerous GIS vendors, the 
> OGC and LIF/OMA.
> > The OGC has recently developed an on-line registry for the 
> common reference
> > systems and datums expressed in the EPSG database. Perhaps 
> we could look to
> > the EPSG.
> > 
> > Just a thought -
> > 
>

---

From: Carl Reed <[email-masked]>
Date: Thu, 23 Jan 2003 16:47:27 -0700

Hi -

Sorry my last posting did not go to the entire list. I forwarded the issue
to an OGC member who is also the EPSG Geodesy Work Group Chair. I am
awaiting his input.

Regards

Carl

----- Original Message -----
From: Rosen, Brian <[email-masked]>
To: 'Henning Schulzrinne' <[email-masked]>; Carl Reed
<[email-masked]>
Cc: Marc Linsner <[email-masked]>; <[email-masked]>
Sent: Thursday, January 23, 2003 12:35 PM
Subject: RE: LO Option Proposal (was: Re:
I-DACTION:draft-ietf-geopriv-dhcp-lo-option-00.txt)