Subject: [Geopriv] Minutes of the Sept. 5&6 GEOPRIV Interim Meeting

From: Andrew Newton <[email-masked]>
Date: Sun, 12 Oct 2003 13:47:19 -0400

The following are the meeting minutes of the GEOPRIV Sept. 5&6 interim 
meeting.

In addition, Hannes has a provided a webpage with detailed notes and 
pictures of the meeting.  > http://www.tschofenig.priv.at/geopriv/Interim2003/

Thanks to all who attended, and special thanks to the scribes: Hannes, 
Ted, and John S.

-andy

Meeting Minutes of the GEOPRIV Interim Meeting
September 5 & 6, 2003, Washington, D.C.

Chairs:
  Allison Mankin
  Randall Gellens
  Andy Newton

Scribes:
  Hannes Tschofenig
  Ted Hardie
  Andy Newton
  John Schnizlein

--> Day One

1) Agenda Bashing

Andy opened the meeting with a review of the Agenda for
the two days, matching those at the meeting to specific
items.  No specific agenda bashing.  It was agreed that the proposed agenda would provide a guide for the structure of the meeting but would be changed according to need.

We will be resending a message soliciting subscription to the 
new mailing list, as there were some technical issues during the
transition.  We will also coordinate with the secretariat on updating
the web page to point to the right list.

2) draft-ietf-geopriv-html-meta

Presentation of the GeoTags work by Andrew Daviel, which is targeted at
legacy HTML, not meant to supersede GML or later
work.  http://geotags.com/geo/geotags2.html describes
the tag format.

Discussion included questions about altitude, and the formats related
to the regional designation (eg. CA-ON for canada, ontario--derived from
ISO 3166).  Stressed that this is meant for human inclusion, not automatically
created or inserted.  

Discussion of the privacy implications--especially with authoring tools.
Randy and Andy pointed out the need for having some META tag
name that could *not* be auto populated, which might force the
auto-population to prompt the user.

Henning argued that there is only so much can be done to stop
implementation mistakes.  Discussion then went on to discussion
about the conflation between comments and keys--that the ability
to provide a comment about the location may be taken to be a key
for search).

Scope question then raised--is this a location objection? Discussion
indicates that the draft as currently written is not a location object
because location object has been defined as "something that is
protected by privacy".  Andrew is interested in exploring whether a
simplified object can be created which still allows author entry, but
does not leave the question of "what is the policy" unanswered.
There is an obvious engineering trade-off here between ease of
entry and complexity of tag.

There was no consensus regarding the next steps for this draft.

3) Location Object Policy Enforcement

Henning gave a presentation regarding methodologies and architectures for policy enforcement for geospatial information, including subscription and notification phases for presence models.

Henning's presentation led to a group discussion about the need to define requirements for authentication in the using protocols.  It was asked if the requirements document should be updated to reflect this requirement, and this was upheld by the general consensus of the room.

4) Security and GEOPRIV Architecture

Jon Peterson gave a brief overview of the architecture of GEOPRIV according to the current requirements document, with followup from Russ and Sean on general security principles.  This was followed by a general group discussion scoping the security requirements for the various interfaces in the GEOPRIV model and how they apply to subscription models.

The group next discussed general security details around the Location Object.  Jon related the work of PIDF with MIME, but also talked about the use of XML Digital Signatures and the use of MIME multipart for selectively signing and encrypting parts of the object.  It was noted by Russ and Andrew that key management and enrollment were not trivial matters.  This then led to a brief discussion regarding shared secrets.

Discussion around hop-to-hop security, object security, and session security led the group to decide that object security was desired.

5) S/MIME Architecture

After Sean's presentation on S/MIME, the group discussed the differences between XML Digital Signatures and S/MIME.  The discussion centered around the need for XML Canonicalization in order to do XML Digital Signatures and multipart security requirements vs. multiple destinations.

The group came to the following consensus; per-element granularity of security was not needed, and there was a preference for S/MIME over XML Digital Signatures.

Jon, Russ, and Ted then discussed the use of shared secrets and public keys.  John Schnizlein raised a concern about scability regarding multiple public keys and the relationship to a location server.  Hannes, Henning,  Randall, and Russ then discussed token-based authorization and authentication.  John S. raised concerns about scability, and then the group discussed the need for any time of authentication regarding public data.  This then led to a discussion about which mechanism would be mandatory to implement.

The group agreed that shared secrets MUST be mandatory to implement and certificates SHOULD be implemented.

This item closed with a brief discussion on high and low entropy.

6) Rules A through C

Jon Peterson gave a presentation on rules A through C.   The group then discussed the application of externally referenced rules, the default permission model for applying them, and the implications upon multiple Location Servers, and the efficiency and side-effects caused by additive (or subtractive) ruleset applications.

No conclusions were reached, and several of the participants promised to put their new proposal ideas into draft form.

The group then discussed the interface language between the Rule Maker and the Location Server.  At issue was the depth of the semantics of the language with regard to the geospatial information vs. a generic XPATH like language and the use of geospatial infoset specific profiles for rule making tools.

Following this discussion, the group decided that the interface language needed to be to have specific knowledge with respect to the data being filtered, and that there MAY be a more generic language similar to a XPATH.

The topic of IP address based policies was then brought up.  There was no consensus that this needed to be addressed.

Jon asked the group about the need for civil location to be in the baseline draft and noted that this was not a requirement.  However, the group agreed that civil location should be in the baseline draft.

Hannes stated that he had a co-worker currently analyzing GML 3.0 and would probably be able to report back regarding what elements/features were required by feature.xsd.

--> Day Two

7) Day two started with a recap of the previous day's meeting.

8) draft-ietf-geopriv-http-header

Andrew Daviel presented his draft on adding headers for HTTP to pass location information.  This was followed by a group discussion around the P3P and other models and how Andrew's draft fits into the accepted practices of using URL's.  Ted suggested looking at P3P as the Location Object and P3P may be very nice fit.  John Morris mentioned that P3P will be treated in a different legal context than specific location information.

9) Location Object Properties

Hannes gave a presentation on Location Object authorization policies specific to rules E through L.  The group discussed the various elements interactively through the presentation.

Henning and Jon discussed authentication in the role of anonymity, with Jon pointing out that IPP had ruled anonymity out of scope.  A conversation on the various rules and their matching semantics was carried on by the group with no clear consensus on direction.

Discussion around rule G pivoted upon the need for defining groups and roles.  It was the general consensus of the room that G should be dropped.

The discussion of the E-L rules and elements went forward, the consensus of the room was that John Morris should modify the core draft to reflect current thinking on rules vs. permission bits.  Henning stated he would soon be working on a new model of permissions as an outcome of the meeting.  The group agreed that the next version of the core draft should attempt to match these meanings and should be a working group item.

---

From: Andrew Newton <[email-masked]>
Date: Sun, 12 Oct 2003 13:57:45 -0400

Sorry for not making this clear:  these are draft minutes.  Please 
forward any corrections or comments to either me or the list.  Thank you.

-andy

> The following are the meeting minutes of the GEOPRIV Sept. 5&6 interim 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv