Subject: [Geopriv] SUPL

From: "Stark, Barbara" <[email-masked]>
Date: Fri, 13 Apr 2007 11:54:22 -0400

It looks like OMA is very open in their sharing of documents. I found
all of the Location WG's "Permanent Documents" publicly published at:
http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_
documents/

And it looks like much of their current work-in-progress is documented
at:
http://member.openmobilealliance.org/ftp/Public_documents/LOC/2007/

But it's a really long list. Could someone familiar with the OMA
Location work provide pointers as to which are the best documents to
look at to get a better understanding of SUPL, per the discussions we
had in Washington, DC these past few days? Thanks,
Barbara

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA621

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 15 Apr 2007 18:38:19 -0500

Hi Barbara,

All of the documents have a date, so you can ignore a lot of that list based on age.

The SUPL architecture document (AD) is probably the best place to start:

http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-AD-SUPL-V1_0-20070122-C.zip

That document requires a fair investment to get anything out of, but it’s all there.  Keep in mind that SUPL entails a complete architecture including: roaming architecture and protocol (RLP), request interface (MLP), security, assisted-GPS signaling (ULP), integration with 3GPP(2) networks (via SMS and WAP-PUSH), network-based location measurements (cell-ID, etc…).  Some of this is difficult to understand without some knowledge of how the location infrastructure of 3GPP(2) networks is built (c.f. 3GPP TS 23.271) and how assisted-GPS works.

I can answer any specific questions you have.

Cheers,

Martin

RLP: Roaming Location Protocol (part of MLS suite; also used for GMLC-GMLC interface in the 3GPP architecture) http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-RLP-V1_0-20051124-C.zip

MLP: Mobile Location Protocol (part of MLS suite) http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-MLP-V3_2-20051124-C.zip

MLS: Mobile Location Services 

ULP: User-plane Location Protocol (SET-SLP interface) http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-ULP-V1_0-20070122-C.zip

3GPP TS 23.271: Functional stage 2 description of Location Services (LCS) http://www.3gpp.org/ftp/Specs/html-info/23271.htm

________________________________

From: Stark, Barbara [mailto:[email-masked]] 
Sent: Saturday, 14 April 2007 1:54 AM
To: GEOPRIV WG
Subject: [Geopriv] SUPL

It looks like OMA is very open in their sharing of documents. I found all of the Location WG's "Permanent Documents" publicly published at:

http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/ <http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/>  

And it looks like much of their current work-in-progress is documented at: 
http://member.openmobilealliance.org/ftp/Public_documents/LOC/2007/ <http://member.openmobilealliance.org/ftp/Public_documents/LOC/2007/>  

But it's a really long list. Could someone familiar with the OMA Location work provide pointers as to which are the best documents to look at to get a better understanding of SUPL, per the discussions we had in Washington, DC these past few days? Thanks,

Barbara 

*****

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: [email-masked]
Date: Mon, 16 Apr 2007 13:48:16 -0400 (EDT)

Hi -

It is also interesting to note that the CRS and Geometry aspects of MLP
are elements of GML schema. However, they are currently using GML 2.1,
which is a deprecated (but still publicly available) OGC standard. Sure
would nice to figure out how to work with OMA to upgrade MLP to use GML
3.1.1 such that they would be consistent with the work of the IETF, OASIS,
ISO, and the OGC. I am not sure how to go about this. Also, FYI, GML has
just been approved as an International Standard (ISO 19136).

Regards

Carl

 Hi Barbara,
> That document requires a fair investment to get anything out of, but
> it’s all there.  Keep in mind that SUPL entails a complete architecture
> including: roaming architecture and protocol (RLP), request interface
> (MLP), security, assisted-GPS signaling (ULP), integration with 3GPP(2)
> networks (via SMS and WAP-PUSH), network-based location measurements
> (cell-ID, etc…).  Some of this is difficult to understand without some
> knowledge of how the location infrastructure of 3GPP(2) networks is built
> (c.f. 3GPP TS 23.271) and how assisted-GPS works.
>
>
>
> RLP: Roaming Location Protocol (part of MLS suite; also used for GMLC-GMLC
> interface in the 3GPP architecture)
> http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-RLP-V1_0-20051124-C.zip
>
> MLP: Mobile Location Protocol (part of MLS suite)
> http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-MLP-V3_2-20051124-C.zip
>
> ULP: User-plane Location Protocol (SET-SLP interface)
> http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/OMA-TS-ULP-V1_0-20070122-C.zip
>
> 3GPP TS 23.271: Functional stage 2 description of Location Services (LCS)
> http://www.3gpp.org/ftp/Specs/html-info/23271.htm
>
>
>
> It looks like OMA is very open in their sharing of documents. I found all
> of the Location WG's "Permanent Documents" publicly published at:
>
> http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/
> <http://member.openmobilealliance.org/ftp/Public_documents/LOC/Permanent_documents/>
>
> <http://member.openmobilealliance.org/ftp/Public_documents/LOC/2007/>
>
> But it's a really long list. Could someone familiar with the OMA Location
> work provide pointers as to which are the best documents to look at to get
> a better understanding of SUPL, per the discussions we had in Washington,
> DC these past few days? Thanks,
>
> Barbara
>
> *****
>
> The information transmitted is intended only for the person or entity to
> which it is addressed and may contain confidential, proprietary, and/or
> privileged material. Any review, retransmission, dissemination or other
> use of, or taking of any action in reliance upon this information by
> persons or entities other than the intended recipient is prohibited. If
> you received this in error, please contact the sender and delete the
> material from all computers. GA621
>