Subject: RE: [Geopriv] Confirmation of GEOPRIV IETF 68 Working Group Hums

From: "Brian Rosen" <[email-masked]>
Date: Wed, 25 Apr 2007 14:29:20 -0400

On most devices of interest, this is a non issue; they are small embedded
devices, like phones.

For other situations, for example a sip softclient running on a laptop, we
will specify an api on the O/S the application is running.  The api will
front end a set of "Location Configuration Protocols" of which DHCP is one.

Brian

> -----Original Message-----
> From: Hallam-Baker, Phillip [mailto:[email-masked]]
> Sent: Wednesday, April 25, 2007 9:50 AM
> To: John Schnizlein; David W. Hankins
> Cc: GEOPRIV WG; [email-masked]
> Subject: RE: [Geopriv] Confirmation of GEOPRIV IETF 68 Working Group Hums
> 
> But how does my application access it?
> 
> DHCP is not something that an application layer program should be allowed
> to perform. It is a security issue. For good reason performing DHCP
> operations requires privileges beyond mere network connectivity on
> Windows.
> 
> That is why configuring application programs from DHCP never caught on.
> 
> > -----Original Message-----
> > From: John Schnizlein [mailto:[email-masked]]
> > Sent: Sunday, April 22, 2007 6:41 PM
> > To: David W. Hankins
> > Cc: GEOPRIV WG; [email-masked]
> > Subject: Re: [Geopriv] Confirmation of GEOPRIV IETF 68
> > Working Group Hums
> >
> > The reason that DHCP is appropriate for information about the
> > location of the host is that the scope of DHCP administration
> > usually does match the local network to which the host is
> > attached.  Location is local information.
> >
> > John
> >
> > On Apr 20, 2007, at 3:38 PM, David W. Hankins wrote:
> >
> > > The point is that the ISO L(x) is not what one considers
> > when judging
> > > wether or not a certain configuration value "would make a good band
> > > name.  I mean DHCP option."
> > >
> > > What we (strive to) consider instead is the administrative scope of
> > > the configuration information, and wether it matches common and
> > > practical use of DHCP.
> >
> >
> > On Apr 19, 2007, at 7:47 PM, David W. Hankins wrote:
> > > On Thu, Apr 19, 2007 at 03:38:40PM -0700, Hallam-Baker,
> > Phillip wrote:
> > >> DHCP is a layer 3 technology that talks directly to layer 2.
> > >
> > > DHCP is a technology that dynamically configures hosts.
> > >
> > > If a host has a configuration knob that might reasonably
> > and properly
> > > be set by the systems administrator or the network you are
> > presently
> > > attached to, then it is reasonable and proper to configure it via
> > > DHCP.
> >
> >
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> >
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: <[email-masked]>
Date: Wed, 25 Apr 2007 16:30:53 -0400

Brian,

<we will specify an api on the O/S the application is running>

Who is "we", geopriv?

Guy Caron
-----Message d'origine-----
De : Brian Rosen [mailto:[email-masked]] 
Envoyé : 25 avril 2007 14:29
À : 'Hallam-Baker, Phillip'; 'John Schnizlein'; 'David W. Hankins'
Cc : 'GEOPRIV WG'; [email-masked]
Objet : RE: [Geopriv] Confirmation of GEOPRIV IETF 68 Working Group Hums

Brian

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 25 Apr 2007 16:34:59 -0400

Sorry, bad choice of words. 

I'm not sure, but almost certainly not IETF.  IETF doesn't do apis.  I'm
trying to get MS+Apple+Linux and maybe some embedded OS folks to agree to
have a common api.  I don't know if that will work yet.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, April 25, 2007 4:31 PM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 25 Apr 2007 16:05:03 -0500

This is one of things we have talked about doing in the NENA VoIP Location WG.

> Sent: Thursday, 26 April 2007 6:31 AM

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]