Subject: [Geopriv] Moving forward with l7-lcp

From: Robert Sparks <[email-masked]>
Date: Fri, 27 Apr 2007 14:51:15 -0500

All -

Those of you that attended the IETF68 Geopriv meeting went through a  
fairly
intense and unusual process to make forward progress on the l7-lcp  
front.
Whether or not you attended, please go re-read the minutes covering  
that part
of the meeting.

To summarize:

   - The group expressed an overwhelming desire to have exactly one  
http-based l7-lcp.
   - The group confirmed strongly that they felt informed enough to  
choose a
     starting point from the contending proposals.
   - A hum poll showed there was not a dominant preference between  
the options,
     so the group agreed to make forward progress by accepting a  
plurality
     opinion. (Ted Hardie helped lead the group through this  
difficult territory).
   - The opinions in the room were perfectly split between using RELO  
as the
     starting point for moving forward and using HELD. Cullen agreed  
to change
     his position to break the tie, but the gesture was eclipsed as  
fairly
     strong support for starting with HELD appeared from those  
participating
     via jabber.

The takeaway was agreement in the room to work this plurality decision
and make forward progress with a document based on HELD.

Clearly, this process was extreme. It appears to have been effective  
- the group
achieved something very hard to do.  It's important that we  
predominantly agree to
work with this decision as we go forward. If you have strong concerns  
about how we got
here, please bring them to the list or to me. Based on the agreement  
that I see, here's
a plan for going forward.

We'll create a new working group document based on
draft-winterbottom-http-location-delivery-05 to provide an HTTP-based  
l7-lcp
protocol that as simply as possible meets the requirements being  
refined in
draft-ietf-geopriv-l7-lcp-ps.

Mary Barnes has agreed to be the editor of this draft. Please join me  
in thanking
her for taking on this task and helping her get started.

I urge everyone to embrace this opportunity to make forward progress  
on this topic.
If you weren't able to participate directly in the meeting, please  
review the progress
we've made and let us know if you're also willing to make progress  
with this plan.

RjS

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: <[email-masked]>
Date: Fri, 27 Apr 2007 16:14:13 -0400

Hi Robert,

I support your suggestion below. However, I remember some discussions on the list before and after ietf68 around updating the draft-ietf-geopriv-l7-lcp-ps document. Should this be looked at before starting alignment work on the HELD draft?

Regards,

Guy Caron
-----Message d'origine-----
De : Robert Sparks [mailto:[email-masked]] 
Envoyé : 27 avril 2007 15:51
À : GEOPRIV WG
Objet : [Geopriv] Moving forward with l7-lcp

All -

To summarize:

RjS

---

From: Ted Hardie <[email-masked]>
Date: Fri, 27 Apr 2007 13:18:39 -0700

At 2:51 PM -0500 4/27/07, Robert Sparks wrote:

>
>  - The opinions in the room were perfectly split between using RELO as the
>    starting point for moving forward and using HELD. Cullen agreed to change
>    his position to break the tie, but the gesture was eclipsed as fairly
>    strong support for starting with HELD appeared from those participating
>    via jabber.

This is not quite correct. Cullen, who had not previously voted, did so.
This was not a changed position.

Note also that the names of specific drafts were used in the vote,
so that this did not include all of the work related to HELD, just one aspect.

				Ted Hardie

---

From: Robert Sparks <[email-masked]>
Date: Fri, 27 Apr 2007 15:44:51 -0500

Both of these are accurate clarifications. Thanks Ted.

RjS

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Sat, 28 Apr 2007 10:32:13 +0200

I want to schedule an update of draft-ietf-geopriv-l7-lcp-ps based on the LIS vs. LS discussion. I might also do some editorial improvements to the document. I have, however, removed all the parts that belong to Rogers document and I suggested a few more things to move to his document. 

I therefore believe that the draft-ietf-geopriv-l7-lcp-ps draft is almost complete whereas Rogers document is not even a working group item. It has to be turned into a WG item!

-------- Original-Nachricht --------
Datum: Fri, 27 Apr 2007 16:14:13 -0400
Von: [email-masked]
An: [email-masked], [email-masked]
Betreff: RE: [Geopriv] Moving forward with l7-lcp

> Hi Robert,
> 
> I support your suggestion below. However, I remember some discussions on
> the list before and after ietf68 around updating the
> draft-ietf-geopriv-l7-lcp-ps document. Should this be looked at before starting alignment work on
> the HELD draft?
> 
> Regards,
> 
> Guy Caron

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 29 Apr 2007 09:23:57 +0200

Hi Robert, 

~snip~

> her for taking on this task and helping her get started.

Are you suggesting to replace the existing authors with Mary Barnes as document editor? Correct? 

Ciao
Hannes

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 30 Apr 2007 08:54:02 -0400

Oh I hope not.  I read that as "editor" not author.  I assume/hope the HELD
authors will remain authors.  

Brian

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Sunday, April 29, 2007 3:24 AM
> To: Robert Sparks; [email-masked]
> Subject: Re: [Geopriv] Moving forward with l7-lcp
> 
> Hi Robert,
> 
> ~snip~
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 30 Apr 2007 10:47:24 -0500

Mary will be the editor of the working group document. We'll be using  
the classic
editor/contributor model. The authors of the HELD draft we're basing  
this wg-draft
on will remain authors and I expect them to be heavy contributors. As  
a working
group item, I'm expecting heavy contribution from the whole working  
group as
the document is refined.

RjS

On Apr 30, 2007, at 7:54 AM, Brian Rosen wrote:

>> Are you suggesting to replace the existing authors with Mary  
>> Barnes as
>> document editor? Correct?
>>
>> Ciao
>> Hannes
>>
>>