Subject: [Geopriv] I-D Action:draft-ietf-geopriv-dhcp-lbyr-uri-option-10.txt

From: [email-masked]
Date: Fri, 11 Feb 2011 13:15:02 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Geographic Location/Privacy Working Group of the IETF.

	Title           : Dynamic Host Configuration Protocol (DHCP) IPv4 and IPv6 Option for a Location Uniform Resource Identifier (URI)
	Author(s)       : J. Polk
	Filename        : draft-ietf-geopriv-dhcp-lbyr-uri-option-10.txt
	Pages           : 13
	Date            : 2011-02-11

This document creates a Dynamic Host Configuration Protocol (DHCP) 
Option for transmitting a client's geolocation Uniform Resource 
Identifier (URI) of a client, which can be dereferenced in a 
separate transaction by the client or an entity the client sends 
this URI to.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-dhcp-lbyr-uri-option-10.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 11 Feb 2011 13:43:11 -0800

"The LuriValue of LuriType=2 is always represented as an integer."

This is insufficiently specified.  How long is this integer?  Signed or unsigned?  Suggested text:

"The LuriValue of LuriType=2 is always represented as a four-byte unsigned integer."

(We should not use an indefinite-length integer; that's unnecessarily hard.  If somebody wants a location URI that's good for more than 136 years, they can renew their DHCP lease.  Two octets is probably too short, since it's less than a day; three octets is weird.  Hence four.  Unsigned because negative seconds are useless in this case.)

--Richard

On Feb 11, 2011, at 1:15 PM, [email-masked] wrote:

> <Mail Attachment>_______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 11 Feb 2011 16:31:18 -0600

At 03:43 PM 2/11/2011, Richard L. Barnes wrote:
>This is insufficiently specified.

fair point

>How long is this integer?  Signed or unsigned?  Suggested text:
>

ok

look for a ver -11 in the next hour. I'll submit it within a few minutes

james

>(We should not use an indefinite-length integer; that's 
>unnecessarily hard.  If somebody wants a location URI that's good 
>for more than 136 years, they can renew their DHCP lease.  Two 
>octets is probably too short, since it's less than a day; three 
>octets is weird.  Hence four.  Unsigned because negative seconds are 
>useless in this case.)
>
>--Richard
>
>
> >       Title           : Dynamic Host Configuration Protocol 
> (DHCP) IPv4 and IPv6 Option for a Location Uniform Resource Identifier (URI)
> >       Author(s)       : J. Polk
>_______________________________________________
>Geopriv mailing list
>[email-masked]