Subject: [Geopriv] WG: altitude in RFC 5870

From: Alexander Mayrhofer <[email-masked]>
Date: Tue, 24 May 2011 14:57:16 +0200

All,

we've received privately feedback about a potential error in RFC 5870. Could someone who is more familiar with reference systems review Jose's email, and advice whether we'd need to add errata to the RFC?

thanks,

Alex

---- 
Von: José Luis García Balboa [mailto:[email-masked]] 
Gesendet: Dienstag, 24. Mai 2011 13:56
An: [email-masked]; Alexander Mayrhofer
Betreff: altitude in RFC 5870

Dear Alexander and Christian:
 
I'm reading RFC 5870. Congratulatios for this interesant document
I write to you in relation to the altitude information of the geoURI, because I think there is a mistake.
 
When using WGS84, the altitude is set in relation to the reference ELLIPSOID (which is the GRS80 ellipsoid), but not to the GEOID. 
You can see this, for example, in the definition of the CRS with code EPSG 4979.
In other words, any GPS navigator can offer you the "ellipsoid height " over the GRS80 elllipsoid (there are many ellipsoids), but no any height referred to the geoid (there is only one geoid). This two figures of the earth are completely different.
 
In page 5 it is said that "altitudes below the WGS-84 reference geoid". This is incorrect. It should say "belo the WGS-84 reference ellipsoid".
In page 10 it is said that "altitudes are relative to the WGS-84 reference geoid rather than Earth's surface". This is also incorrect.
 
I think this should be correct in a future revision of RFC 5870 (or perhaps any other people has already warned you about this).
 
Best regards,
 
**************************************************
 José Luis García Balboa
 
 Dpto. Ingeniería Cartográfica, Geodésica y Fotogrametría
 Escuela Politécnica Superior. Edf. A-3. Despacho 343.
 Campus Las Lagunillas. Universidad de Jaén. 23071 JAÉN (Spain).
 
 Tlf/Fax: (+34) 953 212844 / (+34) 953 212855
 Correo electrónico: [email-masked]
 Web: http://coello.ujaen.es
**************************************************

---

From: Ivan Shmakov <[email-masked]>
Date: Tue, 24 May 2011 20:33:12 +0700

>>>>> Alexander Mayrhofer <[email-masked]> writes:

 > All, we've received privately feedback about a potential error in RFC
 > 5870.  Could someone who is more familiar with reference systems
 > review Jose's email, and advice whether we'd need to add errata to
 > the RFC?

[…]

 > When using WGS84, the altitude is set in relation to the reference
 > ELLIPSOID (which is the GRS80 ellipsoid), but not to the GEOID.  You
 > can see this, for example, in the definition of the CRS with code
 > EPSG 4979.  In other words, any GPS navigator can offer you the
 > "ellipsoid height " over the GRS80 elllipsoid (there are many
 > ellipsoids), but no any height referred to the geoid (there is only
 > one geoid). This two figures of the earth are completely different.

[…]

	Not that I have much expertise in this field, but…

--cut: http://en.wikipedia.org/wiki/World_Geodetic_System --
    […] It comprises a standard coordinate frame for the Earth, a
    standard spheroidal reference surface (the datum or reference
    ellipsoid) for raw altitude data, and a gravitational equipotential
    surface (the geoid) that defines the nominal sea level.
--cut: http://en.wikipedia.org/wiki/World_Geodetic_System --

	Thus, WGS-84 defines both a reference ellipsoid and a geoid,
	which gives the nominal sea level.

--cut: http://en.wikipedia.org/wiki/Altitude --
    […] As a general definition, altitude is a distance measurement,
    usually in the vertical or "up" direction, between a reference datum
    and a point or object.  The reference datum also often varies
    according to the context.  Although the term altitude is commonly
    used to mean the height above sea level of a location, in geography
    the term elevation is often preferred for this usage.
--cut: http://en.wikipedia.org/wiki/Altitude --

	Thus, I guess that the term “altitude” may refer either to the
	distance above the reference ellipsoid, or to the distance above
	the geoid.

	Therefore, I find it believable that there may be CRS that rely
	on one or another definition of altitude, and I find believable
	that there may be equipment that reports the altitude
	corresponding to one or another definition of altitude.

	So, I believe that no change is necessary to the specification
	regarding this issue.  However, a note of warning for
	implementors to be cautious about the exact nature of the data
	to be written in the geo: URI may be desirable.

-- 
FSF associate member #7257