Subject: [Geopriv] Removing dhcp-lbyr dependency from policy-uri

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 12 Dec 2011 16:30:51 -0500

Dear GEOPRIV,

tl;dr: If you care about whether -policy-uri supports DHCP LbyR, please say so now.

As you may be aware, we currently have three documents in IESG processing:
1. -deref-protocol
2. -policy-uri
3. -dhcp-lbyr-uri-option

The first of these are pretty non-controversial, while the last has some outstanding issues with the DHC working group.  Right now, however, -policy-uri has a normative dependence on -dhcp-lbyr-uri-option, because it says how to carry policy URIs inside a DHCP LbyR option.  This raises the question of whether we should remove the DHCP parts of -policy-uri in order to remove the dependency.

So I wanted to get the feeling of the WG on which of three courses of action people would prefer:

A: Do nothing for now.
If approved by the IESG, -policy-uri will sit in the RFC editor's queue waiting for -dhcp-lbyr-uri-option.  If the objections in DHC cannot be overcome and that document dies, then we will work with the RFC editor to remove the text that depends on it.

B: Remove the DHCP text now
This would remove the normative dependency, and leave open the possibility of adding the same mechanism as part of -dhcp-lbyr-uri-option later.

C: Remove the DHCP text now and add it to -dhcp-lbyr-uri-option
This would just move the functionality from one document to another, removing the dependency while ensuring the functionality is maintained.

For reference, I have attached a diff that describes the changes that would need to be made to -policy-uri in order to remove the dependency.

If you have an opinion on this issue, it would be helpful if you could reply in this thread in the next week or so.

Thanks,
--Richard

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 13 Dec 2011 05:45:03 +0800

Option B.

If it turns out to be a problem for the DHCP LbyR then we can write another specification to address that later.

James Winterbottom
Global Product Manager
Commscope GeoLENs
IP Location Product Portfolio
Andrew Building (39), University of Wollongong
Northfields Ave, Wollongong, NSW, 2522 Australia
Email: [email-masked]<mailto:[email-masked]>
Phone: +61-2-42-212938
Mobile: +61-447-773-560
www.commscope.com<http://www.commscope.com/> | www.commscopeblogs.com<http://www.commscopeblogs.com/>

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard L. Barnes
Sent: Tuesday, 13 December 2011 8:31 AM
To: [email-masked] WG
Subject: [Geopriv] Removing dhcp-lbyr dependency from policy-uri

Dear GEOPRIV,

A: Do nothing for now.

Thanks,
--Richard

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 12 Dec 2011 16:47:15 -0500

FWIW, my preference would be B or C, if only to remove the uncertainty.
--Richard

On Dec 12, 2011, at 4:30 PM, Richard L. Barnes wrote:

> <rfcdiff-04-05prop.html>_______________________________________________
> Geopriv mailing list
> [email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Tue, 13 Dec 2011 09:17:49 -0500

Option A.  We have to make DHCP LbyR work one way or another.  I don't mind waiting, and I want less work overall.

Brian

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 13 Dec 2011 13:23:34 -0600

At 08:17 AM 12/13/2011, Brian Rosen wrote:
>Option A.  We have to make DHCP LbyR work one way or another.  I 
>don't mind waiting, and I want less work overall.

Option A - for the reasons stated above

James

> > The first of these are pretty non-controversial, while the last 
> has some outstanding issues with the DHC working group.  Right now, 
> however, -policy-uri has a normative dependence on 
> -dhcp-lbyr-uri-option, because it says how to carry policy URIs 
> inside a DHCP LbyR option.  This raises the question of whether we 
> should remove the DHCP parts of -policy-uri in order to remove the dependency.
> >
> > If approved by the IESG, -policy-uri will sit in the RFC editor's 
> queue waiting for -dhcp-lbyr-uri-option.  If the objections in DHC 
> cannot be overcome and that document dies, then we will work with 
> the RFC editor to remove the text that depends on it.
> >
> > This would remove the normative dependency, and leave open the 
> possibility of adding the same mechanism as part of 
> -dhcp-lbyr-uri-option later.
> >
> > This would just move the functionality from one document to 
> another, removing the dependency while ensuring the functionality 
> is maintained.
> >
> > For reference, I have attached a diff that describes the changes 
> that would need to be made to -policy-uri in order to remove the dependency.
> >
> > If you have an opinion on this issue, it would be helpful if you 
> could reply in this thread in the next week or so.
> >
> > Thanks,
> > --Richard
> >
> >