Subject: [Geopriv] Fwd: New Version Notification for draft-bellis-geopriv-flow-identity-00.txt

From: Ray Bellis <[email-masked]>
Date: Wed, 29 Feb 2012 16:29:19 +0000

I've just submitted the draft detailed below, available at:

  http://tools.ietf.org/html/draft-bellis-geopriv-flow-identity-00

Textually, it's somewhat rough, but I wanted to get feedback on the general idea (and the validity of the XSD) before spending too much time on the words themselves.

Ray

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bellis-geopriv-flow-identity-00.txt
Date: 29 February 2012 16:26:12 GMT
To: <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-bellis-geopriv-flow-identity-00.txt has been successfully submitted by Ray Bellis and posted to the IETF repository.

Filename: draft-bellis-geopriv-flow-identity
Revision: 00
Title: Flow Identity Extension for HELD
Creation date: 2012-02-29
WG ID: Individual Submission
Number of pages: 12

Abstract:
  Identity Extensions using an IP address and port number to request a
  location based on an individual packet flow have been previously
  specified by the GEOPRIV Working Group.

  However certain kinds on NAT require that identifiers for both ends
  of the packet flow must be specified in order to unambiguously
  satisfy the location request.

  This document specifieds a Flow Identity Extension for the HTTP-
  Enabled Location Delivery (HELD) Protocol to support this
  requirement.

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 29 Feb 2012 18:39:59 +0200

Hi Ray, 

ports are specified in HELD identity. 

Since the idea of HELD is to find out where the entity (as described by
an IP address, etc.) is I wonder why it would be useful to include the
destination address and port number (which is what a flow information
adds).

Ciao
Hannes

From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Ray Bellis
Sent: Wednesday, February 29, 2012 6:29 PM
To: GEOPRIV WG
Subject: [Geopriv] Fwd: New Version Notification for
draft-bellis-geopriv-flow-identity-00.txt

Textually, it's somewhat rough, but I wanted to get feedback on the
general idea (and the validity of the XSD) before spending too much time
on the words themselves.

Ray

From: <[email-masked]>

Subject: New Version Notification for
draft-bellis-geopriv-flow-identity-00.txt

To: <[email-masked]>

A new version of I-D, draft-bellis-geopriv-flow-identity-00.txt has been
successfully submitted by Ray Bellis and posted to the IETF repository.

Filename:      draft-bellis-geopriv-flow-identity
Revision:       00
Title:                                   Flow Identity Extension for
HELD
Creation date:                     2012-02-29
WG ID:                              Individual Submission
Number of pages: 12

Abstract:

---

From: Ray Bellis <[email-masked]>
Date: Wed, 29 Feb 2012 16:40:04 +0000

On 29 Feb 2012, at 16:29, Ray Bellis wrote:

> Textually, it's somewhat rough

By which I meant to say, there's barely any text at all, yet...

Ray

---

From: Richard Barnes <[email-masked]>
Date: Wed, 29 Feb 2012 22:12:12 +0530

> Since the idea of HELD is to find out where the entity (as described by an IP address, etc.) is I wonder why it would be useful to include the destination address and port number (which is what a flow information adds).

I can name that tune in 3 letters: CGN.

--Ricahrd

>  
> Ciao
> Hannes
>  
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ray Bellis
> Subject: [Geopriv] Fwd: New Version Notification for draft-bellis-geopriv-flow-identity-00.txt
>  
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: Ray Bellis <[email-masked]>
Date: Wed, 29 Feb 2012 16:45:49 +0000

On 29 Feb 2012, at 16:39, Tschofenig, Hannes (NSN - FI/Espoo) wrote:

Hi Ray,

Indeed, and it was my idea in the first place.

But I didn't get it right.

Because on a CGN (and some other NATs) it's possible for the same source IP / port pair to be part of lots of flows at once.

It's only the complete 6-tuple that uniquely identifies the flow, and hence the internal target behind that NAT.

Ray