Subject: [Geopriv] Fwd: New Version Notification for draft-bellis-geopriv-flow-identity-01.txt

From: Ray Bellis <[email-masked]>
Date: Mon, 14 May 2012 15:03:33 +0000

Following the discussion in Paris and subsequent chats with Martin I've now updated this draft.

The changes are:

- simplified (shorter) XSD

- allowing an IP protocol number to be specified instead
  of "tcp", "udp" etc.

  [I considered doing the same for IP version, but I really
   don't see us trying to do IPv10 just yet...]

- adding of an (optional) "target" attribute to the <flow>
  tag to identify which end of the flow is the target of the
  <locationRequest>.

Please review - the draft is short, and I'd love to see it zip straight through the WG and up to the IESG asap.

Ray

> A new version of I-D, draft-bellis-geopriv-flow-identity-01.txt has been successfully submitted by Ray Bellis and posted to the IETF repository.
> 
> Filename:	 draft-bellis-geopriv-flow-identity
> Revision:	 01
> Title:		 Flow Identity Extension for HELD
> Creation date:	 2012-05-14
> WG ID:		 Individual Submission
> Number of pages: 12

---

From: Martin Thomson <[email-masked]>
Date: Mon, 14 May 2012 10:21:48 -0700

The idea of a source and destination is quite subjective when it comes
to NAT traversal.  From the perspective of the NAT it is usually the
endpoint behind that initiates the flow (because that's how holes
appear), but where there are two NATs on a flow, the same view is held
by both NATs.

e.g.
    A -- NATa -- (Internets!) -- NATb -- B

NATa views A as being the source.  NATb views B as being the source.

This fits well with what you have since you assume src to be the
default and you are normally talking to something that will share the
perspective bias of the NAT.  An explanation of this trap might be
useful.

Extension is easy:
      <xs:sequence>
         <xs:element name="src" type="flow:flowEndpoint"/>
         <xs:element name="dst" type="flow:flowEndpoint"/>
>>       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
       </xs:sequence>

Nit:
Section 3: s/show/shown/

On 14 May 2012 08:03, Ray Bellis <[email-masked]> wrote:
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv