Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

From: "Carl Reed" <[email-masked]>
Date: Tue, 4 Sep 2012 10:31:37 -0600

North is negative? I would check out how GeoTIFF provides map orientation 
information or how the OGC Web Map Service specifies map image orientation 
for a map image returned to a client from a server. There is also the GMLJP2 
standard that specifies how to define a CRS an orientation, and other 
metadata for map data stored in a JPEG file.

Cheers

Carl

-----Original Message----- 
From: Martin Thomson
Sent: Sunday, August 26, 2012 12:09 AM
To: Kipp Jones
Cc: GEOPRIV WG
Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

On 25 August 2012 07:41, Kipp Jones <[email-masked]> wrote:
> I'm still fuzzy on how the map orientation is communicated, but I'm 
> assuming that is outside the scope of this document.

What constitutes "north", "east", "up", etc for a map are something
that the map will have to describe.  The draft describes how an image
is (normally) oriented: north is negative y, east is positive x.
Other document formats might have more precise definitions of how
these appear.
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Martin Thomson <[email-masked]>
Date: Tue, 4 Sep 2012 13:13:05 -0700

As I recall yes.  Image coordinates are unusual in the sense that row
numbers increase toward the bottom of the page.  If you use row
numbers, then a typically oriented map (North toward the top of the
screen) requires North to map to negative row numbers.  That needs to
be explicit in the scaling parameters though.  If the image has
attributes or metadata that make this unnecessary, then there is no
need to specify scale.

--Martin

On 4 September 2012 09:31, Carl Reed <[email-masked]> wrote:
> -----Original Message----- From: Martin Thomson

---

From: Robin Wilton <[email-masked]>
Date: Wed, 5 Sep 2012 09:58:56 +0100

That matches what I've observed, too.  Another way to think of it is this: if you display an image, (0,0) is the top left hand corner, and the co-ordinates increase as you go down and right.

Than means if you want to go 'off the screen to the North', you have to plot negative Y co-ordinates...

Hope this helps!

Robin 

Sent from my iPod

---

From: "Carl Reed" <[email-masked]>
Date: Wed, 5 Sep 2012 10:12:48 -0600

Robin -

I think that we are on the same page. My only concern is that the metadata 
for a georegistered image needs to contain both the CRS information as well 
as the image origin information (top left hand for example), and other 
metadata needed to actually render the image in a GIS, earth browser app or 
any app that requires complete metadata to properly render the image. This 
is why I mentioned GeoTIFF and GMLJP2 as examples of standards that provide 
all the necessary metadata.

But perhaps I am off discussion.

Cheers

Carl

-----Original Message----- 
From: Robin Wilton
Sent: Wednesday, September 05, 2012 2:58 AM
To: Martin Thomson
Cc: Carl Reed ; GEOPRIV WG
Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

That matches what I've observed, too.  Another way to think of it is this: 
if you display an image, (0,0) is the top left hand corner, and the 
co-ordinates increase as you go down and right.

Than means if you want to go 'off the screen to the North', you have to plot 
negative Y co-ordinates...

Hope this helps!

Robin

Sent from my iPod

---

From: tglassey <[email-masked]>
Date: Thu, 06 Sep 2012 06:30:27 -0700

> Than means if you want to go 'off the screen to the North', you have to plot negative Y co-ordinates...

How does this fit in with languages which dont read left-to-right?

Todd

> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2012.0.2197 / Virus Database: 2437/5249 - Release Date: 09/04/12
>
>

-- 
//Confidential Mailing - Please destroy this if you are not the intended recipient.

---

From: Robin Wilton <[email-masked]>
Date: Thu, 6 Sep 2012 14:43:13 +0100

I'm no expert, but as far as I'm aware, in both images and maps, the convention about co-ordinates is distinct from any convention about orientation of script… (so, for instance, a map with Arabic text would still express co-ordinates the same way as a map with English text, but the text on the map would be oriented as 'normal for that language'...)

R
 
Robin Wilton
Technical Outreach Director - Identity and Privacy
Internet Society

email: [email-masked]
Phone: +44 705 005 2931
Twitter: @futureidentity

---

From: tglassey <[email-masked]>
Date: Thu, 06 Sep 2012 06:57:30 -0700

On 9/6/2012 6:43 AM, Robin Wilton wrote:
> I'm no expert, but as far as I'm aware, in both images and maps, the 
> convention about co-ordinates is distinct from any convention about 
> orientation of script… (so, for instance, a map with Arabic text would 
> still express co-ordinates the same way as a map with English text, 
> but the text on the map would be oriented as 'normal for that 
> language'...)

Except that the French (through the BIPM) moved the zero-crossing 
meridian to Paris - so there are two specific types of Admiralty charts 
today - those with Greenwich as the meridian and those with Paris as the 
0 point on the mapping system.

Do we support both?  If so doesnt it make sense to support an open 
mapping format which allows the

     1)    Create a Digital Legend for each map specifying

                 a)    Mapping Definition to be disclosed in the 
process. This way we can include any maps and any process for their 
interpretation we want to.
                 b)    Related Maps or those superseded by this release
                 c)    Its issuing authority and its dates of 
effectivity/validity - this  is critical since these MAPS will become 
Wireframe Tools and will be used in all types of Navigation, Process 
Automation *(silly things like autonav on Hatvester Combines for 
instance is a key function here) so these are really important to the 
larger issue of how these  digital-wire controlled systems work (digital 
wire is the idea of the virtualized fly-by-wire control process with the 
computers running these as the digital agent).

     2)    Location Data to be digitally signed  - how is each map 
content section authenticated and communicated to other systems.

     3)    Special Notes - restrictions from Navagation, Specific 
Customs Rules and Points of Contact for these agencies.

Todd

> email: [email-masked] <mailto:[email-masked]>
> Phone: +44 705 005 2931
> Twitter: @futureidentity
>
>
>
>
>>> That matches what I've observed, too.  Another way to think of it is 
>>> this: if you display an image, (0,0) is the top left hand corner, 
>>> and the co-ordinates increase as you go down and right.
>>>

---

From: tglassey <[email-masked]>
Date: Thu, 06 Sep 2012 06:58:13 -0700

On 9/6/2012 6:57 AM, tglassey wrote:
>> orientation of script… (so, for instance, a map with Arabic text 
>> would still express co-ordinates the same way as a map with English 
>> text, but the text on the map would be oriented as 'normal for that 
>> language'...)
>
> meridian to Paris - so there are two specific types of Admiralty 
> charts today - those with Greenwich as the meridian and those with 
> Paris as the 0 point on the mapping system.
>
> Automation *(silly things like autonav on Hatvester 
err "Harvester Combines" (SIC)
> Combines for instance is a key function here) so these are really 
> important to the larger issue of how these  digital-wire controlled 
> systems work (digital wire is the idea of the virtualized fly-by-wire 
> control process with the computers running these as the digital agent).
>
>>>> That matches what I've observed, too.  Another way to think of it 
>>>> is this: if you display an image, (0,0) is the top left hand 
>>>> corner, and the co-ordinates increase as you go down and right.
>>>>

---

From: Robin Wilton <[email-masked]>
Date: Thu, 6 Sep 2012 15:14:45 +0100

Zut alors… ces sacrés Français! ;^) [Though actually, according to the BIPM website, Greenwich was agreed as 'the initial meridian for longitude' in 1884]

I think the principle still holds, though: the direction of text is independent of the co-ordinate convention.

I think your other points are extremely good questions - and they go way beyond my expertise, so I will defer to anyone who knows what they are talking about.

R

Robin Wilton

email: [email-masked]
Phone: +44 705 005 2931
Twitter: @futureidentity

On 6 Sep 2012, at 14:57, tglassey wrote:

> Except that the French (through the BIPM) moved the zero-crossing meridian to Paris - so there are two specific types of Admiralty charts today - those with Greenwich as the meridian and those with Paris as the 0 point on the mapping system. 
> 
> Do we support both?  If so doesnt it make sense to support an open mapping format which allows the 
> 
>                 a)    Mapping Definition to be disclosed in the process. This way we can include any maps and any process for their interpretation we want to. 
>                 c)    Its issuing authority and its dates of effectivity/validity - this  is critical since these MAPS will become Wireframe Tools and will be used in all types of Navigation, Process Automation *(silly things like autonav on Hatvester Combines for instance is a key function here) so these are really important to the larger issue of how these  digital-wire controlled systems work (digital wire is the idea of the virtualized fly-by-wire control process with the computers running these as the digital agent).
> 
>     2)    Location Data to be digitally signed  - how is each map content section authenticated and communicated to other systems. 
> 
>     3)    Special Notes - restrictions from Navagation, Specific Customs Rules and Points of Contact for these agencies.
> 
> Todd
> 
>> 
>> R
>>  
>> Robin Wilton

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 6 Sep 2012 10:22:16 -0400

This is draft-ietf-geopriv-relative-location.  Base location uses a datum and geoid, which, because this is an extension to PIDF-LO, is constrained to be WGS-84.  Relative location doesn't have an independent datum.

In this specific part of the document, we're not even discussing the location, but a map on which the location can be displayed.  We're not discussing things that are measured in degrees or meters, but in map coordinates, often raster lines.

There are no language specific modifications to plotting locations on a map.  There are not even any nation-specific modifications to plotting locations on a map.

We're not specifying how the map is controlled.  It's just an optional aid for visualization, not navigation.

Brian

On Sep 6, 2012, at 9:57 AM, tglassey <[email-masked]<mailto:[email-masked]>> wrote:

Todd

R

Robin Wilton

email: [email-masked]<mailto:[email-masked]>
Phone: +44 705 005 2931
Twitter: @futureidentity

Todd

_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Marc Berryman <[email-masked]>
Date: Thu, 6 Sep 2012 14:53:23 +0000

I think among some there is confusion over a map and the complex relational spatial data may also be used to display a two dimensional graphic view of parts of that data as a map.

Marc

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rosen, Brian
Sent: Thursday, September 06, 2012 9:22 AM
To: tglassey
Cc: [email-masked]
Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

Brian

On 9/6/2012 6:43 AM, Robin Wilton wrote:
I'm no expert, but as far as I'm aware, in both images and maps, the convention about co-ordinates is distinct from any convention about orientation of script... (so, for instance, a map with Arabic text would still express co-ordinates the same way as a map with English text, but the text on the map would be oriented as 'normal for that language'...)

Todd

R

Robin Wilton

Todd

--

________________________________

Checked by AVG - www.avg.com<http://www.avg.com>
Version: 2012.0.2197 / Virus Database: 2437/5252 - Release Date: 09/06/12

---

From: "Carl Reed" <[email-masked]>
Date: Thu, 6 Sep 2012 09:25:07 -0600

Robin -

Your assessment is correct. I have worked GIS and SDI apps in dozens of 
countries. Conventions for expressing coordinates and images are consistent 
on a global basis. Further, there are ISO and other standards that address 
these conventions:

http://en.wikipedia.org/wiki/ISO_6709 for coordinates. There are now GML 
examples :-)
portal.opengeospatial.org/files/?artifact_id=7200 for image coordinates and 
transformations. Harmonized with ISO and IEC standards.

There are also international cartographic conventions for annotation, 
although these tend to be specified as best practices for specific domains, 
such as for aviation, meteorology or geology.

http://www.docstoc.com/docs/49633518/Cartography-at-the-International-Civil-Aviation-Organization 
provides an overview of the charting and cartographic standards for the 
aviation industry.

Cheers

Carl

From: Robin Wilton
Sent: Thursday, September 06, 2012 7:43 AM
To: tglassey
Cc: [email-masked]
Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

I'm no expert, but as far as I'm aware, in both images and maps, the 
convention about co-ordinates is distinct from any convention about 
orientation of script… (so, for instance, a map with Arabic text would still 
express co-ordinates the same way as a map with English text, but the text 
on the map would be oriented as 'normal for that language'...)

R

Robin Wilton

email: [email-masked]
Phone: +44 705 005 2931
Twitter: @futureidentity

Todd

---

From: tglassey <[email-masked]>
Date: Thu, 06 Sep 2012 12:51:17 -0700

On 9/6/2012 7:22 AM, Rosen, Brian wrote:
> This is draft-ietf-geopriv-relative-location.  Base location uses a 
> datum and geoid, which, because this is an extension to PIDF-LO, is 
> constrained to be WGS-84.  Relative location doesn't have an 
> independent datum.
>
> In this specific part of the document, we're not even discussing the 
> location, but a map on which the location can be displayed.  We're not 
> discussing things that are measured in degrees or meters, but in map 
> coordinates, often raster lines.
>
> There are no language specific modifications to plotting locations on 
> a map.  There are not even any nation-specific modifications to 
> plotting locations on a map.
Meaning that the authority of who is asserting the map data is correct 
is ignored...
>
> We're not specifying how the map is controlled.
Then there is no purpose to this process.
>  It's just an optional aid for visualization, not navigation.
The navigation is done by the human idiot reading the visualization data 
or by an agent which digests it and then uses it for navigation. This is 
the problem with the technology today... it is used for everything you 
swear its not intended for and the issue is we ARE responsible for that.

IMHO -  The issue is we dont need another standard but a set of rules 
for the use of the existing ones. Like the ELID from e911 as a location 
pointer for instance. Also how does RFC 4726 and 3825 fit into all of this?

Todd

>> larger issue of how these  digital-wire controlled systems work 
>> (digital wire is the idea of the virtualized fly-by-wire control 
>> process with the computers running these as the digital agent).
>>
>> [email-masked] <mailto:[email-masked]>
> Checked by AVG - www.avg.com <http://www.avg.com>
> Version: 2012.0.2197 / Virus Database: 2437/5251 - Release Date: 09/05/12
>