Subject: grow: I-D ACTION:draft-ietf-grow-mrt-01.txt

From: [email-masked]
Date: Wed, 26 Oct 2005 18:50:02 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Global Routing Operations Working Group of the IETF.

	Title		: MRT routing information export format
	Author(s)	: L. Blunk, et al.
	Filename	: draft-ietf-grow-mrt-01.txt
	Pages		: 19
	Date		: 2005-10-26
	
This document describes the MRT format for routing information
   export.  This format was developed in concert with the Multi-threaded
   Routing Toolkit (MRT) from whence the format takes it name.  The
   format can be used to export routing protocol messages, state
   changes, and routing information base contents.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-grow-mrt-01.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-grow-mrt-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-grow-mrt-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Larry J. Blunk" <[email-masked]>
Date: Thu, 27 Oct 2005 14:48:08 -0400

A new MRT draft is now up.  Diffs can be found at --
http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=http://tools.ietf.org/id/draft-ietf-grow-mrt-00.txt&url2=http://tools.ietf.org/id/draft-ietf-grow-mrt-01.txt

    This updated draft adds a new OSPF type (OSPF_ET) which includes
both OSPFv3 (IPv6) and microsecond time resolution support.  This the microsecond
support for OSPF was requested by Simon Leinen.

   The draft also adds a minimal security considerations section and removes a bit
extraneous text in the document.

   One issue I did not address was 32-bit AS numbers.   How do people feel about
creating a new BGP type to allow these now that the 4byte AS draft is moving forward.

 -Larry Blunk
  Merit
_________________________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/grow.html
web archive:        http://darkwing.uoregon.edu/~llynch/grow/

---

From: Geoff Huston <[email-masked]>
Date: Mon, 31 Oct 2005 03:33:12 +1100

I'd suggest add it and ship it - 4 byte AS numbers are not in any doubt and
moving a draft on through the process is always (*) better than having it hang
around

(*) well almost always :-)

    Geoff

At 12:47 AM 31/10/2005, Pekka Savola wrote:
>On Thu, 27 Oct 2005, Larry J. Blunk wrote:
>It depends on:
>  - whether the current spec is assumed to document the
>    implementation(s) out there, or something they should/could be
>    doing after at some point in the future,
>  - how mature folks think the current MRT spec is, and
>  - what's its expected lifetime.
>
>If it's OK to wait 3..6 months or even longer to make sure 4byte-AS draft 
>stabilizes first, and there's no hurry to get the spec out, sure..
>
>--
>Pekka Savola                 "You each name yourselves king, yet the
>Netcore Oy                    kingdom bleeds."
>Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Pekka Savola <[email-masked]>
Date: Sun, 30 Oct 2005 15:47:59 +0200 (EET)

It depends on:

If it's OK to wait 3..6 months or even longer to make sure 4byte-AS 
draft stabilizes first, and there's no hurry to get the spec out, 
sure..

---

From: Pekka Savola <[email-masked]>
Date: Sun, 30 Oct 2005 23:17:12 +0200 (EET)

> moving a draft on through the process is always (*) better than having it 

While I don't doubt 4 byte AS numbers is going to go through in some 
form, it is not 100% certain whether there won't be changes (such as a 
different way to encode the numbers in the attributes) which might 
require different approach in MRT format.

The MRT draft may or may not have sufficient abstraction that this is 
not a problem (I haven't looked at the draft).