Subject: [GROW] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

From: Rob Shakir <[email-masked]>
Date: Sun, 20 Feb 2011 21:21:37 +0000

Hi GROW/IDR [0],

One of the problems faced by those operators utilising BGP at the current time are the limited error handling mechanisms that exist within the protocol.  This continues to cause numerous issues, especially with the evolution of BGP-4 within autonomous systems as the signalling protocol of choice.  Where existing work items do exist, in some places they do not completely meet the requirements of modern service provider networks.  This is particularly the case where some compromise to "protocol correctness" is required to meet the robustness requirements.

To this end, the draft forwarded below intends to describe the use cases, and requirements for enhancements to the BGP-4 protocol to meet the robustness requirements of modern SP networks.  In general, most work items are already captured by existing drafts, but my require some extension to meet the requirements specified.  The draft has been presented to a number of operational communities [1], and feedback solicited as to the utility, in general, the feedback I have received is that the approach specified captures the general operational requirements for enhancements to error handling in BGP.

To the end of producing a requirements document to which other work items can be directed, I would very much welcome feedback on this draft from the GROW and IDR communities.

Many thanks in advance for your review.

Kind regards,
Rob

[0]: Please excuse this mail being sent to multiple lists, whilst the majority of the work described within the draft is within the IDR area currently, it was pointed out to me that this draft is perhaps better within the GROW space.  If there are any comments, especially from the relevant WG chairs, I'd be happy to take some guidance as to where this is most suitably discussed.

[1]: Particularly, this draft was presented at NANOG and UKNOF - the slides can be found at http://nanog.org/meetings/nanog51/presentations/Tuesday/shakir-bgp-error-handling_rob-shakir-FINAL2.pdf - I am hoping that I can make a video of the presentation available within a couple of days if this is of interest.

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]]
Sent: Sun 2/20/2011 9:03 PM
To: Shakir, Rob
Subject: New Version Notification for          draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

A new version of I-D, draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt has been successfully submitted by Rob Shakir and posted to the IETF repository.

Filename:	 draft-shakir-idr-ops-reqs-for-bgp-error-handling
Revision:	 01
Title:		 Operational Requirements for Enhanced Error Handling Behaviour in BGP-4
Creation_date:	 2011-02-20
WG ID:		 Independent Submission
Number_of_pages: 22

Abstract:
BGP-4 is utilised as a key intra- and inter-Autonomous System routing
protocol in modern IP networks.  The failure modes as defined by the
original protocol standards are based on a number of assumptions
around the impact of session failure.  Numerous incidents both in the
global Internet routing table and within Service Provider networks
have been caused by strict handling of a single invalid UPDATE
message causing large-scale failures in one or more Autonomous
Systems.

This memo describes the current use of BGP-4 within Service Provider
networks, and outlines a set of requirements for further work to
enhance the mechanisms available to a BGP-4 implementation when
erroneous data is detected.  Whilst this document does not provide
specification of any standard, it is intended as an overview of a set
of enhancements to BGP-4 to improve the protocol's robustness to suit
its current deployment.

The IETF Secretariat.

---

From: Russell Heilling <[email-masked]>
Date: Tue, 22 Feb 2011 15:49:12 +0000

I agree 100%.  As the document points out there are a lot of
individual efforts to improve the situation currently within the IDR
and GROW scope.  Having a clear requirements document is essential to
make sure that these efforts are all going in the right direction and
that all concerns are addressed.

Regards,

Russell

On 22 February 2011 14:50, Neil J. McRae <[email-masked]> wrote:
> Rob,
> This is a great document and as a network operator I think this is
> something that I'd like to see implemented. The downsides of a minute
> inconsistency are not great enough compared to a complete BGP failure with
> my organisations network*
>
> Regards,
> Neil.
> (* which in the last 10 years I've had way too many times).
>
> On 20/02/2011 21:21, "Rob Shakir" <[email-masked]> wrote:
>
>>Hi GROW/IDR [0],
>>
>>One of the problems faced by those operators utilising BGP at the current
>>time are the limited error handling mechanisms that exist within the
>>protocol.  This continues to cause numerous issues, especially with the
>>evolution of BGP-4 within autonomous systems as the signalling protocol
>>of choice.  Where existing work items do exist, in some places they do
>>not completely meet the requirements of modern service provider networks.
>> This is particularly the case where some compromise to "protocol
>>correctness" is required to meet the robustness requirements.
>>
>>To this end, the draft forwarded below intends to describe the use cases,
>>and requirements for enhancements to the BGP-4 protocol to meet the
>>robustness requirements of modern SP networks.  In general, most work
>>items are already captured by existing drafts, but my require some
>>extension to meet the requirements specified.  The draft has been
>>presented to a number of operational communities [1], and feedback
>>solicited as to the utility, in general, the feedback I have received is
>>that the approach specified captures the general operational requirements
>>for enhancements to error handling in BGP.
>>
>>To the end of producing a requirements document to which other work items
>>can be directed, I would very much welcome feedback on this draft from
>>the GROW and IDR communities.
>>
>>[0]: Please excuse this mail being sent to multiple lists, whilst the
>>majority of the work described within the draft is within the IDR area
>>currently, it was pointed out to me that this draft is perhaps better
>>within the GROW space.  If there are any comments, especially from the
>>relevant WG chairs, I'd be happy to take some guidance as to where this
>>is most suitably discussed.
>>
>>[1]: Particularly, this draft was presented at NANOG and UKNOF - the
>>slides can be found at
>>http://nanog.org/meetings/nanog51/presentations/Tuesday/shakir-bgp-error-h
>>andling_rob-shakir-FINAL2.pdf - I am hoping that I can make a video of
>>the presentation available within a couple of days if this is of interest.
>>
>>Subject: New Version Notification for
>>draft-shakir-idr-ops-reqs-for-bgp-error-handling-01
>>
>>
>>A new version of I-D,
>>draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt has been
>>successfully submitted by Rob Shakir and posted to the IETF repository.
>>
>>_______________________________________________
>>Idr mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/idr
>
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

-- 
Russell Heilling                        http://perlmonkey.blogspot.com
"The amazing ability of the bee to adapt herself often helps the
 beekeeper to overcome the results of his ignorance." - Brother Adam

---

From: Colin Petrie <[email-masked]>
Date: Wed, 23 Feb 2011 09:24:43 +0000

> my organisations network*

I totally agree. This document is a pretty good summary of the
requirements on this, and a reasonable suggested implementation to
mitigate the problems we have seen before too many times.

Great work, thanks Rob :)

Cheers
Colin

---

From: "Smith, Donald" <[email-masked]>
Date: Wed, 23 Feb 2011 09:32:30 -0700

+1 reasonable bgp error handling (rather then dropping sessions and flushing routes) is a good idea.

Ignorance is Bliss. "Bliss (Basic Language for Implementation of System Software) was a
systems programming language originally for the PDP-10 and DECsystem-20 written at CMU." K-Oberman
[email-masked]

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Colin Petrie
> Sent: Wednesday, February 23, 2011 2:25 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [GROW] [Idr] Fwd: New Version Notification for draft-
> shakir-idr-ops-reqs-for-bgp-error-handling-01
>
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

This communication is the property of Qwest and may contain confidential or
privileged information. Unauthorized use of this communication is strictly
prohibited and may be unlawful.  If you have received this communication
in error, please immediately notify the sender by reply e-mail and destroy
all copies of the communication and any attachments.

---

From: Chris White <[email-masked]>
Date: Wed, 23 Feb 2011 14:57:17 -0800

+1

Chris

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 24 Feb 2011 06:56:47 +0100

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris White
Sent: woensdag 23 februari 2011 23:57
To: Smith, Donald
Cc: [email-masked]; [email-masked]
Subject: Re: [GROW] [Idr] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

+1

Chris

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 24 Feb 2011 00:59:31 -0500

+1

Regards,
Jeff  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, February 23, 2011 21:57
To: Chris White; Smith, Donald
Cc: [email-masked]; [email-masked]
Subject: Re: [Idr] [GROW] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris White
Sent: woensdag 23 februari 2011 23:57
To: Smith, Donald
Cc: [email-masked]; [email-masked]
Subject: Re: [GROW] [Idr] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

+1

Chris

---

From: Renwei li <[email-masked]>
Date: Fri, 25 Feb 2011 16:44:32 +0000

+1

Renwei

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, February 23, 2011 9:57 PM
To: Chris White; Smith, Donald
Cc: [email-masked]; [email-masked]
Subject: Re: [GROW] [Idr] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris White
Sent: woensdag 23 februari 2011 23:57
To: Smith, Donald
Cc: [email-masked]; [email-masked]
Subject: Re: [GROW] [Idr] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

+1

Chris

---

From: Warren Kumari <[email-masked]>
Date: Fri, 25 Feb 2011 17:54:57 -0500

<aol>

Me too!

</aol>
On Feb 25, 2011, at 11:44 AM, Renwei li wrote:

>>>> inconsistency are not great enough compared to a complete BGP  
>>>> failure
>>> with