Subject: [GROW] [2nd Try] new draft of private IP in SP core

From: Anthony Kirkham <[email-masked]>
Date: Tue, 03 May 2011 09:16:35 +1000

Hi,

As I mentioned in my last email I had been working on this for a while 
with slow progress. People had indicated to me this draft was 
worthwhile. I'd appreciate any feedback.

Filename:	 draft-kirkham-private-ip-sp-cores
Revision:	 03
Title:		 Issues with Private IP Addressing in the Internet
Creation_date:	 2011-04-15
WG ID:		 Independent Submission
Number_of_pages: 12

Regards
Tony K
-- 

*Anthony Kirkham*
*Solution Architect

***World Wide Security
Service Practice
**
[email-masked] <mailto:[email-masked]>
Phone: *+61 (0)7 3238 8203*
Mobile: *+61 (0)401 890 494*

CISSP, CCIE# - 1378

**

Level 12, 300 Adelaide Street
Brisbane, Qld, 4000
Australia
Cisco home page <http://www.cisco.com/global/AU/>

---

From: Anton Ivanov <[email-masked]>
Date: Wed, 04 May 2011 10:44:13 +0100

Looks good on first read.

As people start to scrape the bottom of the barrel for IPv4 addresses, 
best practice and informative documents like this will become very useful.

Best Regards,

On 03/05/11 00:16, Anthony Kirkham wrote:
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>

---

From: Arturo Servin <[email-masked]>
Date: Wed, 4 May 2011 09:20:11 -0300

Anthony,

	Very interesting reading and you documented well the variety of problems in using IP private space in the core.

	I have some comments:

1) In the note:

"Note:  The practice of ISPs using 'stolen' address space has many of
   the same issues (or effects) as that of using private IP address
   space within core networks … "

Perhaps it is a good idea to add that even though it is not discussed in the document this is a bad practice.

2) May be it is just me and writing style, but 11 sections are too many. To me it was difficult to separate in the document when you are referring to the use, the effects or the possible solutions on using private space. Instead of a flat document, I would suggest to add some main sections to group topics. For example:

Uses of Private Address space
	- Conservation of Address Space
	- Security Arguments for a Privately Addressed Core

Effects of using  Private Address space
	- Traceroute
	- Path MTU Discovery
	- Unexpected interactions with some NAT implementations
	- Interactions with edge anti-spoofing techniques
	- Peering using loopbacks
	- DNS Interaction
	- Operational and Troubleshooting issues

	Section 11 and 12 are probably good candidates to fill "Security Considerations".

Best regards,
.as

Arturo Servin

On 2 May 2011, at 20:16, Anthony Kirkham wrote:

> Hi,
> 
> As I mentioned in my last email I had been working on this for a while with slow progress. People had indicated to me this draft was worthwhile. I'd appreciate any feedback.
> 
> Anthony Kirkham
> Solution Architect
> World Wide Security
> [email-masked] 
> Phone: +61 (0)7 3238 8203
> Mobile: +61 (0)401 890 494
> 
> CISSP, CCIE# - 1378
> 
> 
> 
> Cisco home page

---

From: Arturo Servin <[email-masked]>
Date: Wed, 4 May 2011 09:30:34 -0300

Anthony,

	Also, in section 8 you can add a reference to:

http://tools.ietf.org/html/draft-ietf-dnsop-as112-ops-08

	I imagine that some of these host are trying to make reverse lookups.

Regards,
.as