Subject: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

From: [email-masked]
Date: Thu, 12 May 2011 15:15:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Global Routing Operations Working Group of the IETF.

	Title           : Time to Remove Filters for Previously Unallocated IPv4 /8s
	Author(s)       : L. Vegoda
	Filename        : draft-ietf-grow-no-more-unallocated-slash8s-01.txt
	Pages           : 6
	Date            : 2011-05-12

It has been common for network administrators to filter IP traffic
from and BGP prefixes of unallocated IPv4 address space.  Now that
there are no longer any unallocated IPv4 /8s, this practise is more
complicated, fragile and expensive.  Network administrators are
advised to remove filters based on the registration status of the
address space.

This document explains why any remaining packet and BGP prefix
filters for unallocated IPv4 /8s should now be removed on border
routers and documents those IPv4 unicast prefixes that should not be
routed across the public Internet.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 26 May 2011 14:23:41 -0400

Grow-Folk,
Leo rev'd the doc with some changes to hopefully meet comments
received, if the commenters could verify that their needs are met I
think we can ask for a short (1wk?) WGLC run and seeing no other
dissent move this along to the IESG.

have a read and a look at the diff:
<http://tools.ietf.org/wg/grow/draft-ietf-grow-no-more-unallocated-slash8s/draft-ietf-grow-no-more-unallocated-slash8s-01-from-00.diff.html>

if you please.

-Chris

On Thu, May 12, 2011 at 6:15 PM,  <[email-masked]> wrote:
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>
>

---

From: "George, Wesley" <[email-masked]>
Date: Fri, 27 May 2011 08:27:27 -0400

The only additional comment I have is that there may be one more non-IANA-reserved unrouted space to add to the list.

ARIN AC has recommended that the ARIN board adopt the policy (2011-5) reserving a /10 to be used as shared address space (specifically for internal NAT pools in a CGN application). We might want to recommend filtering that.

However, I don't want to delay the draft from going through the process while they sort this out, because ARIN still needs to work with IESG to sort out how they do this, since normally number reservations come from IETF -> IANA. You'd have to reach out to Curran to see if they have an idea of what block they're going to reserve (assuming there are no additional roadblocks) so that you can document it in this draft. If he doesn't know the specific block, he may at least be able to give you a pointer to where they are going to document what it is once it's formally reserved - I assume they'll make it fairly clear on the ARIN website.

Wes George

P.S. - Please, PLEASE don't turn this into a discussion on the merits of the ARIN proposal or CGN. I'm just the messenger.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Thursday, May 26, 2011 2:24 PM
To: [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Grow-Folk,

if you please.

-Chris

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Ricardo Patara <[email-masked]>
Date: Fri, 27 May 2011 11:04:39 -0300

Rereading the draft, I notice there is no mention to 192.168/16 (10/8 and 172.16/12 are there).
Any specific reason?

Regards,
Ricardo

---

From: Leo Vegoda <[email-masked]>
Date: Fri, 27 May 2011 07:33:48 -0700

Hi Ricardo,

All three RFC 1918 blocks are listed in section 4. Do you believe they need additional explanatory text?

Thanks,

Leo 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ricardo Patara
Sent: Friday, May 27, 2011 7:05 AM
To: George, Wesley
Cc: [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Regards,
Ricardo

---

From: Ricardo Patara <[email-masked]>
Date: Fri, 27 May 2011 13:00:20 -0300

Sorry, my bad. 
I was looking at the "diff" page with the two versions comparison, and they don't show the complete text.

Regards

---

From: Leo Vegoda <[email-masked]>
Date: Fri, 27 May 2011 09:32:32 -0700

Hi George,

The ARIN web site indicates that the policy would be implemented immediately if it is adopted by ARIN's BoT. If that is the case, a prefix to include should be made known in short order and could be included in a revision this document very quickly, too. 

Thanks,

Leo 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of George, Wesley
Sent: Friday, May 27, 2011 5:27 AM
To: Christopher Morrow; [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Wes George

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Thursday, May 26, 2011 2:24 PM
To: [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Grow-Folk,

if you please.

-Chris

---

From: "George, Wesley" <[email-masked]>
Date: Fri, 27 May 2011 13:13:15 -0400

Copying John Curran. I'm paraphrasing some guidance he gave before when I said that it had to go through IESG first, so it'd probably be better to get an update directly from him. The policy proposals always say either "immediate" or some sort of trigger date as to the timeline for implementation. This is more of an implementation detail that has to be worked out, so I'm unsure of the timeline.
Perhaps some placeholder text can go in the draft so that it can be updated during IETF last call or IESG review if a block hasn't been identified yet. 

John - does ARIN know what prefix you'd be reserving for 2011-5 yet? We'd like to include in this draft along with the other reserved prefixes.

Wes

-----Original Message-----
From: Leo Vegoda [mailto:[email-masked]] 
Sent: Friday, May 27, 2011 12:33 PM
To: George, Wesley; Christopher Morrow; [email-masked]; [email-masked]
Subject: RE: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Hi George,

Thanks,

Leo 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of George, Wesley
Sent: Friday, May 27, 2011 5:27 AM
To: Christopher Morrow; [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Wes George

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Thursday, May 26, 2011 2:24 PM
To: [email-masked]; [email-masked]
Subject: Re: [GROW] I-D Action:draft-ietf-grow-no-more-unallocated-slash8s-01.txt

Grow-Folk,

if you please.

-Chris