Subject: [GROW] I-D Action: draft-ietf-grow-route-leak-problem-definition-03.txt

From: [email-masked]
Date: Mon, 12 Oct 2015 19:37:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Global Routing Operations Working Group of the IETF.

        Title           : Problem Definition and Classification of BGP Route Leaks
        Authors         : Kotikalapudi Sriram
                          Doug Montgomery
                          Danny McPherson
                          Eric Osterweil
                          Brian Dickson
	Filename        : draft-ietf-grow-route-leak-problem-definition-03.txt
	Pages           : 11
	Date            : 2015-10-12

Abstract:
   A systemic vulnerability of the Border Gateway Protocol routing
   system, known as 'route leaks', has received significant attention in
   recent years.  Frequent incidents that result in significant
   disruptions to Internet routing are labeled "route leaks", but to
   date we have lacked a common definition of the term.  In this
   document, we provide a working definition of route leaks, keeping in
   mind the real occurrences that have received significant attention.
   Further, we attempt to enumerate (though not exhaustively) different
   types of route leaks based on observed events on the Internet.  We
   aim to provide a taxonomy that covers several forms of route leaks
   that have been observed and are of concern to Internet user community
   as well as the network operator community.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-grow-route-leak-problem-definition/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-grow-route-leak-problem-definition-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-grow-route-leak-problem-definition-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Tue, 13 Oct 2015 02:58:26 +0000

This version (draft-ietf-grow-route-leak-problem-definition-03) 
is a significantly revised and updated draft relative to version-02.
The document (version-02) was in WGLC in the GROW WG.
Many thanks to Charles, Jeff, Wes and Andrei for their
review, comments, and support in response to WGLC 
in GROW (it was cross posted to IDR as well). 
The authors have considered all their comments/suggestions in revising this draft, 
and we feel that it has significantly benefited  from their recent review/re-review. 

Cross posting this message to the IDR list because 
there has been some interest in this document in IDR as well.
A companion draft on route leaks solution is currently a WG draft in IDR.   

Sriram

________________________________________
From: GROW <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Monday, October 12, 2015 10:37 PM
To: [email-masked]
Cc: [email-masked]
Subject: [GROW] I-D Action:     draft-ietf-grow-route-leak-problem-definition-03.txt

Abstract:

_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 14 Oct 2015 10:52:46 -0400

> and we feel that it has significantly benefited  from their recent review/re-review. 

Thanks, Sriram.  You've addressed my comments.

Should there be an additional edits, I'd suggest removing "subprefix" and
consistently using "more specific prefix".  

-- Jeff

---

From: Rick Casarez <[email-masked]>
Date: Thu, 15 Oct 2015 14:20:24 -0400

I would concur on Jeff's suggestion.

Otherwise I like the draft.

-------------------
Cheers, Rick

Experiences not things.

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Sun, 1 Nov 2015 02:51:59 +0000

Rick,

Jeff,

> consistently using "more specific prefix".

Thanks. No problem. I will plan to take care of this change in the next revision

along with a few other comments that have been shared recently on the GROW list.

Sriram

________________________________
From: Rick Casarez <[email-masked]>
Sent: Thursday, October 15, 2015 2:20 PM
To: Jeffrey Haas
Cc: Sriram, Kotikalapudi; idr wg list; [email-masked]; Charles van Niman; Andrei Robachevsky ([email-masked])
Subject: Re: [GROW] I-D Action: draft-ietf-grow-route-leak-problem-definition-03.txt

-------------------
Cheers, Rick

Experiences not things.

On Wed, Oct 14, 2015 at 10:52 AM, Jeffrey Haas <[email-masked]<mailto:[email-masked]>> wrote:

-- Jeff

_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow