Subject: [GROW] I-D Action: draft-ietf-grow-bmp-16.txt

From: [email-masked]
Date: Thu, 12 Nov 2015 13:15:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Global Routing Operations Working Group of the IETF.

        Title           : BGP Monitoring Protocol
        Authors         : John Scudder
                          Rex Fernando
                          Stephen Stuart
	Filename        : draft-ietf-grow-bmp-16.txt
	Pages           : 26
	Date            : 2015-11-12

Abstract:
   This document defines a protocol, BMP, that can be used to monitor
   BGP sessions.  BMP is intended to provide a convenient interface for
   obtaining route views.  Prior to introduction of BMP, screen-scraping
   was the most commonly-used approach to obtaining such views.  The
   design goals are to keep BMP simple, useful, easily implemented, and
   minimally service-affecting.  BMP is not suitable for use as a
   routing protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-grow-bmp/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-grow-bmp-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-grow-bmp-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 12 Nov 2015 16:27:44 -0500

Hi Everybody,

Version 16 resolves (or attempts to resolve!) all comments received during IESG review. To summarize the changes:

- The final paragraph of section 3.2 seemed to say the monitoring station could send a Termination message to the router. Since the monitoring station never sends messages, that didn't make sense. Removed the text.
- Renamed "L3 VPN Instance Peer" as "RD Instance Peer" and wrote explanatory text clarifying that this type works for any kind of peer partly identified by a RD.
- Added a new peer type, "Local Instance Peer" to cover the case where a routing instance isn't identified with an RD. It's a pretty unlikely corner case to be unable to make the peer unique using the combination of Peer Address, Peer AS and Peer BGP ID, but it's not impossible. This fixes the corner case.
- Specified that reserved bits must be zero, must be ignored.
- Specified when Route Mirroring messages may be sent (it's any time you can send a Route Monitoring message).
- Added registries for BMP Peer Types and BMP Peer Flags, oops.
- Changed the final paragraph of the security considerations section to read "this document does not specify any security mechanism for BMP." Removed references to IPSec and TCP-AO.
- A few other small editorial changes, updated references, etc.

Thanks to all the reviewers,

--John

> On Nov 12, 2015, at 4:15 PM, [email-masked] wrote:
> 
>