Subject: Re: [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 2 Jul 2018 13:23:56 +0000

Hi Yunan, Shunwan, and Zhenbin, 

What are the advantages of inventing a new protocol over just using YANG and NETCONF, RESTCONF, or gNMI? Operators and vendors are doing this anyway. A second alternative would be to listen passively in IS-IS (or OSPF for that matter). Why would anyone want this? 

As far as where it belongs, we have a rather full agenda in LSR so I don't think we want to devote time to it there at IETF 102.  

Thanks,
Acee

On 7/2/18, 8:20 AM, "GROW on behalf of Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked] on behalf of [email-masked]> wrote:

    Dear GROW & OPSAWG WGs,
    
    We have proposed a Network Monitoring Protocol (NMP) for the control plane OAM. NMP for ISIS is illustrated in this draft to showcase the benefit and operation of NMP. Yet, we haven't decided which WG it belongs to. 

    Comments and suggestions are very welcome! 
    
    Thank you!

    Yunan Gu
    Huawei Technologies Co. Ltd
    
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] 
    Sent: 2018年7月2日 20:07
    To: Zhuangshunwan <[email-masked]>; Lizhenbin <[email-masked]>; Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>
    Subject: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

    A new version of I-D, draft-gu-network-mornitoring-protol-00.txt
    has been successfully submitted by Yunan Gu and posted to the IETF repository.
    
    Name:		draft-gu-network-mornitoring-protol
    Revision:	00
    Title:		Network Monitoring Protocol (NMP)
    Document date:	2018-07-02
    Group:		Individual Submission
    Pages:		15
    URL:            https://www.ietf.org/internet-drafts/draft-gu-network-mornitoring-protol-00.txt
    Status:         https://datatracker.ietf.org/doc/draft-gu-network-mornitoring-protol/
    Htmlized:       https://tools.ietf.org/html/draft-gu-network-mornitoring-protol-00
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-gu-network-mornitoring-protol

    Abstract:
       To enable automated network OAM (Operations, administration and
       management), the availability of network protocol running status
       information is a fundamental step.  In this document, a network
       monitoring protocol (NMP) is proposed to provision the information
       related to running status of IGP (Interior Gateway Protocol) and
       other control protocols.  It can facilitate the network
       troubleshooting of control protocols in a network domain.  Typical
       network issues are illustrated as the usecases of NMP for ISIS to
       showcase the necessity of NMP.  Then the operations and the message
       formats of NMP for ISIS are defined.  In this document ISIS is used
       as the illustration protocol, and the case of OSPF and other control
       protocols will be included in the future version.

    Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat
    
    _______________________________________________
    GROW mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/grow

---

From: Lizhenbin <[email-masked]>
Date: Tue, 3 Jul 2018 10:39:38 +0000

Hi Acee,
Thank for your attention to the new draft. Please refer to my reply inline.

Best Regards,
Robin

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Monday, July 02, 2018 9:24 PM
To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

What are the advantages of inventing a new protocol over just using YANG and NETCONF, RESTCONF, or gNMI? 
[Robin] In the draft we simply mention the difference between NMP and protocols you mentioned for the management plane. Though there is maybe some overlap between the two types of protocols, the protocols you mentioned is not enough for monitoring the control protocol. For example, would we like to use YANG and NETCONF, RESTCONF, or gNMI to export the packets of control protocols such as update message of BGP and/or ISIS PDU, etc. for the purpose of monitoring?

Operators and vendors are doing this anyway. A second alternative would be to listen passively in IS-IS (or OSPF for that matter). Why would anyone want this? 
[Robin] In fact we tried the method you proposed. From our point of view, the basic design principle should be that the monitoring entity should be decoupled from the monitored entity. This is to avoid following cases:
1. The failure of operation of the control protocol may affect the monitoring at the same time.
2. The limitation of the control protocol will also have effect on the monitoring. For example, for the method of listening passively, if there are multiple hops between the listener and the network devices, it has to set up a tunnel as the virtual link for direct connection. But the TCP-based monitoring protocol need not care about it. 

As far as where it belongs, we have a rather full agenda in LSR so I don't think we want to devote time to it there at IETF 102.  
[Robin] Though the WG the draft should belong to is not determined yet, we think the work belongs to OPS area and send the notice to GROW WG and OPSAWG. We also applied for the presentation in the two WGs. We should have copied the notice to the related WGs of RTG area. So the LSR WG and RTGWG WG mailing list are added. More comments and suggestions are welcome.

Thanks,
Acee

    Dear GROW & OPSAWG WGs,

    
    Thank you!

    Yunan Gu
    
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] 
    Sent: 2018年7月2日 20:07
    To: Zhuangshunwan <[email-masked]>; Lizhenbin <[email-masked]>; Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>
    Subject: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

    Abstract:

    
    The IETF Secretariat

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 3 Jul 2018 16:08:56 +0000

Hi Robin, 
I'm not arguing to deprecate BMP. What I am arguing is that the fact that BMP was created 15 years ago doesn't necessarily mean we should create an analogous IMP for IS-IS given the current IETF OPS technologies and the fact that faster link speeds and Moore's law facilitate deployment of these new OPS technologies. Anyway, I looked at the agenda and I will definitely attend GROW on Wednesday afternoon for the discussion. 
Thanks,
Acee 

On 7/3/18, 6:40 AM, "Lizhenbin" <[email-masked]> wrote:

    Hi Acee,
    
    Best Regards,
    Robin

    -----Original Message-----
    From: OPSAWG [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
    Sent: Monday, July 02, 2018 9:24 PM
    To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
    Subject: Re: [OPSAWG] [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

    
    Thanks,
    Acee

    
        Dear GROW & OPSAWG WGs,

        
        Thank you!

        Yunan Gu
        
        -----Original Message-----
        From: [email-masked] [mailto:[email-masked]] 
        Sent: 2018年7月2日 20:07
        To: Zhuangshunwan <[email-masked]>; Lizhenbin <[email-masked]>; Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>
        Subject: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

        Abstract:

        
        The IETF Secretariat

---

From: Randy Bush <[email-masked]>
Date: Tue, 03 Jul 2018 11:45:56 -0700

i am confused as why this is in grow.  it's protocol.

randy

---

From: Lizhenbin <[email-masked]>
Date: Wed, 4 Jul 2018 01:58:54 +0000

Hi Randy,
Since BMP is promoted in GROW WG, the work has much similarity with BMP. So we applied for the presentation here.

Best Regards,
Robin

-----Original Message-----
From: Randy Bush [mailto:[email-masked]] 
Sent: Wednesday, July 04, 2018 2:46 AM
To: Acee Lindem (acee) <acee=[email-masked]>
Cc: Lizhenbin <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

randy

---

From: Lizhenbin <[email-masked]>
Date: Thu, 5 Jul 2018 10:34:43 +0000

Hi Acee,
It is not described clearly in the draft that reusing BMP is also a possible option for monitoring IGP. We will refine the draft. 
Expect to have more discussion with you in IETF 102.

Thanks,
Robin

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, July 04, 2018 12:09 AM
To: Lizhenbin <[email-masked]>; [email-masked]; [email-masked]
Cc: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

Hi Robin, 

    Hi Acee,
    
    Best Regards,
    Robin

    -----Original Message-----
    From: OPSAWG [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
    Sent: Monday, July 02, 2018 9:24 PM
    To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
    Subject: Re: [OPSAWG] [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

    
    Thanks,
    Acee

    
        Dear GROW & OPSAWG WGs,

        
        Thank you!

        Yunan Gu
        
        -----Original Message-----
        From: [email-masked] [mailto:[email-masked]] 
        Sent: 2018年7月2日 20:07
        To: Zhuangshunwan <[email-masked]>; Lizhenbin <[email-masked]>; Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>
        Subject: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

        Abstract:

        
        The IETF Secretariat

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 5 Jul 2018 21:49:01 +0000

Hi Robin, 

On 7/5/18, 6:35 AM, "Lizhenbin" <[email-masked]> wrote:

    Hi Acee,

It doesn't matter where you put it, it is still an alternate paradigm for IS-IS management. 

I'm sure we will. I really don't think this meets the "stick to the wall" test for GROW. 

Thanks,
Acee 

    Thanks,
    Robin

    -----Original Message-----
    From: Acee Lindem (acee) [mailto:[email-masked]] 
    Sent: Wednesday, July 04, 2018 12:09 AM
    To: Lizhenbin <[email-masked]>; [email-masked]; [email-masked]
    Cc: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
    Subject: Re: [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt
    
    Hi Robin, 

        Hi Acee,
        
        Best Regards,
        Robin

        -----Original Message-----
        From: OPSAWG [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
        Sent: Monday, July 02, 2018 9:24 PM
        To: Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; [email-masked]
        Subject: Re: [OPSAWG] [GROW] FW: New Version Notification for draft-gu-network-mornitoring-protol-00.txt

        
        Thanks,
        Acee

        
            Dear GROW & OPSAWG WGs,

            
            Thank you!

            Yunan Gu
            
            -----Original Message-----

            Abstract:

            
            The IETF Secretariat

---

From: Randy Bush <[email-masked]>
Date: Thu, 05 Jul 2018 17:14:36 -0700

robin,

> It is not described clearly in the draft that reusing BMP is also a
> possible option for monitoring IGP. We will refine the draft.  

if i could also use bmp for monitoring dns, smtp, and ntp, i could
stop using nagios!

i think what acee is trying to say is that "B" in BMP does not stand
for Bypass.

randy

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 6 Jul 2018 11:32:08 +0200

​Why anyone would need BMP wrapper to monitor IGP ?

BGP has been recently polluted enough that it works just perfectly fine
without a new draft/rfc or single line of code change to act as IGP
monitoring protocol.

Just enable  AFI 16388 / SAFI 71 as described in RFC7752 (possibly with
many additional follow-up extensions being currently cooked) and ride on.

r.

---

From: Randy Bush <[email-masked]>
Date: Fri, 06 Jul 2018 05:59:22 -0700

> ​Why anyone would need BMP wrapper to monitor IGP ?

probably similar reasons that folk seem to need bgp-ls to get the
is-is/ospf databases.  is-is and ospf have decades of complexity
layered on un-simple bases.  so we seek yet another layer of gunk
through which to see them more 'simply.'

i would say an optimistic view might be that it will take a couple
more decades to gunk up bgp-ls and bmp so that we want yet another
layer.  but it would appear that my optimism is not warranted.

randy

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 6 Jul 2018 13:27:00 +0000

> On Jul 6, 2018, at 8:59 AM, Randy Bush <[email-masked]> wrote:
> 

Those who forget the past are condemned to repeat it…

Acee

> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr