Subject: Re: [GROW] FW: New Version Notification for draft-zhuang-grow-monitoring-bgp-parameters-00.txt

From: "Tim Evens (tievens)" <[email-masked]>
Date: Tue, 17 Jul 2018 16:27:04 +0000

Below are comments.

** Section 4, Extension of BMP Initiation Message:

I suppose there are two ways to encode bgp optional params and default behaviors. We could encode all in the single info TLV where the info length is the total length in bytes of all encoded sub-tlv's.  Alternatively, we could repeat the info TLV's where only a subset of the sub-tlv's are encoded.  BGP capabilities works this way today, which IMO is a bit of a pain because we have to support both.  IMHO, I would prefer to pick one.  For example, call out that only one TBD1 and TDB2 can be present in an init message.  This would require the single info TLV to encode all sub-tlv's. For example, info tlv TBD1 (bgp caps) length would encode all bgp caps as an array of param sub-tlv's.

TBD3 - TBD12 should probably refence (rfc/draft links) the attribute values indicated.  For example, local pref is well known and encoded as a 32-bit "unsigned" int.   This draft doesn't call out that it's unsigned or signed, but if we know it's referring to the local-pref attribute, then we know it's unsigned and the value range allowed.

Other than the above, it looks good from initial review.

Thanks,

Tim

On 7/2/18, 7:00 PM, "GROW on behalf of Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

    We have uploaded two drafts on BMP extensions.

    "draft-gu-grow-bmp-vpn-label" proposes the idea of using BMP to collect VPN labels for applications such as traffic optimization.

    "draft-zhuang-grow-monitoring-bgp-parameters" proposes to use BMP to collect BGP parameters: capacity and default behavior. The capacity parameters (both enabled and not enabled) are reported to the BMP server for better network optimization. The default behavior parameters, such as vendor-specific protocol preferences, are reported for multi-vendor interoperation.

    Comments and suggestions are welcome!

    Thanks!

    Yunan

---

From: Zhuangshunwan <[email-masked]>
Date: Wed, 18 Jul 2018 05:39:01 +0000

Hi Tim,

Thanks for your detailed review and good advice to this draft!

Reply inline marked [Shunwan]

Thanks,

Shunwan et al

From: Tim Evens (tievens) [mailto:[email-masked]]
Sent: Wednesday, July 18, 2018 12:27 AM
To: Zhuangshunwan <[email-masked]>; Guyunan (Yunan Gu, IP Technology Research Dept. NW) <[email-masked]>; [email-masked]; Mipenghui (Kevin Mi) <[email-masked]>; Lizhenbin <[email-masked]>; [email-masked]
Subject: Re: [GROW] FW: New Version Notification for draft-zhuang-grow-monitoring-bgp-parameters-00.txt

Below are comments.

[Shunwan] Good advice, we will list all the options in the next version and do a comparative analysis to choose a better option.

[Shunwan] Will add in the next version.

Thanks,

Tim

On 7/2/18, 7:00 PM, "GROW on behalf of Guyunan (Yunan Gu, IP Technology Research Dept. NW)" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    Hi all,

    Thanks!

    Yunan