Subject: VC Directionaility

From: 류호용 <[email-masked]>
Date: Sat, 15 Jul 2000 11:39:06 +0900

Hello, Avri Doria.

I suggest that VC-Directionality field be added to Port Type Specific Data Filed in Port Configuration Message.

   0                             1                             2                            3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4  5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |P|M|L|R|Q|D|label range count|          label range length       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                                                                                                |
   ~                      Label Range Block                                           ~
   |                                                                                                |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                       Receive Data Rate                                           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                      Transmit Data Rate                                           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |  Port Status    |   Line Type    |  Line Status    |  Priorities     |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |       Physical Slot Number      |     Physical Port Number      |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

VC Directionality
         A value specifying bidirectional VC capability, which means that the
         Switch can (within a given VPI) support the use of a given VCI as
         a label for both link directions independently.
         Or it specifies unidirectional  VC capability, which means (within a  
        given VPI) that a given VCI may be utilize for only one direction at  
        the link.

We develop MPLS system based on ATM switch using GSMP and LDP/CR-LDP Protocols. 

Label Allocation Procedure of LDP/CR-LDP Protocol is different according to the VC Directionality of Port. 

But, Currently GSMP Protocol doesnot have the field that indicates the VC directionality. 

LDP/CR-LDP don't know the VC-Directionality for Port. Current, LDP/CR-LDP assume that VC Directionality 

for Port has Bi-Direction capability. 

So, I suggest that one bit of Label Range field of Port Type Specific Data in Port Configuration Message

be deleted and Direction Field be added at the bit. 

How do you think about it? 

Best regards,
Hoyong Ryu.

================================================
Name  : Ryu Ho Yong
E-Mail : [email-masked]
FAX : +82-42-860-5440
Phone : +82-42-860-5364
Organization : Senior Member of Engineering Saff
                      MPLS Protocol Team, INTERNET Department,
                      Switching & Transmission Technology Lab.
                      ETRI (Electronic Telecommunication Research Institue)
================================================

---

From: "Avri Doria" <[email-masked]>
Date: Thu, 20 Jul 2000 10:27:42 -0400

Hi,

I was about to send the list a last call on the Spec when I received
your message.  I have been thinking about how to respond to this
request, and hoping that someone else on the list would have an 
opinion on the topic.

Personally I have a few concerns:

- I don't really think that halving the label count range is a good
idea. I know that even 127 label count ranges seems reasonable, but 
256 includes some insurance for the future or for extreme designs.  

-I think you are right that that this is an item that the switch should
include in the port configuration.  I would be  more likely to include
it in the general part of the message since it would not necessarily be 
an ATM specific issue. 

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|   PortType    |S|B|x|x|x|x|x|x|     Data Fields Length        |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   
B: if set indicates that switch is capable of using an individual
label as both an input and an output label in the same session.
(or since this may be the rule, a U flag could be defined as the
obverse)

-I am wondering if this constitutes a substantive change and whether 
I would need to recycle the draft due to this change.  If so, I should
recycle before  I start the last call.  Except for the fact that I
cannot
submit a new draft for a least 2 weeks and that would delay the process.
And I don't want to delay the last call - i.e. I want to initiate it
today
or tomorrow.

Opinions on all of the issues is invited.

thanks
a.

-- 

Avri Doria
+1 401 663 5024