Subject: RE: last call comments

From: Hans Sjöstrand (ETX)<[email-masked]>
Date: Wed, 23 Aug 2000 10:26:29 +0200

> >What  doesn't necessarily make sense is to require any particular 
> >switch to support both methods.  This needs to be handled by adding 
> >a phrase indicating the switches must adopt at least one of the two 
> >label types.
> >
> 
> If we do this then the controller must be able to discover 
> this from the
> switch (via the switch configuration message or some such.) 
> balaji
> 

This was a bad track that just will cause incomptibility. What happens if two boxes have chosen different encoding. Doesn't really matter if they discover early or late, it doesn't work anyway. 

The old slogan "Be liberal in what you accept, and conservative in what you send." must apply. Decoding TLV's is trivial programming, please retain both. 

/// Hasse

---

From: "Avri Doria" <[email-masked]>
Date: Wed, 23 Aug 2000 06:22:51 -0700

Hi,

Of course you are right.  Thank you for reminding me of
the liberal in acceptance motto.

While we could have used GSMP's normal method of sending
an error message about a capability not supported, I 
think that in this case you are right and both should be
required.

Does anyone else have a comment on this issue?

Thanks
a. 

-- 

Avri Doria
+1 401 663 5024

---

From: Balaji Srinivasan <[email-masked]>
Date: Wed, 23 Aug 2000 08:47:25 -0700 (PDT)

>Does anyone else have a comment on this issue?

Just this.
How important is backward compatibility, especially since the PDU format
has already chaged from v1 (the service capabilities etc).
Does making all labels TLVs help? I would think so. It would be
easier if there is not a lot of run time decisions. If we keep the old
format labels in will they help in backward compatibility? I dont think so
since the rest of the connection management PDU has already changed.

Thanks
balaji

 -- 
Balaji Srinivasan
[email-masked]
Control Plane Technologies