Subject: [GSMP] capability sets

From: avri <[email-masked]>
Date: Mon, 23 Jun 2003 23:24:24 +0900

the one in the base spec now, is technology specific, so it will
need to be moved to the packet based spec.

2 questions:

-should each technology have a specific capability
set definition.  i think so, but am interested in hearing other 
opinions.

-can it remain the fixed size?
[capset id, traffic flags]
[tech specific]
[tech specific]

the capset id would be subdivided to allow each technology
its own range.

or should it be variable?
i.e.
[capset id, length]
[flags, tech specific]
   .
   .
[tech specific]

opinions please?  i tend toward the fixed option,
but if there is a good reason for a variable length
block, please let me know.

i am especially interested in hearing from the
tech specific design teams.

thanks
a.

_______________________________________________
GSMP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gsmp

---

From: Kenneth Sundell <[email-masked]>
Date: Wed, 25 Jun 2003 10:22:52 +0200

hi,

avri wrote:

> set definition.  i think so, but am interested in hearing other opinions.

agree. i support the move to the packet spec.

> tech specific design teams.

speaking for the packet spec team, the fixed format should be fine. 
anyone seeing a need for further parameters in the capability sets 
should speak up at this point, it would justify adding the variable 
length option. otherwise i will just leave it as is stands. i guess the 
base spec wouldn't be impacted in either case since it won't define the 
capability set record format in the next revision (after the move to the 
packet spec).

cheers,
ken

-- 

Kenneth Sundell
Sr. Protocols Architect
CTO/ATI Strategic Protocols
Nortel Networks (Sweden)
ESN 521-3538, Ext IAC+46 8 5088-3538