Subject: [hiaps] FW: Hybrid access bar bof

From: <[email-masked]>
Date: Thu, 23 Jul 2015 21:16:22 +0200

Dear all,
We had a small meeting yesterday at lunch break (we'll report in some more detail later) but could try to use a chance to present our issues tomorrow morning at the HA barbof.
Whoever likes to join me there is welcome!
Thanks!
Best regards
Dirk
-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Donnerstag, 23. Juli 2015 20:42
To: von Hugo, Dirk
Subject: Hybrid access bar bof

Hi Dirk
Friday morning
At 8am margareth is organizing a bar bof At Budapest room I have another meeting I hope you can go

Behcet 

Sent from my iPhone

---

From: <[email-masked]>
Date: Tue, 28 Jul 2015 18:15:02 +0200

Dear all,
at IET93 in Prague we had a small informal meeting on hiaps issues discussing the NAT@RG use case with hybrid access (e.g. DSL+LTE) where for different access links and multiple devices (e.g. at home) behind the NAT a consistent and customer-configurable policy enforcement should be enabled. Some vendors say (e.g. A10 during bits'n'bytes) that in an SDN-based (vCPE) deployment this would be solved but I still like to see it working.
Also  at the 'hybrid aggregation bundling' barbof mentioned below we shortly presented our issues ...
I hope there will be more activity on that in future - also on more generic approaches towards FMC-related heterogeneous link bundling - perhaps also stimulating our discussions ;-)
Comments, corrections, and discussion welcome!
Best regards
Dirk
-----Original Message-----
From: hiaps [mailto:[email-masked]] On Behalf Of von Hugo, Dirk
Sent: Donnerstag, 23. Juli 2015 21:16
To: [email-masked]
Cc: [email-masked]
Subject: [hiaps] FW: Hybrid access bar bof

Dear all,
-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Donnerstag, 23. Juli 2015 20:42
To: von Hugo, Dirk
Subject: Hybrid access bar bof

Hi Dirk
Friday morning

Behcet 

Sent from my iPhone

_______________________________________________
hiaps mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hiaps

---

From: Olivier Bonaventure <[email-masked]>
Date: Wed, 29 Jul 2015 16:21:32 +0200

Dirk,

> I hope there will be more activity on that in future - also on more generic approaches towards FMC-related heterogeneous link bundling - perhaps also stimulating our discussions ;-)

Concerning FMC, you might be interested by the presentation given by KT 
during the MPTCP working group. KT uses Multipath TCP to enable 
smartphones to combine LTE and WiFi and reach higher bandwidth.

See 
http://recordings.conf.meetecho.com/Playout/watch.jsp?recording=IETF93_MPTCP&chapter=chapter_1
starts at around minute 34

This service is commercially deployed and was launched in mid June. 
Although it only runs on Samsung Galaxy S6, they already had 5500 active 
users on the day of the presentation

Olivier

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Jul 2015 10:52:40 -0500

Hi Olivier,

On Wed, Jul 29, 2015 at 9:21 AM, Olivier Bonaventure
<[email-masked]> wrote:
> Dirk,
>
>> at IET93 in Prague we had a small informal meeting on hiaps issues
>> discussing the NAT@RG use case with hybrid access (e.g. DSL+LTE) where for
>> different access links and multiple devices (e.g. at home) behind the NAT a
>> consistent and customer-configurable policy enforcement should be enabled.
>> Some vendors say (e.g. A10 during bits'n'bytes) that in an SDN-based (vCPE)
>> deployment this would be solved but I still like to see it working.
>> I hope there will be more activity on that in future - also on more
>> generic approaches towards FMC-related heterogeneous link bundling - perhaps
>> also stimulating our discussions ;-)
>
>
>
> during the MPTCP working group. KT uses Multipath TCP to enable smartphones
> to combine LTE and WiFi and reach higher bandwidth.
>
> See
> This service is commercially deployed and was launched in mid June. Although
> it only runs on Samsung Galaxy S6, they already had 5500 active users on the
> day of the presentation

I think this is an application of Lollipop or Android 5.0 which
enables the use of multiple network interfaces.

It is end user or host oriented. Our interest is the wireline-wireless
convergence usually aimed at reaching higher bandwidth at the CPE
using bundling techniques with the wireless network.

By the way, if anybody wants to be unsubscribed of this list, let us know.

Regards,

Behcet

---

From: Olivier Bonaventure <[email-masked]>
Date: Wed, 29 Jul 2015 17:57:01 +0200

Behcet,

> enables the use of multiple network interfaces.

The deployment is based on a Multipath TCP kernel with a SOCKS proxy 
application on the smartphone and a SOCKS proxy running Multipath TCP in 
the operator's network. Thanks to the proxy, the operator can control 
the utilisation of the WiFi and LTE networks and this works with regular 
smartphone applications.

> using bundling techniques with the wireless network.

This is clearly what they do since they reach 850 Mbps by combining fast 
LTE with fast WiFi.

Olivier

---

From: <[email-masked]>
Date: Thu, 30 Jul 2015 07:29:49 +0000

Hi Behcet,

With MPTCP proxy at the CPE side, MPTCP can be a bundling technique. Actually, the IETF already has a bunch of techniques that can be used for hybrid access; the challenge here would be to not reinvent the wheel.

Pierrick

> -----Message d'origine-----
> De : hiaps [mailto:[email-masked]] De la part de Behcet Sarikaya
> Envoyé : mercredi 29 juillet 2015 17:53
> À : [email-masked]
> Cc : [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Objet : Re: [hiaps] Hybrid access bar bof
> 
> Hi Olivier,
> 
> >> discussing the NAT@RG use case with hybrid access (e.g. DSL+LTE)
> >> where for different access links and multiple devices (e.g. at home)
> >> behind the NAT a consistent and customer-configurable policy enforcement
> should be enabled.
> >> Some vendors say (e.g. A10 during bits'n'bytes) that in an SDN-based
> >> (vCPE) deployment this would be solved but I still like to see it working.
> >> generic approaches towards FMC-related heterogeneous link bundling -
> >> perhaps also stimulating our discussions ;-)
> >
> >
> >
> > Concerning FMC, you might be interested by the presentation given by
> > KT during the MPTCP working group. KT uses Multipath TCP to enable
> > Although it only runs on Samsung Galaxy S6, they already had 5500
> > active users on the day of the presentation
> 
> I think this is an application of Lollipop or Android 5.0 which enables the use of
> multiple network interfaces.
> 
> It is end user or host oriented. Our interest is the wireline-wireless convergence
> usually aimed at reaching higher bandwidth at the CPE using bundling techniques
> with the wireless network.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 30 Jul 2015 09:43:52 +0200

Hi Pierrick,
That's IMO one of the goals of the breakfast BoF on HA ... I assume that Margaret will send round some notes.
Though MPTCP and LISP people were not present AFAICR
Best Regards
Dirk 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Donnerstag, 30. Juli 2015 09:30
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Schott, Roland; Leymann, Nicolai; von Hugo, Dirk
Subject: RE: [hiaps] Hybrid access bar bof

Hi Behcet,

Pierrick

> De : hiaps [mailto:[email-masked]] De la part de Behcet 
> Sarikaya Envoyé : mercredi 29 juillet 2015 17:53 À : 
> [email-masked] Cc : [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked] Objet : Re: [hiaps] Hybrid access bar bof
> 
> Hi Olivier,
> 
> >> where for different access links and multiple devices (e.g. at 
> >> home) behind the NAT a consistent and customer-configurable policy 
> >> enforcement
> should be enabled.
> >> generic approaches towards FMC-related heterogeneous link bundling 
> >> - perhaps also stimulating our discussions ;-)
> >
> >
> >
> > http://recordings.conf.meetecho.com/Playout/watch.jsp?recording=IETF
> > 93
> > _MPTCP&chapter=chapter_1

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 30 Jul 2015 10:09:48 +0200

Hi all,
And BTW I just realized that the announced mailing list has already been set up http://www.ietf.org/mail-archive/web/ietf-announce/current/msg14401.html 
with info at https://www.ietf.org/mailman/listinfo/banana Banana -- Bandwidth Aggregation for interNet Access: Discussion of bandwidth aggregation solutions based on IETF technologies

However no postings are to be found there yet ...

Best Regards

Dirk 

-----Original Message-----
From: hiaps [mailto:[email-masked]] On Behalf Of von Hugo, Dirk
Sent: Donnerstag, 30. Juli 2015 09:44
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Leymann, Nicolai; Schott, Roland
Subject: Re: [hiaps] Hybrid access bar bof

Hi Pierrick,
Though MPTCP and LISP people were not present AFAICR Best Regards Dirk -----Original Message-----

Hi Behcet,

Pierrick

---

From: Mingui Zhang <[email-masked]>
Date: Fri, 31 Jul 2015 05:54:53 +0000

Hi Dirk,

Thanks for the advertisement!

For the CPE based DSL+LTE use case, which is the primary use case of Hybrid Access, the basic requirement is to leave user's equipments unaware of the change. The goal is to increase the access bandwidth by adding free LTE bandwidth to the limited DSL bandwidth. I believe KT's experiment is not about this use case. 

1. The users' equipments are changed. 
2. WIFI is used to increase the bandwidth of LTE. Because WIFI is cheaper than LTE? We can see 850 Mbps is greater than 300 Mbps (LTE MAX) but it is apparently less than 867 Mbps (WIFI MAX). So this is "LTE+" rather than "DSL+LTE ", right?

I saw the MPTCP proposal for the CPE based DSL+LTE use case. Generally, two proxies are required. One is on the CPE and the other one is on an aggregation point in front of the Internet. It faces some unsolved issues that other solutions are also trying to solve. For example, how to let the traffic of certain service types bypass the bonding bandwidth? How to report the bypassing bandwidth from the CPE to the aggregation point?

The front page of BANANA list has done a nice harmonization. Let's discuss there.

Best regards,
Mingui

> From: hiaps [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, July 30, 2015 4:10 PM
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> And BTW I just realized that the announced mailing list has already been set up
> http://www.ietf.org/mail-archive/web/ietf-announce/current/msg14401.html
> with info at https://www.ietf.org/mailman/listinfo/banana Banana --
> Bandwidth Aggregation for interNet Access: Discussion of bandwidth
> aggregation solutions based on IETF technologies
> 
> With MPTCP proxy at the CPE side, MPTCP can be a bundling technique.
> Actually, the IETF already has a bunch of techniques that can be used for hybrid
> access; the challenge here would be to not reinvent the wheel.
> 
> Pierrick
> 
> ________________________________________________________________
> _________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.

---

From: <[email-masked]>
Date: Fri, 31 Jul 2015 08:06:29 +0000

Hi

> De : Mingui Zhang [mailto:[email-masked]]
> Envoyé : vendredi 31 juillet 2015 07:55
> À : [email-masked]; SEITE Pierrick IMT/OLN; [email-masked];
> [email-masked]
> Cc : [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Objet : RE: [hiaps] Hybrid access bar bof
> 
> Hi Dirk,
> 
> For the CPE based DSL+LTE use case, which is the primary use case of Hybrid
> Access, the basic requirement is to leave user's equipments unaware of the
> change. The goal is to increase the access bandwidth by adding free LTE
> bandwidth to the limited DSL bandwidth. I believe KT's experiment is not about this
> use case.
> 
> 2. WIFI is used to increase the bandwidth of LTE. Because WIFI is cheaper than
> LTE? We can see 850 Mbps is greater than 300 Mbps (LTE MAX) but it is
> apparently less than 867 Mbps (WIFI MAX). So this is "LTE+" rather than
> "DSL+LTE ", right?
> 
> I saw the MPTCP proposal for the CPE based DSL+LTE use case. Generally, two
> proxies are required. One is on the CPE and the other one is on an aggregation
> point in front of the Internet. It faces some unsolved issues that other solutions are
> also trying to solve. For example, how to let the traffic of certain service types
> bypass the bonding bandwidth? 

Well... This is basic policy based routing as, implemented, for example, by Linux/IPtables.
Actually, I do not see problems that can't be solved with existing protocols/mechanisms... but, I may be wrong....

Pierrick

How to report the bypassing bandwidth from the
> CPE to the aggregation point?
> 
> > http://www.ietf.org/mail-archive/web/ietf-announce/current/msg14401.ht
> > ml with info at https://www.ietf.org/mailman/listinfo/banana Banana --
> > That's IMO one of the goals of the breakfast BoF on HA ... I assume
> > that Margaret will send round some notes.
> > Actually, the IETF already has a bunch of techniques that can be used
> > for hybrid access; the challenge here would be to not reinvent the wheel.
> >
> > Pierrick
> >
> > > >> at IET93 in Prague we had a small informal meeting on hiaps
> > > >> issues discussing the NAT@RG use case with hybrid access (e.g.
> > > >> DSL+LTE) where for different access links and multiple devices
> > > >> (e.g. at
> > > >> home) behind the NAT a consistent and customer-configurable
> > > >> policy enforcement
> > > should be enabled.
> > > >> I hope there will be more activity on that in future - also on
> > > >> more generic approaches towards FMC-related heterogeneous link
> > > >> bundling
> > > > Concerning FMC, you might be interested by the presentation given
> > > > by KT during the MPTCP working group. KT uses Multipath TCP to
> > > > enable smartphones to combine LTE and WiFi and reach higher bandwidth.
> > > >
> > > > See
> > > It is end user or host oriented. Our interest is the
> > > wireline-wireless convergence usually aimed at reaching higher
> > > bandwidth at the CPE using bundling techniques with the wireless network.
> > >
> > confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> > que les pieces jointes. Les messages electroniques etant susceptibles
> > d'alteration, Orange decline toute responsabilite si ce message a ete altere,
> deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should not
> > be distributed, used or copied without authorisation.

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 31 Jul 2015 08:24:38 +0000

I believe there is several solutions today in the market and some require more adaptations than others.
E.g. If you give the same IP address and multiple links/Interfaces (ETH, xG, WIFI) and the IP stack accepts that, it can do packet or flow based hashing. Tested and working with openWRT, Android, IOS, Linux. Some stack prefer one interface over another and others have more extensive hashing/loadbalanicng mechanisms, but this is implementation specific.
The nice thing is that you don’t consume extra ip addresses and most stacks support this today. Works on smartphones, residential GW and enterprise GW(s).