Subject: RE: [Hipsec] Re: Addressing WG LC comments on draft-ietf-hip-arch

From: "Henderson, Thomas R" <[email-masked]>
Date: Mon, 20 Dec 2004 11:07:13 -0800

> -----Original Message-----
> From: Lars Eggert [mailto:[email-masked]]
> Sent: Monday, December 20, 2004 9:54 AM
> To: Pekka Nikander
> Cc: [email-masked]
> Subject: [Hipsec] Re: Addressing WG LC comments on draft-ietf-hip-arch
> 
> > Abstract
> ...
> >    protocols are defined.  The memo describes the thinking of the
> >    authors as of Fall 2003.
> 
> Fall 2004? (Here and at several other places later.)

Pekka, maybe you or Gonzalo can clarify this point.  My understanding
is that we are trying to publish a historical document here that documents
the thinking of no later than 2003.  That is, refinements to the architecture
document or architectural thinking since fall of last year are out of scope.

> 
> >       changes to the current APIs.  In the long run, it is 
> probable that
> >       some new APIs are needed.
> 
> s/probable/possible/

I think "probable" is more accurate.

> > 5.  Host Identity namespace
> ...
> >    'well known', some unpublished or 'anonymous'.  A system may self
> >    assert its own identity, or may use a third-party 
> authenticator like
> >    DNSSEC, PGP, or X.509 to 'notarize' the identity 
> assertion.  It is
> >    expected that the Host Identifiers will initially be 
> authenticated
> >    with DNSSEC and that all implementations will support DNSSEC as a
> >    minimal baseline.
> 
> s/self assert/self-assert/
> 
> Do we really want the last sentence about DNSSEC in there? (And if we 
> do, we shoud cite it.)

This was probably true as of last year, but recently there has been a
chorus against requiring a DNS dependency.

Tom
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 20 Dec 2004 22:02:28 +0200

> document or architectural thinking since fall of last year are out of 

Yes, Tom, you are right.  The intention is to publish a document that
reflects back our understanding as of a year ago from now.

We may want to codify our understanding as of now (or in
the future) too, but that would be a different effort.
For example, I'm starting to disagree with the tight
integration with ESP, but I certainly did not a year ago.

I'll return to the rest of the messages tomorrow, now it is
too late here.

--Pekka

---

From: Lars Eggert <[email-masked]>
Date: Tue, 21 Dec 2004 09:41:06 +0100

Tom, Pekka,

> reflects back our understanding as of a year ago from now.

I'd put short paragraph on this into the abstract, introduction and 
conclusion; along the lines of

"This document describes the HIP architecture at its state in the fall 
of 2003. Although the architecture has evolved since then, this document 
is an important fix point in understanding."

Thanks,
Lars
-- 
Lars Eggert                                     NEC Network Laboratories

---

From: Pekka Nikander <[email-masked]>
Date: Tue, 21 Dec 2004 13:22:30 +0200

> of 2003. Although the architecture has evolved since then, this 
> document is an important fix point in understanding."

Note that the beginning of Abstract already mentions the snapshot 
nature.
I changed the abstract to read as follows:

       <t>This memo describes a snapshot of the reasoning behind a
       proposed new namespace, the Host Identity namespace, and a new
       protocol layer, the Host Identity Protocol, between the
       internetworking and transport layers.  Herein are presented the
       basics of the current namespaces, their strengths and
       weaknesses, and how a new namespace will add completeness to
       them.  The roles of this new namespace in the protocols are
       defined.  The memo describes the thinking of the authors as of
       Fall 2003.  The architecture may have evolved since.  This 
document
       represents one stable point in that evolution of
       understanding. </t>

I think that is enough, as the introduction already mentions this.
What do you think?

--Pekka

---

From: Lars Eggert <[email-masked]>
Date: Tue, 21 Dec 2004 12:27:48 +0100

Pekka Nikander wrote:
> 
> Note that the beginning of Abstract already mentions the snapshot nature.
>       Fall 2003.  The architecture may have evolved since.  This document

Very happy with this.