Subject: RE: [Hipsec] dns extensions

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 6 Sep 2005 07:04:48 -0700

I do not know of any-- I think the public implementations mainly use
/etc/hosts files.  

Tom

> -----Original Message-----
> From: Wesley Eddy [mailto:[email-masked]] 
> Sent: Friday, August 26, 2005 1:41 PM
> To: [email-masked]
> Subject: [Hipsec] dns extensions
> 
> Are any implementations (bind patches, etc) available 
> supporting the HIP DNS extensions for HIPHI and HIPRVS RRs and QTYPEs?
> 
> -Wes
> 
> --
> Wesley M. Eddy
> Verizon FNS / NASA GRC
> http://roland.grc.nasa.gov/~weddy
> 

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Julien Laganier <[email-masked]>
Date: Tue, 6 Sep 2005 16:45:57 +0200

On Tuesday 06 September 2005 16:04, Henderson, Thomas R wrote:
> I do not know of any-- I think the public implementations mainly
> use /etc/hosts files.

With djbdns <http://cr.yp.to/djbdns/>, an alternative DNS server, you 
can easily defines new RRs; the syntax to use to feed the 
tinydns-data program is:

:fqdn:n:rdata:ttl:timestamp:lo

where r is the RR type and rdata the RR itself, which can include 
octal \nnn codes. A simple program should do the trick of converting 
the /etc/hosts Tom mentionned into the above representation thant can 
be fed to tinydns-data.

As for the resolver part, I think someone needs to hack it ;)

--julien

-- 
julien