Subject: [Hipsec] hip in ns-2

From: "ipv6ysg" <[email-masked]>
Date: Mon, 19 Dec 2005 14:18:09 +0800 (CST)

Hello,
    I was wondering if anyone knew of any ns-2 based tools that could perform an analysis of hip? Any advice and help is much appreciated.

                                                                        Jeffrey

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Andrei Gurtov <[email-masked]>
Date: Thu, 22 Dec 2005 11:04:10 +0200

Hi,

I don't think anyone implemented HIP in ns-2 yet. It might be quite
difficult in fact. If that implementation does everything that real HIP
implementations do, such as IPsec data encryption and public key crypto,
it would be impossible to run experiments with multiple HIP connections
in accelerated virtual time because CPU power would not be enough. What
perhaps could be useful is a simple implementation of HIP base exchange
and update messages to estimate the RTT delay and bandwith consumption
they produce.

Andrei

ipv6ysg wrote:

> Hello,
>
> I was wondering if anyone knew of any ns-2 based tools that could
> perform an analysis of hip? Any advice and help is much appreciated.
>
> Jeffrey
>
>
>
>
>
>
>
>
>
>
> 年 末 啦！邮 箱 老 用 户 快 回 来参 加 万 元 大 奖 回 馈 活 动 ！
> *快 抢 ！ 完 全 白 送* ：IBM 手 提 电 脑， NOKIA 高 端 手 机，iPod
> nano 时 尚 MP3 。
> <http://jifen.mail.163.com/act_home/index.htm?from=footer>
>
>------------------------------------------------------------------------
>