Subject: [Hipsec] Value of I1 retransmission timer

From: Cullen Jennings <[email-masked]>
Date: Sun, 20 Jan 2008 10:48:34 -0800

What are implementations actually using for the value of the  
retransmission timer?

Thanks, Cullen

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Miika Komu <[email-masked]>
Date: Sun, 20 Jan 2008 23:21:51 +0200 (EET)

On Sun, 20 Jan 2008, Cullen Jennings wrote:

Hi,

> What are implementations actually using for the value of the retransmission 
> timer?

HIPL implementation currently retransmits every 10 seconds and gives up 
after five failures. HIP daemon will continue retransmission even longer 
if the application persists longer than this, or another application tries 
to use the same HIT pair.

-- 
Miika Komu                                       http://www.iki.fi/miika/

---

From: Julien Laganier <[email-masked]>
Date: Mon, 21 Jan 2008 11:40:11 +0100

> What are implementations actually using for the value of the

I used to have a configurable retransmission timer set to 3 seconds as 
default.

--julien

---

From: Julien Laganier <[email-masked]>
Date: Mon, 21 Jan 2008 11:40:11 +0100

--julien

---

From: Jan Mikael Melen <[email-masked]>
Date: Mon, 21 Jan 2008 21:47:46 +0200

Hi,

HIP4Inter.net is implementing exponential backoff for retransmitting I1 
packets. The timer has a initial value of 500ms and does 5 retransmissions.

   Jan

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Mon, 21 Jan 2008 13:33:32 -0800

OpenHIP:  By default 

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: Sunday, January 20, 2008 10:49 AM
> To: HIP
> Subject: [Hipsec] Value of I1 retransmission timer
> 
> 

By default, OpenHIP will send an I1 and retransmit every 10 seconds (no
backoff) until five retransmissions have failed.  The default
retransmission behavior is therefore to send six I1s spaced 10 seconds
apart before moving to E-FAILED state.  

Tom

---

From: Julien Laganier <[email-masked]>
Date: Tue, 22 Jan 2008 08:45:45 +0100

On Monday 21 January 2008, Julien Laganier wrote:
> I used to have a configurable retransmission timer set to 3 seconds
> as default.

forgot to say that I used exponential backoff too.

--julien