Subject: [Hipsec] Native API draft: way forward

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 25 Feb 2008 10:14:06 +0200

Folks,

as you know, the WGLC on the native API draft finished a while ago. 
There were a few technical comments on the draft during the WGLC, most 
of which have been incorporated into the draft. Now we need to make a 
decision on how to proceed with this draft.

There are some concerns that the API defined in this document may need 
to change as soon as we have a little more experience with NAT traversal 
and HIP-based overlays. With this in mind, we have two options:

1) publish the draft now stressing that it defines an experimental API 
and, as soon as we understand how NAT traversal and HIP-based overlays 
will affect the API, publish a new spec, most likely modifying the API.

2) wait for the NAT traversal and HIP-based overlays work to be more 
mature before publishing this draft. This way, the API defined by the 
draft will have better chances to be future proof.

I lean towards doing 2), but I would like to get feedback from the 
community on what is the best way forward.

Thanks,

Gonzalo
HIP co-chair
_______________________________________________
Hipsec mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/hipsec

---

From: Miika Komu <[email-masked]>
Date: Mon, 25 Feb 2008 20:45:58 +0200 (EET)

On Mon, 25 Feb 2008, Gonzalo Camarillo wrote:

The latest version of the draft is here:

http://www.ietf.org/internet-drafts/draft-ietf-hip-native-api-04.txt

> Folks,
>
> as you know, the WGLC on the native API draft finished a while ago. There 
> were a few technical comments on the draft during the WGLC, most of which 
> have been incorporated into the draft. Now we need to make a decision on how 
> to proceed with this draft.
>
> There are some concerns that the API defined in this document may need to 
> change as soon as we have a little more experience with NAT traversal and 
> HIP-based overlays. With this in mind, we have two options:
>
> 1) publish the draft now stressing that it defines an experimental API and, 
> as soon as we understand how NAT traversal and HIP-based overlays will affect 
> the API, publish a new spec, most likely modifying the API.
>
> 2) wait for the NAT traversal and HIP-based overlays work to be more mature 
> before publishing this draft. This way, the API defined by the draft will 
> have better chances to be future proof.
>
>
> I lean towards doing 2), but I would like to get feedback from the community 
> on what is the best way forward.
>
> Thanks,
>
> Gonzalo
> HIP co-chair
>

-- 
Miika Komu                                       http://www.iki.fi/miika/
_______________________________________________
Hipsec mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/hipsec

---

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 26 Feb 2008 10:34:24 +0100

Hi,

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: Monday, February 25, 2008 9:14 AM
> To: HIP
> Subject: [Hipsec] Native API draft: way forward
> 
> Folks,
> 
> There were a few technical comments on the draft during the 
> WGLC, most of which have been incorporated into the draft. 
> Now we need to make a decision on how to proceed with this draft.
> 
> There are some concerns that the API defined in this document 
> may need to change as soon as we have a little more 
> experience with NAT traversal and HIP-based overlays. With 
> this in mind, we have two options:
> 
> 1) publish the draft now stressing that it defines an 
> experimental API and, as soon as we understand how NAT 
> traversal and HIP-based overlays will affect the API, publish 
> a new spec, most likely modifying the API.
> 
> 2) wait for the NAT traversal and HIP-based overlays work to 
> be more mature before publishing this draft. This way, the 
> API defined by the draft will have better chances to be future proof.

I also would tend to 2) as HIP is not yet a protocol that is used outside the IETF community to a large extend. This gives us more time to get done really.

  Martin 

[email-masked]   <== NEW ADDRESS

NEC Laboratories Europe - Network Research Division

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014  
_______________________________________________
Hipsec mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/hipsec