Subject: [hiprg] HIP DEX code comment in meeting

From: Robert Moskowitz <[email-masked]>
Date: Thu, 04 Aug 2011 07:02:30 -0400

I caught a comment from someone in the meeting about status of a C++ HIP 
DEX codebase.  I was focused on something else in the session at the 
time and failed to identify the talker.  Since this comment was not made 
at the mike, when I went through the audio yesterday, I did not pick it 
up. So....

Can anyone enlighten me as to work on HIP DEX development?  :)

---

From: Jani Pellikka <[email-masked]>
Date: Thu, 04 Aug 2011 14:39:06 +0300

Hi!

Like Andrei mentioned we have a DEX implementation written in C++ but 
unfortunately not yet able to share it publicly. We intend to do this 
later though. We can probably present results and show what we have used 
it for in the next IETF meeting.

Btw, it is an independent implementation from the existing HIP 
implementations (HIPL, OpenHIP, ...).

Cheers,

-- 
Jani

On 08/04/2011 02:06 PM, Andrei Gurtov wrote:
 > -----BEGIN PGP SIGNED MESSAGE-----
 > Hash: SHA1
 >
 >
 > Jani from CWC Oulu has made C++ DEX implementation.
 >
 > We're not releasing it publicly yet as experiments for a paper are still
 > ongoing but can share it under some gentleman agreement.
 >
 > Andrei
 >
 > Robert Moskowitz wrote:
 >> _______________________________________________
 >> hiprg mailing list
 >> [email-masked]
 >> https://www.irtf.org/mailman/listinfo/hiprg
 >
 > -----BEGIN PGP SIGNATURE-----
 > Version: GnuPG v1.4.11 (MingW32)
 > Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
 >
 > iEYEARECAAYFAk46fSoACgkQP7jp0uceFkSOwACdFSIvmK3fkWhrPptYdMf6otti
 > NBAAn3QlYHXRyLFxoh34J7HMRubZX5db
 > =fn9J
 > -----END PGP SIGNATURE-----

---

From: Levä Tapio <[email-masked]>
Date: Thu, 4 Aug 2011 13:06:16 +0000

The comment can be found from Jabber: http://www.ietf.org/jabber/logs/hiprg/2011-07-28.html 

Ari was reading it to the mike.

[15:14:34] <razister> This is Jani Pellikka from Centre for Wireless Communications, Univ. Oulu, Finland.
I want to use this opportunity to announce that we have a C++ implementation of HIP Diet Exchange for Linux.
Only the exchange is implemented and it works on IPv4 and IPv6. It is not yet public as we are experimenting
with it and using it in our research project, but later we intend to open source it. Probably in the next
IETF meeting we can present some results and show what we have done with it. I will email the mailing list
about this as well. Just FYI.
[15:15:28] <ari> Jani: to the mic?
[15:15:44] <razister> Yes, please.
[15:15:50] <ari> ack 

Tapio

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jani Pellikka
> Sent: 4. elokuuta 2011 14:39
> To: [email-masked]
> Subject: Re: [hiprg] HIP DEX code comment in meeting
> 
> Hi!
>