Subject: Re: [hiprg] HIP DEX suggestion

From: Ed Beroset <[email-masked]>
Date: Thu, 4 Aug 2011 09:20:54 -0400 (GMT-04:00)

Speaking of implementations, I have a suggestion about HIP DEX. Right now it specifies the use of AES-CBC but I would like to see if we could change that to either AES-CFB or AES-CTR.  The reason is that for CBC, one must implement both the AES encrypt and decrypt functions.  With CFB and CTR, one only need implement AES encrypt.  This saves about 1.5k of code space on a typical small microprocessor for which HIP DEX is intended and has at least equivalent (and some say better) security properties.

Ed Beroset

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 04 Aug 2011 10:28:06 -0400

> Speaking of implementations, I have a suggestion about HIP DEX. Right now it specifies the use of AES-CBC but I would like to see if we could change that to either AES-CFB or AES-CTR.  The reason i…

Very good point.  Plus hardware that does AES-CCM should be able to do 
CTR 'easily'. But I have to look at what the counter would be.  CBC was 
'easy' in that there was a natural nonce.