Subject: [HOKEY] Overall HOKEY Architecture

From: Charles Clancy <[email-masked]>
Date: Wed, 24 Jan 2007 19:31:33 -0500

The sum of all the architectural consensuses achieved at the interim
meeting yielded a basic architecture for HOKEY re-auth that
automatically incorporates both handoff and roaming into a single protocol.

The idea is that there is always a logical "HOKEY server" added to any
domain.  It may be the same physical devices on either the home or local
AAA server.  It talks AAA to both the authenticator and the home EAP
server.  It receives a server-specific EMSK from the EAP server after
the initial EAP authentication.  From that it derives a reauth USRK, and
from that, any necessary reauth keys.

Attached is a diagram.

Comments?

-- 
t. charles clancy, ph.d.  <>  [email-masked]  <>  www.cs.umd.edu/~clancy

_______________________________________________
HOKEY mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hokey

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Wed, 24 Jan 2007 17:14:09 -0800

Charles Clancy <mailto:[email-masked]> allegedly scribbled on
Wednesday, January 24, 2007 4:32 PM:

> The idea is that there is always a logical "HOKEY server" added to
> any domain.  It may be the same physical devices on either the home
> or local AAA server.  It talks AAA to both the authenticator and the
> home EAP server.  It receives a server-specific EMSK from the EAP
> server after the initial EAP authentication.  From that it derives a
> reauth USRK, and from that, any necessary reauth keys.     
> 
> Attached is a diagram.
> 
> Comments?

This looks pretty much accurate & OK to me except that I think that the
last message should be using a key derived from the EMSK, rather than
the MSK.  This would change the structure of the HOKEYkey hierarchy a
bit, but I think it would be more secure.

---

From: Charles Clancy <[email-masked]>
Date: Wed, 24 Jan 2007 20:18:26 -0500

> bit, but I think it would be more secure.

Indeed -- It isn't meant to be the actual MSK, but rather an "MSK" 
derived from the reauth keying hierarchy.

---

From: Lakshminath Dondeti <[email-masked]>
Date: Wed, 24 Jan 2007 17:23:21 -0800

Looks good.

Lakshminath

Charles Clancy wrote:
> ------------------------------------------------------------------------
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 24 Jan 2007 21:43:27 -0500

I agree with what the diagram is trying to convey, except that the
signaling between the peer and HOKEY server is actually re-key, not
really re-authentication (because long-term credentials are not used
there).  My observation (without dispute) is that we are creating one
level of media-independent key hierarchy on top of media-specific key
hierarchy, and EAP is used for re-key at this level of key hierarchy.
It would be clearer if we call it "HOKEY re-key architecture".

Yoshihiro Ohba

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 24 Jan 2007 21:37:45 -0800

The architecture looks good. On the "MSK" produced by HOKEY, it would be
good to avoid confusion by distinguishing it as a "Re-authentication MSK
(rMSK)" or some such term. 

Vidya

> -----Original Message-----
> From: Charles Clancy [mailto:[email-masked]] 
> Sent: Wednesday, January 24, 2007 5:18 PM
> To: Glen Zorn (gwz)
> Cc: [email-masked]
> Subject: Re: [HOKEY] Overall HOKEY Architecture
> 
> Glen Zorn (gwz) wrote:
> > This looks pretty much accurate & OK to me except that I think that 
> > the last message should be using a key derived from the 
> EMSK, rather 
> > than the MSK.  This would change the structure of the HOKEYkey 
> > hierarchy a bit, but I think it would be more secure.
>

---

From: "Julien Bournelle" <[email-masked]>
Date: Thu, 25 Jan 2007 09:16:13 +0100

Hi,

 The architecture looks good. It could also be nice to have the architecture
 in the roaming case.

 I agree with vidya that rMSK maybe a better term.

 Regards,

 Julien

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Thu, 25 Jan 2007 10:07:52 -0800

Julien Bournelle <mailto:[email-masked]> allegedly scribbled
on Thursday, January 25, 2007 12:16 AM:

> Hi,
> 
>  The architecture looks good. It could also be nice to have the
> architecture  in the roaming case. 

We  believe that this architecture works in all cases.

>> The architecture looks good. On the "MSK" produced by HOKEY, it would
>> be good to avoid confusion by distinguishing it as a
>> "Re-authentication MSK (rMSK)" or some such term.
>> 
>> Vidya
>> 
>>>> This looks pretty much accurate & OK to me except that I think
>>>> that the last message should be using a key derived from the EMSK,
>>>> rather than the MSK.  This would change the structure of the
>>>> HOKEYkey hierarchy a bit, but I think it would be more secure.
>>>

---

From: "Julien Bournelle" <[email-masked]>
Date: Fri, 26 Jan 2007 12:06:46 +0100

Hi,

 a question below:

> We  believe that this architecture works in all cases.

 ok. but do the reauth will occur with the local-HOKEY server or
 the home-HOKEY server ?

 Julien

---

From: Madjid Nakhjiri <[email-masked]>
Date: Wed, 31 Jan 2007 11:06:36 -0800

Hi Charles,

I am about a week or 100:) emails behind here, but I have wanted to make
this point for a while.

Unless we are changing the understood terminology, the root key is called
handover root key (HRK) which is used to derive both per-authenticator keys
and fast re-auth keys. So using the term "re-auth key" is confusing.

Re-authentication alone does not achieve the key hierarchy that is required
for handover. In fact re-authentication may even be optional in conjunction
with handover and what is required for handover key management (read
fetching a new key for the new authenticator).

Regards,

Madjid

-----Original Message-----
From: Charles Clancy [mailto:[email-masked]] 
Sent: Wednesday, January 24, 2007 4:32 PM
To: [email-masked]
Subject: [HOKEY] Overall HOKEY Architecture

Attached is a diagram.

Comments?

---

From: Madjid Nakhjiri <[email-masked]>
Date: Wed, 31 Jan 2007 11:06:56 -0800

BTw, HRK is mentioned in several places in the charter...

-----Original Message-----
From: Charles Clancy [mailto:[email-masked]] 
Sent: Wednesday, January 24, 2007 4:32 PM
To: [email-masked]
Subject: [HOKEY] Overall HOKEY Architecture

Attached is a diagram.

Comments?

---

From: Madjid Nakhjiri <[email-masked]>
Date: Wed, 31 Jan 2007 11:12:01 -0800

The other thing that I think is missing is the interaction between the peer
and what you call hokey server (through authenticator) following the initial
authentication that relates to HRK key distribution. This can be related to
channel binding or whatever signaling that is possibly orthogonal to the
initial EAP method run and needs to be done at the end.
Sending HRK to hokey server does not complete the hokey signaling during
initial auth, IMO. This, especially, since we are going the route of EAP
codes (and not methods) for hokey.

-----Original Message-----
From: Charles Clancy [mailto:[email-masked]] 
Sent: Wednesday, January 24, 2007 4:32 PM
To: [email-masked]
Subject: [HOKEY] Overall HOKEY Architecture

Attached is a diagram.

Comments?

---

From: Madjid Nakhjiri <[email-masked]>
Date: Wed, 31 Jan 2007 11:12:52 -0800

-----Original Message-----
From: Charles Clancy [mailto:[email-masked]] 
Sent: Wednesday, January 24, 2007 5:18 PM
To: Glen Zorn (gwz)
Cc: [email-masked]
Subject: Re: [HOKEY] Overall HOKEY Architecture

Madjid>>which is called "HRK" :)

---

From: Madjid Nakhjiri <[email-masked]>
Date: Wed, 31 Jan 2007 11:15:14 -0800

Not sure why we insist on overhauling all the existing terminology. HRK was
the term that has been used all along and it is in the charter already.

Are we forgetting that the group's name is hokey? Or we are changing that
too soon?

Madjid

-----Original Message-----
From: Julien Bournelle [mailto:[email-masked]] 
Sent: Thursday, January 25, 2007 12:16 AM
To: Narayanan, Vidya
Cc: [email-masked]
Subject: Re: [HOKEY] Overall HOKEY Architecture

Hi,

 Regards,

 Julien