Subject: [HOKEY] RE: EMSK Document

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Fri, 8 Jun 2007 14:38:02 -0700

Lakshminath Dondeti <mailto:[email-masked]> allegedly scribbled
on Friday, June 08, 2007 10:54 AM:

> Madjid,
> 
> Thanks for doing the editorial fixes.
> 
> I like the technical content in the version of the draft Joe sent;
> let's keep it as is.

Actually, I'd much prefer that this document only carry it as far as the
derivation of the USRK.  As numerous people have noted, lots of services
may not know or care about domains.  The DSRK seems particularly
hokey-dependent to me & as such I think it should be in its own doc.

> 
> regards,
> Lakshminath
> 
> On 6/8/2007 10:30 AM, Madjid Nakhjiri wrote:
>> Hi Joe,
>> 
>> Thanks for the write up. I am fixing up the editorial nits, see a lot
>> of "rook"s, does not sound like a bad shorthand for "root keys":) I
>> did a spell check and am going through the doc right now.
>> 
>> Anyway, my impression was that based on the idea of including both
>> domain labels and usage labels, you could have 3 permutatiions, USRK,
>> DSRK and DSUSRK. Don't we want to cover DSUSRK in the pics?
>> 
>> I can add that to the pics.
>> 
>> R,
>> 
>> Madjid
>> 
>> -----Original Message-----
>> From: Joseph Salowey (jsalowey) [mailto:[email-masked]]
>> Sent: Thursday, June 07, 2007 5:01 PM
>> To: Charles Clancy
>> Cc: Glen Zorn (gwz); Lakshminath Dondeti; Narayanan, Vidya; Madjid
>> Nakhjiri Subject: RE: EMSK Document
>> 
>> OK attached is a revision that should match what was presented.  Let
>> me know if it looks correct. 
>> 
>> We should probably do a little cleanup and submit it.
>> 
>> Thanks,
>> 
>> Joe
>> 
>>> -----Original Message-----
>>> From: Charles Clancy [mailto:[email-masked]]
>>> Sent: Friday, June 01, 2007 4:22 AM
>>> To: Joseph Salowey (jsalowey)
>>> Cc: Glen Zorn (gwz); Lakshminath Dondeti; Narayanan, Vidya; Madjid
>>> Nakhjiri Subject: Re: EMSK Document
>>> 
>>> Joe,
>>> 
>>> What specific complications are you talking about?  My understanding
>>> was that we had consensus for:
>>> 
>>>             EMSK
>>>           /   |   \
>>>       USRK  USRK  DSRK
>>>                    / | \
>>>                   DSUSRKs
>>> 
>>> That's what we presented in the last IETF, and what needs to be
>>> accomplished in the next draft update.
>>> 
>>> --
>>> t. charles clancy, ph.d.  |  [email-masked]  |  www.cs.umd.edu/~clancy
>>> 
>>> 
>>> Joseph Salowey (jsalowey) wrote:
>>>> I'm still not really convinced that complicating the basic
>>>> derivation with a domain is the right thing to do.  I believe the
>>>> concept of a domain is specific to certain usages and not to all
>>>> usages. 
>>>> 
>>>> Joe
>>>> 
>>>>> -----Original Message-----
>>>>> From: Charles Clancy [mailto:[email-masked]]
>>>>> Sent: Thursday, May 31, 2007 6:24 PM
>>>>> To: Glen Zorn (gwz)
>>>>> Cc: Joseph Salowey (jsalowey); Lakshminath Dondeti; Narayanan,
>>>>> Vidya; Madjid Nakhjiri Subject: Re: EMSK Document
>>>>> 
>>>>> Glen,
>>>>> 
>>>>> None of the DSRK stuff was in the -00 document.  We'd also
>>>>> converged on a the idea of USRKs and DSUSRKs, which isn't in the
>>>>> -01n version. 
>>>>> 
>>>>> --
>>>>> t. charles clancy, ph.d.  <>  [email-masked]  <>
>>>>> www.cs.umd.edu/~clancy 
>>>>> 
>>>>> Glen Zorn (gwz) wrote:
>>>>>> Joseph Salowey (jsalowey) <> allegedly scribbled on Thursday,
>>>>>> May 31, 2007 1:41 PM: 
>>>>>> 
>>>>>>> Hi Charles,
>>>>>>> 
>>>>>>> Sorry for the delay, attached is the current document. I took
>>>>>>> me a while to find the latest.  I think we need to describe the
>>>>>>> concept of a domain more and recommend that if your are using
>>>>>>> keys in multiple domains you should use DSRK. 
>>>>>>> 
>>>>>>> Cheers,
>>>>>>> 
>>>>>>> Joe
>>>>>>> 
>>>>>>>> -----Original Message-----
>>>>>>>> From: Charles Clancy [mailto:[email-masked]]
>>>>>>>> Sent: Monday, May 28, 2007 9:59 AM
>>>>>>>> To: Joseph Salowey (jsalowey); Lakshminath Dondeti; Narayanan,
>>>>>>>> Vidya; Madjid Nakhjiri; Glen Zorn (gwz)
>>>>>>>> Subject: EMSK Document
>>>>>>>> 
>>>>>>>> Joe,
>>>>>>>> 
>>>>>>>> How's the EMSK keying hierarchy document coming?  Do you have
>>>>>>>> a copy of the latest version?  I'd like to outline a set of
>>>>>>>> required changes so the authors can put together the next
>>>>>>>> version, and hopefully go to WGLC in the near future.
>>>>>> Hmm.  Where are these required changes coming from?  I can't
>>>>>> find any discussion of this topic on the list since February. 
>>>>>> Am I missing something? 
>>>>>> 
>>>>>>>> --
>>>>>>>> t. charles clancy, ph.d.  <>  [email-masked]  <>
>>>>>>>> www.cs.umd.edu/~clancy 

_______________________________________________
HOKEY mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hokey

---

From: Lakshminath Dondeti <[email-masked]>
Date: Fri, 08 Jun 2007 15:08:28 -0700

Glen,

We had a long discussion on this on the mailing list and at f2f 
meetings.  As Charles notes,below, we have consensus for the derivation 
he has shown below.  I think it is best to not reopen this topic to make 
forward progress.

I realize it is your decision on how to manage the work -- 1 document or 
2 -- but we are past that stage now.

thanks,
Lakshminath

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 8 Jun 2007 15:15:23 -0700

Actually, DSRK is totally HOKEY independent and that's the reason we
made the decision to include it as part of the EMSK hierarchy document.
The HOKEY hierarchy starts at the rRK and not at the DSRK.  I don't
think it makes sense to have it as a separate document.  So, our
previous decision of keeping it with the EMSK hierarchy document makes
more sense to me. 

Vidya 

> From: Glen Zorn (gwz) [mailto:[email-masked]] 
> Sent: Friday, June 08, 2007 2:38 PM
> To: Dondeti, Lakshminath; Madjid Nakhjiri
> Cc: Joseph Salowey (jsalowey); Charles Clancy; Narayanan, 
> Vidya; [email-masked]
> Subject: RE: EMSK Document
> 
> Lakshminath Dondeti <mailto:[email-masked]> allegedly 
> scribbled on Friday, June 08, 2007 10:54 AM:
> 
> > Madjid,
> > 
> Actually, I'd much prefer that this document only carry it as 
> far as the derivation of the USRK.  As numerous people have 
> noted, lots of services may not know or care about domains.  
> The DSRK seems particularly hokey-dependent to me & as such I 
> think it should be in its own doc.
> 
> > 
> > regards,
> > Lakshminath
> > 
> >>>>>> Joseph Salowey (jsalowey) <> allegedly scribbled on 
> Thursday, May 
> >>>>>> 31, 2007 1:41 PM:
> >>>>>> 
> >>>>>>> Hi Charles,
> >>>>>>> 
> >>>>>>> Sorry for the delay, attached is the current 
> document. I took me 
> >>>>>>> a while to find the latest.  I think we need to describe the 
> >>>>>>>> How's the EMSK keying hierarchy document coming?  Do 
> you have a 
> >>>>>>>> copy of the latest version?  I'd like to outline a set of 
> >>>>>> Hmm.  Where are these required changes coming from?  I 
> can't find 
> >>>>>> any discussion of this topic on the list since February.
> >>>>>> Am I missing something? 
> >>>>>> 
> >>>>>>>> --

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Fri, 8 Jun 2007 16:15:29 -0700

Lakshminath Dondeti <mailto:[email-masked]> allegedly scribbled
on Friday, June 08, 2007 3:08 PM:

> meetings.  As Charles notes,below, we have consensus for the
> derivation he has shown below.  

I didn't say anything about changing the key hierarchy or the
derivation.

> I think it is best to not reopen this
> topic to make forward progress.   
> 
> I realize it is your decision on how to manage the work -- 1 document
> or 2 -- but we are past that stage now.
> 
> thanks,
> Lakshminath
> 
>> Actually, I'd much prefer that this document only carry it as far as
>> the derivation of the USRK.  As numerous people have noted, lots of
>> services may not know or care about domains.  The DSRK seems
>> particularly hokey-dependent to me & as such I think it should be in
>> its own doc. 
>> 
>>> regards,
>>> Lakshminath
>>> 
>>>> Thanks for the write up. I am fixing up the editorial nits, see a
>>>> lot of "rook"s, does not sound like a bad shorthand for "root
>>>> keys":) I did a spell check and am going through the doc right now.
>>>> 
>>>> domain labels and usage labels, you could have 3 permutatiions,
>>>> USRK, DSRK and DSUSRK. Don't we want to cover DSUSRK in the pics?
>>>> 
>>>> OK attached is a revision that should match what was presented. 
>>>> Let me know if it looks correct. 
>>>> 
>>>>> What specific complications are you talking about?  My
>>>>> understanding was that we had consensus for:
>>>>> 
>>>>>             EMSK
>>>>>           /   |   \
>>>>>       USRK  USRK  DSRK
>>>>>                    / | \
>>>>>                   DSUSRKs
>>>>> 
>>>>>>> converged on a the idea of USRKs and DSUSRKs, which isn't in
>>>>>>> the -01n version. 
>>>>>>> 
>>>>>>> --
>>>>>>>>> me a while to find the latest.  I think we need to describe
>>>>>>>>> the concept of a domain more and recommend that if your are
>>>>>>>>> using keys in multiple domains you should use DSRK.
>>>>>>>>> 
>>>>>>>>> Cheers,
>>>>>>>>> 
>>>>>>>>> Joe
>>>>>>>>> 
>>>>>>>>>> To: Joseph Salowey (jsalowey); Lakshminath Dondeti;
>>>>>>>>>> Narayanan, Vidya; Madjid Nakhjiri; Glen Zorn (gwz)
>>>>>>>>>> Subject: EMSK Document
>>>>>>>>>> 
>>>>>>>>>> Joe,
>>>>>>>>>>

---

From: "Joseph Salowey \(jsalowey\)" <[email-masked]>
Date: Fri, 8 Jun 2007 16:22:53 -0700

SO I think Glen's suggestion has merit.  I believe that what is most
needed for general use is a spec for how to derive keys from an EMSK.
What the keys are used for should be described in another document.  

I'm not sure that how generally useful DSRKs are.  I don't think there
is a clear definition of what a Domain means.  I think this definition
may vary from one usage to another.  

Joe

> From: Narayanan, Vidya [mailto:[email-masked]] 
> Sent: Friday, June 08, 2007 3:15 PM
> To: Glen Zorn (gwz); Dondeti, Lakshminath; Madjid Nakhjiri
> Cc: Joseph Salowey (jsalowey); Charles Clancy; [email-masked]
> Actually, DSRK is totally HOKEY independent and that's the 
> reason we made the decision to include it as part of the EMSK 
> hierarchy document.
> The HOKEY hierarchy starts at the rRK and not at the DSRK.  I 
> don't think it makes sense to have it as a separate document. 
>  So, our previous decision of keeping it with the EMSK 
> hierarchy document makes more sense to me. 
> 
> Vidya 
> 
> > Cc: Joseph Salowey (jsalowey); Charles Clancy; Narayanan, Vidya; 
> > [email-masked]
> > services may not know or care about domains.
> > The DSRK seems particularly hokey-dependent to me & as such 
> I think it 
> > should be in its own doc.
> > 
> > > 
> > > regards,
> > > Lakshminath
> > >

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 8 Jun 2007 17:11:27 -0700

My understanding is that we are only defining the key derivations from
the EMSK and the key properties in this document.  Just as the USRKs, we
aren't actually describing what the keys should be used for in the DSRK
case either.  Both DSRKs and USRKs can be derived from the EMSK and
that's what we are capturing.  As to what a "Domain" means, it is
whatever the DSRK is scoped to - it may be as granular as one server or
something bigger as an administrative domain with multiple servers -
this will be indicated by the Domain that is used in the DSRK
derivation.  The idea behind DSRKs is that it can be handed to the
entity for which it is scoped.  

As to the general use for DSRKs, it is hard to predict future uses.  As
of now, the idea is to enable an extensible key hierarchy that can be
used for local domain services just like the USRKs are available for
home domain or even cross-domain services.  

Vidya 

> Sent: Friday, June 08, 2007 4:23 PM
> To: Narayanan, Vidya; Glen Zorn (gwz); Dondeti, Lakshminath; 
> Madjid Nakhjiri
> Cc: Charles Clancy; [email-masked]
> SO I think Glen's suggestion has merit.  I believe that what 
> is most needed for general use is a spec for how to derive 
> keys from an EMSK.
> I'm not sure that how generally useful DSRKs are.  I don't 
> think there is a clear definition of what a Domain means.  I 
> think this definition may vary from one usage to another.  
> 
> Joe
> 
> reason we 
> > think it makes sense to have it as a separate document.
> >  So, our previous decision of keeping it with the EMSK hierarchy 
> > document makes more sense to me.
> > 
> > Vidya
> >

---

From: Madjid Nakhjiri <[email-masked]>
Date: Mon, 11 Jun 2007 11:24:33 -0700

DSRKs where suggested all along to solve a multi-domain problem, so if DSRK
is dealt with in another problem, I don't have a problem.

I for one, cannot even see a HOKEY solution that is solely dependent on
DSRK. 
Even HOKEY specific documents, if they want to allow DSRK based hierarchy,
need to allow for a USRK based hierarchy as well. Otherwise, we are back at
the same discussion: I DON'T TRUST A VISITED DOMAIN TO DO WHATEVER IT WANTS
WITH THE KEY, regardless of which doc we are talking about, this EAP-ERX or
key delivery.

I have discussed this at length and don't want to reopen this issue. 

Madjid

-----Original Message-----
From: Joseph Salowey (jsalowey) [mailto:[email-masked]] 
Sent: Friday, June 08, 2007 4:23 PM
To: Narayanan, Vidya; Glen Zorn (gwz); Dondeti, Lakshminath; Madjid Nakhjiri
Cc: Charles Clancy; [email-masked]
Subject: RE: EMSK Document

Joe

---

From: Madjid Nakhjiri <[email-masked]>
Date: Mon, 11 Jun 2007 11:41:27 -0700

I clearly said multiple time on list and in Prague that we want to allow a
USRK based DSUSRK generation, i.e. allow a HOKEY hierarchy off an HRK that
is domain independent (as I discussed on the email before and shown below).

>       USRK  DSUSRK  DSRK

Madjid

> From: Madjid Nakhjiri [mailto:[email-masked]]
> Sent: Friday, June 01, 2007 9:13 AM
> To: 'Charles Clancy'; Joseph Salowey (jsalowey)
> Cc: Glen Zorn (gwz); 'Lakshminath Dondeti'; 'Narayanan, Vidya'; 
> 'Madjid Nakhjiri'
> I have been in favor of
> Based on all the issues that we discussed for a long time, so I think 
> the compromise I understood was
> 
> 
>             EMSK
>           /   |   \
>       USRK  USRK  DSRK
>      / | \       / | \
>     DSUSRKs     DSUSRKs  
> 
> Or however you want to call those last keys, I don't care.
> 
> Madjid

-----Original Message-----
From: Lakshminath Dondeti [mailto:[email-masked]] 
Sent: Friday, June 08, 2007 3:08 PM
To: Glen Zorn (gwz)
Cc: [email-masked]; Madjid Nakhjiri
Subject: [HOKEY] Re: EMSK Document

Glen,

thanks,
Lakshminath

On 6/8/2007 2:38 PM, Glen Zorn (gwz) wrote:
> on Friday, JuFrom [email-masked] Mon Jun 11 14:49:43 2007
Date: Mon, 11 Jun 2007 11:41:27 -0700
From: Madjid Nakhjiri <[email-masked]>
Subject: RE: [HOKEY] Re: EMSK Document
To: 'Lakshminath Dondeti' <[email-masked]>,
	"'Glen Zorn (gwz)'" <[email-masked]>
Cc: [email-masked]

I clearly said multiple time on list and in Prague that we want to allow a
USRK based DSUSRK generation, i.e. allow a HOKEY hierarchy off an HRK that
is domain independent (as I discussed on the email before and shown below).

>       USRK  DSUSRK  DSRK

Madjid

> From: Madjid Nakhjiri [mailto:[email-masked]]
> Sent: Friday, June 01, 2007 9:13 AM
> To: 'Charles Clancy'; Joseph Salowey (jsalowey)
> Cc: Glen Zorn (gwz); 'Lakshminath Dondeti'; 'Narayanan, Vidya'; 
> 'Madjid Nakhjiri'
> I have been in favor of
> Based on all the issues that we discussed for a long time, so I think 
> the compromise I understood was
> 
> 
>             EMSK
>           /   |   \
>       USRK  USRK  DSRK
>      / | \       / | \
>     DSUSRKs     DSUSRKs  
> 
> Or however you want to call those last keys, I don't care.
> 
> Madjid

-----Original Message-----
From: Lakshminath Dondeti [mailto:[email-masked]] 
Sent: Friday, June 08, 2007 3:08 PM
To: Glen Zorn (gwz)
Cc: [email-masked]; Madjid Nakhjiri
Subject: [HOKEY] Re: EMSK Document

Glen,

thanks,
Lakshminath

On 6/8/2007 2:38 PM, Glen Zorn (gwz) wrote:
>>>>>>>>> a copy of the latest version?  I'dne 08, 2007 10:54 AM:
> 
>> Madjid,
>>

---

From: Madjid Nakhjiri <[email-masked]>
Date: Mon, 11 Jun 2007 11:35:18 -0700

This document was supposed to be an IETF standard track for what it was
called "Application specific master keys (AMSK)" that allow tight usage of
EMSK. We changed AMSK to USRK, to signify tight control on what the key is
used for. 

If we are allowing the key to be shipped to a domain, then we need to keep a
tight control of what the key is being used to that domain, so in that
sense, Joe did the right thing inserting statement on exactly who exactly is
going to access the key and what set of service DSRK is to be used, possibly
including key usages in the context shipped with the key. To me that is a
lot more complexity than USRK. So I don't mind just including USRK in there
for now if we cannot agree on the complex issues. So far it seems we are
regressing on several things we thought we had converged on, including a
shipping a DSUSRK for a domain and usage directly to a visited domain.

Sure we ca like to outline a set of

---

From: Madjid Nakhjiri <[email-masked]>
Date: Mon, 11 Jun 2007 11:35:18 -0700

Sure we cannot predict future "use", but we need to restrict future "abuse".
That is exactly what people did with EMSK, they simply forbid its export
until future uses are tightly specified.

How do I know I sent a DSRK to a domain, it is not going to go beyond the
AAA server into some access point somewhere (that is defining the key scope
and doing the 3 party key distribution with identity verification for the
server receiving DSRK)?

How do I know the DSRK is not going to be used for an application that the
user is not allowed to reach?

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Friday, June 08, 2007 5:11 PM
To: Joseph Salowey (jsalowey); Glen Zorn (gwz); Dondeti, Lakshminath; Madjid
Nakhjiri

Vidya 

> >nnot predict future "use", but we need to restrict future "abuse".
That is exactly what people did with EMSK, they simply forbid its export
until future uses are tightly specified.

How do I know I sent a DSRK to a domain, it is not going to go beyond the
AAA server into some access point somewhere (that is defining the key scope
and doing the 3 party key distribution with identity verification for the
server receiving DSRK)?

How do I know the DSRK is not going to be used for an application that the
user is not allowed to reach?

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Friday, June 08, 2007 5:11 PM
To: Joseph Salowey (jsalowey); Glen Zorn (gwz); Dondeti, Lakshminath; Madjid
Nakhjiri

Vidya 

> > > Narayanan,
> > > >>>>>>>> Vidya; Madjid Nakhjiri; Gl > 
> > > > 
> > > > regards,
> > > > Lakshminath
> > > > 

en Zorn (gwz)

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Mon, 11 Jun 2007 11:53:31 -0700

Madjid Nakhjiri <mailto:[email-masked]> allegedly scribbled on
Monday, June 11, 2007 11:25 AM:

> DSRKs where suggested all along to solve a multi-domain problem, so
> if DSRK is dealt with in another problem, I don't have a problem. 
> 
> I for one, cannot even see a HOKEY solution that is solely dependent
> on DSRK. 
> Even HOKEY specific documents, if they want to allow DSRK based
> hierarchy, need to allow for a USRK based hierarchy as well.
> Otherwise, we are back at the same discussion: I DON'T TRUST A
> VISITED DOMAIN TO DO WHATEVER IT WANTS WITH THE KEY, 

OK, so how would propose to keep the visited (or home, for that matter)
domain from doing anything it wants w/the key?  

> regardless of
> which doc we are talking about, this EAP-ERX or key delivery.    
> 
> I'm not sure that how generally useful DSRKs are.  I don't think
> there is a clear definition of what a Domain means.  I think this
> definition may vary from one usage to another.  
> 
> Joe
> 
>> made the decision to include it as part of the EMSK hierarchy
>> document. The HOKEY hierarchy starts at the rRK and not at the DSRK.
>> I don't think it makes sense to have it as a separate document.
>>> [email-masked] Subject: RE: EMSK Document
>>> 
>>> The DSRK seems particularly hokey-dependent to me & as such I think
>>> it should be in its own doc. 
>>> 
>>>> 
>>>> regards,
>>>> Lakshminath
>>>> 
>>>>>> Cc: Glen Zorn (gwz); Lakshminath Dondeti; Narayanan, Vidya;
>>>>>> Madjid Nakhjiri Subject: Re: EMSK Document
>>>>>> 
>>>>>> Joe,
>>>>>> 
>>>>>>> derivation with a domain is the right thing to do.  I believe
>>>>>>> the concept of a domain is specific to certain usages and not
>>>>>>> to all usages. 
>>>>>>> 
>>>>>>> Joe
>>>>>>> 
>>>>>>>>>> Sorry for the delay, attached is the current document. I
>>>>>>>>>> took me a while to find the latest.  I think we need to
>>>>>>>>>> describe the concept of a domain more and recommend that if
>>>>>>>>>> your are using keys in multiple domains you should use DSRK.
>>>>>>>>>> 
>>>>>>>>>> Cheers,
>>>>>>>>>> 
>>>>>>>>>> Joe
>>>>>>>>>> 
>>>>>>>>>>> How's the EMSK keying hierarchy document coming?  Do you
>>>>>>>>>>> have a copy of the latest version?  I'd like to outline a
>>>>>>>>>>> set of required changes so the authors can put together the
>>>>>>>>>>> next version, and hopefully go to WGLC in the near future.

---

From: Madjid Nakhjiri <[email-masked]>
Date: Mon, 11 Jun 2007 12:04:06 -0700

Glen, I don't know, or lets say, I don't want to spend time figuring it out
all out, unless I absolutely have to:) Solving the problem you mention
below, would be up to people who want to generate and use DSRKs. I simply
provided a bunch of precautions.

I personally like to see the solution based on the USRK. Hasn't that been
clear up to now? Then I must seriously work on my communications skills:)

Madjid

-----Original Message-----
From: Glen Zorn (gwz) [mailto:[email-masked]] 
Sent: Monday, June 11, 2007 11:54 AM
To: Madjid Nakhjiri; Joseph Salowey (jsalowey); Narayanan, Vidya; Dondeti,
Lakshminath
Cc: [email-masked]
Subject: [HOKEY] RE: EMSK Document

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 13 Jun 2007 05:02:28 -0400

On Mon, Jun 11, 2007 at 12:04:06PM -0700, Madjid Nakhjiri wrote:
> 
> I personally like to see the solution based on the USRK. 

+1.

Yoshihiro Ohba

> Hasn't that been