Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

From: Qin Wu <[email-masked]>
Date: Mon, 15 Aug 2011 11:07:06 +0800

Please find below a review from Richard about draft-ietf-hokey-erp-aak-04.
I forwarded this eMail to the Hokey list. If you reply, please maintain
Richard' eMail address in the recipients list.

Regards!
-Qin
-----邮件原件-----
发件人: young [mailto:[email-masked]] 
发送时间: 2011年8月12日 16:58
收件人: 'Glen Zorn'; [email-masked]'
主题: 答复: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

Hi, All:

I have read it and have the following comments.
1)  The document also specifies a method by which the SAP may send the
   identities of neighboring attachment points to the peer in the EAP-
   Initiate/Re-auth-Start message. 
[Richard] 
The are two kinds of CAP discovery model：The CAPs could be found by SAP or
by MH.
Why not specify both cases?

2) The peer sends an early-authentication request message (EAP-Initiate/
   Re-auth with the 'E' flag set) containing the keyName-NAI, the NAS-
   Identifier, rIK and sequence number.  
[Richard] 
The question is similar to the first one. It seemed that the text suggests
the CAP list must be offered by the SAP. 
In the real application , It is possible that: The CAP list offered by the
SAP is a reference or Mandatory.
Also, MH could have a CAP list by itself and may refer or use the CAP list
provided by the SAP. 
I suggest the draft would consider such cases and give some descriptions.

3)  This document only discusses the case of distributing the key to a
single CAP.
[Richard] it would let the draft only supports very limited scenarios. In
some cases like unstable Wireless signal, the MH have to rapidly 
Shift among several CAPs. In order to ensure the user experience, it is
possible that AAK is installed on the several 
CAPs before the MH's hand over.  

4) The realm in the keyName-NAI field is used to locate the peer's ERP/AAK
server
[Richard] what would happen if the SAP does not know the ERP/AAK server
indicated by the keyName-NAI

Regards
Richard

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Glen
Zorn
发送时间: 2011年8月4日 19:31
收件人: [email-masked]
主题: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

At the hokey WG session during IETF 81 last week, the beginning of a three
week Working Group Last Call for this document was announced.
However, it appears that no-one mentioned this fact on the mailing list :-(,
so the Last Call will be extended to 25 August.

A URL for this document is
http://www.ietf.org/id/draft-ietf-hokey-erp-aak-04.txt.  Please note that
the draft is only 15 pages long, including boilerplate, so reading it should
not be a major task.  Reply to this message with any comments (including
statements such as "I read it and it's fine").  Thank you.

---

From: Zhen Cao <[email-masked]>
Date: Tue, 23 Aug 2011 13:33:02 +0800

Richard, thank you for the comments.

See inline for the response.  We will update the draft to reflect some
of your comments. Thank you again.

> Why not specify both cases?

I think the case of CAP discovery via MH is out of scope of this document.

> I suggest the draft would consider such cases and give some descriptions.

Same as the first question, I think we should keep it simple. And to
support you case, the SAP can leave the list blank and depends on the
EAP-Initiate/Re-auth packet to include the discovered CAP.

> CAPs before the MH's hand over.

We are designing a protocol to support the basic needs, and with good
extensibility .  In the previous versions of this draft, we have
indeed discussed the case of multiple CAP, but the working group
consensus is to have only one CAP in the scope. That's why we are
here.

> indicated by the keyName-NAI

Inter-realm handover is not in scope.

> _______________________________________________
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey
>

-- 
Best regards,
Zhen

---

From: Glen Zorn <[email-masked]>
Date: Tue, 23 Aug 2011 15:11:34 +0700

On 8/23/2011 12:33 PM, Zhen Cao wrote:

...

>> indicated by the keyName-NAI

Routing of EAP messages (encapsulated, in this case, in Diameter) is
always a function of the AAA infrastructure., I think.

> Inter-realm handover is not in scope.

Really?  I would think that that would be the only really useful purpose
of ERP-AAK...

...

---

From: Qin Wu <[email-masked]>
Date: Mon, 29 Aug 2011 16:14:56 +0800

Hi,
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Zhen Cao" <[email-masked]>
Cc: "Qin Wu" <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 23, 2011 4:11 PM
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

> always a function of the AAA infrastructure., I think.

[Qin]: Absolutely.

> Really?  I would think that that would be the only really useful purpose

[Qin]: The current version doesn't cover inter-realm handover. But it doesn't mean
ERP-AAK specified in this document can not support inter-realm handover. The problem
to support inter-realm handover in my mind is NAI-Identifier is not global identity.
In some case, CAP or SAP may share the same NAI-Identitifier, in such case, how does 
the AAA distinguish between CAP and SAP with the same NAI-Identifier?
If this document intend to expand scope, this issue should be fixed first.

---

From: Zhen Cao <[email-masked]>
Date: Mon, 29 Aug 2011 17:08:59 +0800

> Really?  I would think that that would be the only really useful purpose

Inter-realm handover is not even supported by ERP, so definitely not a
target of ERP-AAK.

-- 
Best regards,
Zhen

---

From: Tina TSOU <[email-masked]>
Date: Mon, 29 Aug 2011 22:01:00 +0000

Qin,
In line...

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Monday, August 29, 2011 1:15 AM
To: Glen Zorn; Zhen Cao
Cc: [email-masked]
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

Hi,
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Zhen Cao" <[email-masked]>
Cc: "Qin Wu" <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 23, 2011 4:11 PM
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

[Qin]: Absolutely.

[TT] Qin, may I suggest you to create another I-D to describe this additional issue?

---

From: Glen Zorn <[email-masked]>
Date: Tue, 30 Aug 2011 22:34:17 +0700

On 8/30/2011 5:01 AM, Tina TSOU wrote:

...

> [TT] Qin, may I suggest you to create another I-D to describe this additional issue?

The simplest thing to do, I think, would be to change the NAS-Identifier
to a Diameter name, which are guaranteed to be globally unique.  It
doesn't really seem like a new draft is necessary.

...

---

From: Qin Wu <[email-masked]>
Date: Wed, 31 Aug 2011 08:33:12 +0800

----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Tina TSOU" <[email-masked]>
Cc: "Qin Wu" <[email-masked]>; "Zhen Cao" <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 30, 2011 11:34 PM
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

> doesn't really seem like a new draft is necessary.

[Qin]: Yes, that is also what I think.