Subject: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

From: Glen Zorn <[email-masked]>
Date: Thu, 04 Aug 2011 18:31:07 +0700

At the hokey WG session during IETF 81 last week, the beginning of a
three week Working Group Last Call for this document was announced.
However, it appears that no-one mentioned this fact on the mailing list
:-(, so the Last Call will be extended to 25 August.

A URL for this document is
http://www.ietf.org/id/draft-ietf-hokey-erp-aak-04.txt.  Please note
that the draft is only 15 pages long, including boilerplate, so reading
it should not be a major task.  Reply to this message with any comments
(including statements such as "I read it and it's fine").  Thank you.

---

From: Tina TSOU <[email-masked]>
Date: Thu, 04 Aug 2011 18:05:08 +0000

This version of draft is well written, no more nits was found when I read it.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Glen Zorn
Sent: Thursday, August 04, 2011 4:31 AM
To: [email-masked]
Subject: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

At the hokey WG session during IETF 81 last week, the beginning of a three week Working Group Last Call for this document was announced.
However, it appears that no-one mentioned this fact on the mailing list :-(, so the Last Call will be extended to 25 August.

A URL for this document is
http://www.ietf.org/id/draft-ietf-hokey-erp-aak-04.txt.  Please note that the draft is only 15 pages long, including boilerplate, so reading it should not be a major task.  Reply to this message with any comments (including statements such as "I read it and it's fine").  Thank you.

---

From: andy L <[email-masked]>
Date: Tue, 9 Aug 2011 17:16:29 +0800

first of all, I have read, it is fine.
still I have some comments
1 since it is said in Chapter 3 /*This document   only discusses the case of
distributing the key to a single CAP.*/ the statement like /*To  avoid the
same pre-established Master Session Key (pMSK) being   derived for multiple
CAPs, the sequence number MUST be nique for   each CAP.*/ is not so
necessary.
2  draft-ietf-hokey-rfc5296bis specifies some ways to map ERP parameters to
AAA attributes, such as the keyName-NAI into the User-Name  attribute of
RADIUS , I think it is worth being recommendated for this draft.

thanks

Andrew Liu

2011/8/4 Glen Zorn <[email-masked]>

> _______________________________________________
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey
>
>

---

From: Zhen Cao <[email-masked]>
Date: Tue, 23 Aug 2011 13:18:19 +0800

Thank you, Andy, See inline.

> CAPs, the sequence number MUST be nique for   each CAP.*/ is not so

That's correct. We will correct it in the new version.

> RADIUS , I think it is worth being recommendated for this draft.

But in ERP-AAK, we do not need to map the keyName-NAI to some AAA attribute.

-- 
Best regards,
Zhen

---

From: Glen Zorn <[email-masked]>
Date: Tue, 23 Aug 2011 14:37:06 +0700

>> CAPs, the sequence number MUST be nique for   each CAP.*/ is not so

Is that true?  The document only discusses deriving the for on CAP _at a
time_; do you really think it's OK for the same key to be used with the
next CAP in a series of moves??

...

---

From: Qin Wu <[email-masked]>
Date: Mon, 29 Aug 2011 16:07:56 +0800

Hi,
Sorry to chime in.
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Zhen Cao" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 23, 2011 3:37 PM
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

> next CAP in a series of moves??

[Qin]: My answer to your last question above is "No". I think it is not harmful to allow the key to be distributed 
multiple CAs when the client doesn't really know where to move.
However if client has already know which is the next CA he is going to attach to, I think the case of
distributing the key to a single CAP should apply here. 
Does my clarification make sense to you?