Subject: Re: [HOKEY] Change proposal for ERP-AAK - 3: Multiple CAP case support

From: Glen Zorn <[email-masked]>
Date: Wed, 05 Oct 2011 18:53:32 +0700

On 9/29/2011 4:45 PM, Qin Wu wrote:

> Hi,
> As we discussed on the list to the draft-ietf-hokey-erp-aak-04, it is
> not difficult to support multiple CAP(s) case.
> However we should make sure each pMSK is calculated for each CAP using
> different Sequence number, therefore I propose to do the
> following change to allow two ways to avoid the same pMSK derived for
> multiple CAP,
> one way is
> 
> The multiple sequence numbers can be derived from SEQ field in the
> message header by following +1 rule.
> 
> e.g., we have 3 CAP, the SEQ field is set to the value 100
> 
> so the pMSK for CAP A will be derived using seqence number 100.
> 
>     the pMSK for CAP B will be derived using sequence number 100+1
> 
>    the pMSK for CAP C will be derived using sequence number 100+2
> 
>  

OK, how does the AAA server know which CAP to send which key?

> 
> The second way is directly using Sequence number field carried in the TV
> of the message for each CAP,and mandate
> 
> each sequence number asscicated with each CAP must always follow that
> CAP. Also I think if multiple Sequenced number TLV are carried for each CAP,
> 
> the SEQ field in the ERP/AAK message header should be set to smallest 
> value contained in the  Sequenced number TLVs. This is more flexible way
> comparing
> 
> with the first way. But I think it will be better to allow both.

I'm not sure that I understand this, would you mind explaining a little
more?  Also, if both are allowed, which one would be mandatory to implement?

...

---

From: Qin Wu <[email-masked]>
Date: Sat, 08 Oct 2011 12:05:12 +0800

Hi,
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, October 05, 2011 7:53 PM
Subject: Re: [HOKEY] Change proposal for ERP-AAK - 3: Multiple CAP case support

> OK, how does the AAA server know which CAP to send which key?

[Qin]: The simple way is that the AAA sever relies on the CAP order contained in the list of
NAS-Identifiers or CAP-Identifiers.

> more?  

[Qin]: Okay, when multiple CAPs are transported to the the server using EAP-Initiate message,
we may carry multiple CAPs using CAP/NAS-Identifier in one EAP-Initiate message,
also we may carry each CAP in each of multiple EAP-Initiate message.
I don't think the second choice is good choice since it introduce multiple roundtrip.
For the first choice, when multiple CAP(s) are carried in one EAP-Initiate message,
in order to  avoid the pMSK for each CAP using the same sequence number, we 
define new TV payload, i.e.,Sequence number TV. So We can carry different Sequence number
for each CAP, put each sequencer number after each CAP/NAS-Identifier.

>Also, if both are allowed, which one would be mandatory to implement?

[Qin] It dependes on if Sequence number TV payload is mandatory TV payload, if it is,
I think the server should extract each sequence number to generate different pMSK for each CAP.
If it is not, the Sequence number TV payload are not carried in the EAP-Initiate message to the server,
the server should use SEQ field in the EAP-initiate message header to generate different sequence number for each CAP.
Does it make sense?