Subject: [homenet] Homenet Architecture Draft

From: Ray Bellis <[email-masked]>
Date: Fri, 5 Aug 2011 14:57:42 +0000

We currently have draft-arkko-townsley-homenet-arch-00 as a candidate for our first chartered WG item.

To ensure we can maintain some inertia following our session in Quebec, it would be appreciated if members could  review this document.

I'd especially like to see some feedback on §3.2 "Principles" since I get the impression that some of those may be quite contentious.

The discussion on LAN-side routing is interesting and I'm happy to see that continue.  However we must also work on the bigger picture before getting rat-holed too much into implementation details.

Ray Bellis
Homenet co-chair

---

From: Don Sturek <[email-masked]>
Date: Fri, 05 Aug 2011 09:10:45 -0700

Hi Ray,

I don't agree with the statement: "However we must also work on the bigger
picture before getting rat-holed too much into implementation details."

I found the discussion on routing protocols very relevant.  I hope the
group can also review/revise the architecture at the same time.

Don

On 8/5/11 7:57 AM, "Ray Bellis" <[email-masked]> wrote:

>To ensure we can maintain some inertia following our session in Quebec,
>it would be appreciated if members could  review this document.
>
>I'd especially like to see some feedback on §3.2 "Principles" since I get
>the impression that some of those may be quite contentious.
>
>The discussion on LAN-side routing is interesting and I'm happy to see
>that continue.  However we must also work on the bigger picture before
>getting rat-holed too much into implementation details.
>
>Ray Bellis
>Homenet co-chair
>
>_______________________________________________
>homenet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/homenet

---

From: Ray Bellis <[email-masked]>
Date: Fri, 5 Aug 2011 16:20:34 +0000

> group can also review/revise the architecture at the same time.

Don,

I specifically said that I'm happy for the routing protocol discussion to continue.

However we mustn't forget our initial work item - the architecture draft.

Ray

---

From: "STARK, BARBARA H (ATTSI)" <[email-masked]>
Date: Fri, 5 Aug 2011 13:09:23 -0400

Thanks Ray. I agree that the routing protocol discussion has been interesting, but that we really need to take a more disciplined approach if we're ever going to get consensus on what the "correct" technology solutions are.

I think that starting with the architecture is a good idea. This will let us develop a holistic view of what it is we're trying to solve. I think it's important that we also get some idea as to the relative importance of the various architectural challenges (topology and §3.2 "Principles"?) over others. We need to be very careful to balance functionality with ease-of-use in the recommendations we make. IMO, the likelihood that functionality can be implemented bug-free and not cause confusion (and not cause trouble calls to the service provider) is part of the ease-of-use element. That is, if introduction of a function could confuse people or do bad things more often than it is found to be useful, then we don't need to be recommending that function as a MUST for everybody, and perhaps not as a SHOULD for everybody, either.

Understanding the whole picture will also let us consider how selection of one technology to deal with one element impacts other selections. 

I'll take a look at the referenced draft and provide my comments.
Barbara

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ray Bellis
> Sent: Friday, August 05, 2011 10:58 AM
> To: [email-masked]
> Subject: [homenet] Homenet Architecture Draft
> 
> I'd especially like to see some feedback on §3.2 "Principles" since I
> get the impression that some of those may be quite contentious.
>

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 16 Aug 2011 16:41:26 -0400

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ray
> Bellis
> To ensure we can maintain some inertia following our session in Quebec, it would be
> appreciated if members could  review this document.

ISTR mention of an interim meeting, but haven't heard anything since Quebec.

> some of those may be quite contentious.

OK:
Largest Possible Subnets.
I disagree with this principle.  Why is switching (or bridging) better than routing?
Is policy easier to write for MAC addresses than IP addresses?  Is the network more
resilient to devices (including other routers) being added, removed, interconnected,
or moved?
One should have more than a /64 per interface, so when a new router is joined, it can
get a prefix, rather than reconfiguring addressing throughout the home.

Transparent end-to-end.
Yes, as long as "addressable" != "reachable".  We are not ruling out ACLs or firewalls.
I will return to the firewall diatribe, if I must.  "Administratively unreachable" is
transparent, altered IP headers are not.

IP Connectivity between All Nodes.  Inconsistent with the above, and inconsistent
with any kind of security policy (e.g., don't let guests reach my file share).
Says, "IP-layer connectivity" then says "at the link layer where  possible".  I thought
those were different layers.

Intelligent Policy.  I don't know what this section means.  No QoS, WRED, or AQM?

There's a terminology difference between fun-multi-router and homenet-architecutre:
is a LAN a single segment, or a home-area network?

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Ray Bellis <[email-masked]>
Date: Tue, 16 Aug 2011 21:09:49 +0000

On 16 Aug 2011, at 21:41, Howard, Lee wrote:

It is being planned at the moment.

Please watch this space - I hope to be able to announce dates and venue later this week.

Ray