Subject: Re: [homenet] [v6ops] default LAN routing protocol for IPv6 CE router

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 2 Aug 2011 21:57:10 +0000

This is something that should be today as part of broadband IPv6
deployments to prevent conflict at the service provider edge.  I cannot
think of a good reason why I would want to accept IPv6 router
advertisements, at this time from residential gateways.

John

On 8/2/11 1:47 AM, "Michael Newbery" <[email-masked]> wrote:

>It's outside the CPE spec, but I can see that the document could state,
>as an assumption, that the ISP will filter routing advertisements from
>the CPE and will only pass those that it has determined (via some
>external mechanism, undefined in this document) belong to the CPE.

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 2 Aug 2011 21:57:33 +0000

John

---

From: Mark Andrews <[email-masked]>
Date: Wed, 03 Aug 2011 09:37:47 +1000

In message <[email-masked]>, "Brzozowski, Jo
> advertisements, at this time from residential gateways.

If they advertise the /64's of the /56 they are using you can filter
the unrequested traffic and also prevent looping packets when they
send the rest of the /56 back to you.  If we don't do something
like this the border CPE router has to have a null route covering
the /56 (or whatever upstream has delegated to it) which would be
a good thing to do regardless.

Seeing the /64's also gives you a insight into whether you can
allocate on the /60 boundary or not.  Similarly if you need to
start planning for /52's rather than /56's.

Mark

> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Mark Andrews <[email-masked]>
Date: Wed, 03 Aug 2011 10:55:28 +1000

> start planning for /52's rather than /56's.

Additionally, the advertised prefixes could be used to make BCP 38
filters better for homes that are multi-homed (or even single homed).
You don't need to propogate the routes but you could accept traffic
sourced from the advertised ranges.  Yes, I'm aware there are lots
of issues involved here like not accepting overly broad routes and
rapidly changing routes to prevent/reduce the abuse potential.

Mark

---

From: "Brzozowski, John" <[email-masked]>
Date: Wed, 3 Aug 2011 00:58:02 +0000

>start planning for /52's rather than /56's.
[jjmb] I don¹t get it.  If I (the provider) delegated a /56 I already know
that I delegated the same to the end user.  I have no need to receive any
router advertisements from the WAN interface of the end users gateway.  In
the case I am referring to DHCPv6 is used to dynamically delegate an IPv6
prefix of some length plus a globally routable /128 for the WAN interface.

---

From: "Brzozowski, John" <[email-masked]>
Date: Wed, 3 Aug 2011 00:58:29 +0000

---

From: Mark Andrews <[email-masked]>
Date: Wed, 03 Aug 2011 11:11:41 +1000

In message <[email-masked]>, "Brzozowski, Jo
hn" writes:
> [jjmb] I don=B9t get it.  If I (the provider) delegated a /56 I already know

I mis-interpreted the message I replied to, i.e. RA's vs routes.

> >> =
> >> =
> >> =
> >-- =

---

From: "Brzozowski, John" <[email-masked]>
Date: Wed, 3 Aug 2011 01:19:59 +0000

ack