Subject: [homenet] default LAN routing protocol for IPv6 CE router

From: "Torbet, Dan" <[email-masked]>
Date: Wed, 3 Aug 2011 07:42:53 -0600

The conversations so far on this topic have been great.  I think however, we need to take a step back for a moment and think through what the HOMENET network looks like when serviced by a CPE Router.  In my mind, we have a few scenarios that are possible.

The first is a CPE ingress router to the home and no other routers.  There may be in this device multiple SSIDs and they each might need to have their own address space and have separate firewall/filtering rules.  In this case, everything is contained in a single box and so no additional routing protocols are needed.  This has been defined in the CPE router (RFC 6204)  and the bis extension that is in draft right now.

The second case is a CPE ingress router with N routers behind it.  In this case, I humbly submit that anything where N is greater than 2 says medium sized business maybe larger.  I find it real hard to get any deeper than 2 routers in series for a HOMENET class device deployment. Anything greater than that and you likely would not use this class of device anyway.  Sure there will be situations where this is not true ,but I'll wager that in 90% of the installations where a CPE router is providing the link to the world, this will be the case.  Even factoring in SmartGrid I just can't see a very deep network.  Is there a use case for more than 1 or 2 layers in a HOMENET deployment that uses a CPE router as the connection to the world? To be clear here - this is what I mean:
(sorry for the poor ASCII art here )

               Provider Router -------- CPE router ----------Router ------ Router

Or

                                                            Provider
                                                                 |
                                                            CPE Router
                                                                ^
                                             Router                  Router
                                                |                             |
                                             Router                 Router

I will acknowledge that in some business cases you might place a router on each floor or each building in a campus, but this is where things get blurry for me - would you really use a CPE router in these cases for ingress into the business? You certainly could, but would you?

Given that, I think that defining how many routers exist behind this CPE ingress router will provide us with a reasonable place from which to define the needs and requirements for an IGP running in the home.

Dan

---

From: Philip Homburg <[email-masked]>
Date: Wed, 03 Aug 2011 16:09:37 +0200

In your letter dated Wed, 3 Aug 2011 07:42:53 -0600 you wrote:
>    The second case is a CPE ingress router with N routers behind
>    it.  In this case, I humbly submit that anything where N is
>    greater than 2 says medium sized business maybe larger.  

>From a layer 3 point of view, I think you are right (but these things are
hard to predict). What happens in practice though is that routers cost about
the same as switches. So people may stack routers in weird ways just because
they need more ports somewhere, or a wireless basestation, etc.

It not always easy to figure out how to switch off the routing functionality
and get the device to become a switch. Moreover, most users are probably
not even aware that there is a difference.

So in practice, I wouldn't be surprised if routers would get stacked quite
deep.

---

From: Thomas Herbst <[email-masked]>
Date: Wed, 3 Aug 2011 07:18:37 -0700

IMHO, consumers should be able to connect their routers together fairly randomly and have them work, because they will connect them randomly.

The hard problem we get to fairly quickly with random connections determining which connections do or do not require special security levels.

From: "Torbet, Dan" <[email-masked]<mailto:[email-masked]>>
Date: Wed, 3 Aug 2011 06:42:53 -0700
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [homenet] default LAN routing protocol for IPv6 CE router

The second case is a CPE ingress router with N routers behind it.  In this case, I humbly submit that anything where N is greater than 2 says medium sized business maybe larger.  I find it real hard to get any deeper than 2 routers in series for a HOMENET class device deployment. Anything greater than that and you likely would not use this class of device anyway.  Sure there will be situations where this is not true ,but I’ll wager that in 90% of the installations where a CPE router is providing the link to the world, this will be the case.  Even factoring in SmartGrid I just can’t see a very deep network.  Is there a use case for more than 1 or 2 layers in a HOMENET deployment that uses a CPE router as the connection to the world? To be clear here – this is what I mean:
(sorry for the poor ASCII art here )

Or

                                                            Provider
                                                                 |
                                                            CPE Router
                                                                ^
                                             Router                  Router
                                                |                             |
                                             Router                 Router

I will acknowledge that in some business cases you might place a router on each floor or each building in a campus, but this is where things get blurry for me – would you really use a CPE router in these cases for ingress into the business? You certainly could, but would you?

Dan

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 3 Aug 2011 07:48:55 -0700

> The hard problem we get to fairly quickly with random connections determining which connections do or do not require special security levels. 

the number of time's I've seen two cpe devices cascaded of each other in ipv4 land is significant, it works for the most part in the sense that double nat inside your house works for the most part. normally I take pitty on those folks and help them turn the interior one into a bridge, but the  expectation that anyone will do more than plug them together is problematic. there are other things that are routers that interact with the home network... laptop with vmware or virtualbox is a router, today in ipv4 it nats or bridges, smartphones are routers potentially with their own downstream devices. some of these devices are relatively statically connected and some of them are ephemerally connected.

> From: "Torbet, Dan" <[email-masked]>
> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Don Sturek <[email-masked]>
Date: Wed, 03 Aug 2011 09:57:56 -0700

Hi Rajiv,

One of the issues is that many early deployments of smart meter are using
IEEE 802.15.4.  That technology uses extremely small packet sizes (127
byte packets).

Meanwhile, each of the device manufacturers using smart meter information
are choosing their own link layer technology.   SAE (electric cars) are
looking to deploy powerline carrier (HomePlug GreenPHY seems to be the
leading candidate, IEEE P1901 subset).

So for simple smart meter deployments, the router won't necessarily be
present.  However, as devices like plug in electric vehicles are deployed
and connected to the smart meter, you will end up with routers as well as
the CPE router device.

Don

On 8/3/11 9:46 AM, "Rajiv Asati (rajiva)" <[email-masked]> wrote:

>Don,
>
>Just curious about 'smart energy' home network - Why is there a router
>behind the CPE router?
>
>Cheers,
>Rajiv
>
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Don
>> Sturek
>> Sent: Wednesday, August 03, 2011 10:25 AM
>> To: Torbet, Dan; [email-masked]; [email-masked]
>> Subject: Re: [v6ops] default LAN routing protocol for IPv6 CE router
>> 
>> Hi Dan,
>> 
>> Here is the initial scenario we are dealing with in the smart energy
>arena:
>> 
>> 
>> 
>>                 Provider (eg ISP)                        Provider (eg
>utility)
>>                          |
>> |
>>                      CPE router
>> CPE router
>>                           |
>> |
>>                       Router       ---------------------------------
>router
>>                           |                        Link layer
>> |
>>                           |                          Interconnect
>> |
>>                <Macs,
>> <Smart appliances,
>>                  iPads,
>> plug in vehicles,
>>                  Entertainment....>
>load
>> shed devices....>
>> 
>> I purposely drew in the devices the way I did since some of these
>networks
>> will evolve as silos then will interconnect when customers upgrade
>their
>> routers to ones with multiple link layers that accommodate
>interconnection.
>> 
>> Ultimately, there will not be such a rigid division of devices like
>shown but
>> wanted to emphasize the likelihood that there will be multiple CPE
>routers in
>> the home and an interconnection between them within the home.
>> 
>> Don
>> 
>> 
>> 
>> 
>> Date: Wed, 3 Aug 2011 07:42:53 -0600
>> Subject: [v6ops] default LAN routing protocol for IPv6 CE router
>> 
>> 
>> 
>> The conversations so far on this topic have been great.  I think
>however, we
>> need to take a step back for a moment and think through what the
>HOMENET
>> network looks like when serviced by a CPE Router.  In my mind, we have
>a few
>> scenarios that are possible.
>> 
>> 
>> 
>> 
>> The first is a CPE ingress router to the home and no other routers.
>There may
>> be in this device multiple SSIDs and they each might need to have
>their own
>> address space and have separate firewall/filtering rules.  In this
>case,
>> everything is contained in a single box and so no additional routing
>protocols
>> are needed.  This has been defined in the CPE router (RFC 6204)  and
>the bis
>> extension that is in draft right now.
>> 
>> 
>> 
>> The second case is a CPE ingress router with N routers behind it.  In
>this
>> case, I humbly submit that anything where N is greater than 2 says
>medium
>> sized business maybe larger.  I find it real hard to get any deeper
>than 2
>> routers in series for a HOMENET class device deployment. Anything
>greater than
>> that and you likely would not use this class of device anyway.  Sure
>there
>> will be situations where this is not true ,but I'll wager that in 90%
>of the
>> installations where a CPE router is providing the link to the world,
>this will
>> be the case.  Even factoring in SmartGrid I just can't see a very deep
>> network.  Is there a use case for more than 1 or 2 layers in a HOMENET
>> deployment that uses a CPE router as the connection to the world? To
>be clear
>> here - this is what I mean:
>> 
>>                Provider Router -------- CPE router ----------Router
>------
>> Router
>> 
>> 
>> 
>> Or
>> 
>> 
>> 
>> 
>> 
>>                                                             Provider
>> 
>>                                                                  |
>> 
>>                                                             CPE Router
>> 
>>                                                                 ^
>> 
>>                                              Router
>Router
>> 
>>                                                 |
>> |
>> 
>>                                              Router
>Router
>> 
>> 
>> 
>> I will acknowledge that in some business cases you might place a
>router on
>> each floor or each building in a campus, but this is where things get
>blurry
>> for me - would you really use a CPE router in these cases for ingress
>into the
>> business? You certainly could, but would you?
>> 
>> 
>> 
>> Given that, I think that defining how many routers exist behind this
>CPE
>> ingress router will provide us with a reasonable place from which to
>define
>> the needs and requirements for an IGP running in the home.
>> 
>> 
>> 
>> Dan
>> 
>> _______________________________________________ v6ops mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 3 Aug 2011 10:00:54 -0700

> Just curious about 'smart energy' home network - Why is there a router

got a better idea for interconnecting 802.15.4 and 802.3 networks than at layer-3?

> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Fred Baker <[email-masked]>
Date: Wed, 3 Aug 2011 10:04:16 -0700

> The conversations so far on this topic have been great.  I think however, we need to take a step back for a moment and think through what the HOMENET network looks like when serviced by a CPE Route…

That was, of course, one of the objectives of

http://tools.ietf.org/html/draft-baker-fun-multi-router
  "Exploring the multi-router SOHO network", Fred Baker, 1-Jul-11

---

From: Fred Baker <[email-masked]>
Date: Wed, 3 Aug 2011 10:06:17 -0700

> Just curious about 'smart energy' home network - Why is there a router

Because there is not (today) a residential router that spans 802.3/802.11 and 802.15.4 or 1901.2. There is therefore an expectation that those interfaces might be on a separate router. I can imagine vastly-multiport routers - you and I make them - but I can also imagine a cluster of two-port routers.

---

From: james woodyatt <[email-masked]>
Date: Wed, 03 Aug 2011 11:09:30 -0700

> got a better idea for interconnecting 802.15.4 and 802.3 networks than at layer-3?

How does 802.15.4 achieve the 1280 octet minimum MTU size required by IPv6?  I'm sure this is explained in an RFC somewhere, but I don't know.  Hoping someone knows off the top of their head and can quickly rattle off a citation from memory.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Ralph Droms <[email-masked]>
Date: Wed, 3 Aug 2011 14:12:18 -0400

RFC 4944

- Ralph

---

From: Robert Cragie <[email-masked]>
Date: Thu, 4 Aug 2011 05:03:36 +0100

+1

L2 bridging is OK if you can do it but not everything looks like Ethernet
frames. Not only that but if we have multi-link subnets using route-over,
the router to host ratio goes up considerably. The problem space is then
multi-link subnets then multi-subnet site/zone/homenets. L3 routing is the
only way this is going to work in homenet.

Robert

---

From: james woodyatt <[email-masked]>
Date: Thu, 04 Aug 2011 12:33:04 -0700

On Aug 3, 2011, at 21:03 , Robert Cragie wrote:
> 
> L2 bridging is OK if you can do it but not everything looks like Ethernet frames. Not only that but if we have multi-link subnets using route-over, the router to host ratio goes up considerably. The problem space is then multi-link subnets then multi-subnet site/zone/homenets. L3 routing is the only way this is going to work in homenet.

This is not strictly true.  ND-proxy is an alternative.

I've been told it's not a *viable* alternative--- for unspecified and possibly non-technical reasons-- but it is an alternative.  I've got a big bucket of popcorn to munch while I watch this discussion play out, and I really don't have a strong opinion one way or another.

My take, to the extent I have one, is that in comparison to L2-briding and ND-proxy, L3 routing on home networks will be "a bag of hurt" (to borrow a phrase from Le Grande Fromage), but if that's the direction from which rough consensus will emerge... well, okay then.  Let's open up the bag.

---

From: Robert Cragie <[email-masked]>
Date: Fri, 05 Aug 2011 19:07:05 +0100

Hi James,

Comments inline, bracketed by <RCC></RCC>

Robert

> This is not strictly true.  ND-proxy is an alternative.
<RCC>Maybe so, but it seems complex. It strikes me L3 routing is a more 
pragmatic approach, considering that is what is being done in, for 
example, ROLL, with simple one-interface routers.</RCC>
> My take, to the extent I have one, is that in comparison to L2-briding and ND-proxy, L3 routing on home networks will be "a bag of hurt" (to borrow a phrase from Le Grande Fromage), but if that's t…
<RCC>I don't doubt there will be a lot of issues to cover. L2 bridging 
is clearly simple but has clear issues beyond the common L2 frame for 
heterogenous subnetworks within the home, for example, with mesh 
wireless networks with sleepy nodes. This to me seems like the 
opportunity to take the bull emerging from your bag of cheese (how did 
it get in there?!) by the horns.</RCC>
>
>
> --
> james woodyatt<[email-masked]>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 6 Aug 2011 15:42:37 +0200

Hi James;

As Ralph indicates, RFC4944 describes a L2.5 fragmentation mechanism and
recommends a MTU of 1280 on 802.15.4 links.

That fragmentation mechanism does not allow forwarding at L3 (each L3
hop needs to reassemble). It is also sensitive to frame loss, which
sadly is frequent in 802.15.4 though it was mitigated in some
environment such as industrial (see WiHART, ISA100.11a, 802.15.4e).
Both issues (loss and forwarding) are addressed in
http://tools.ietf.org/html/draft-thubert-6lowpan-simple-fragment-recover
y but the draft is homeless at the moment.

4944 is also partially obsoleted by RFC-to-be 6282 for the header
compression piece.

Finally, I'd recommend to take a look at
http://tools.ietf.org/html/draft-thubert-6lowpan-backbone-router-02.
This work was initially a component of the registration based ND that
was designed at 6LoWPAN, and was split in midflight. You'll see in the
overview that the concept is to use a backbone router that proxies ND
between the 802.15.4 meshes and a higher speed Ethernet (or emulated
Ethernet such as WIFI infra mode), with the assumption that the backbone
runs classical ND whereas the  meshes use the registration-based ND.

Cheers,

Pascal

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ralph Droms (rdroms)
> Sent: Wednesday, August 03, 2011 8:12 PM
> To: james woodyatt
> Cc: Joel Jaeggli; IPv6 Operations; [email-masked]
> Subject: Re: [homenet] [v6ops] default LAN routing protocol for IPv6CE
> router
> 
> RFC 4944
> 
> - Ralph
> 
> >> got a better idea for interconnecting 802.15.4 and 802.3 networks
than at
> layer-3?
> >
> > How does 802.15.4 achieve the 1280 octet minimum MTU size required
by
> IPv6?  I'm sure this is explained in an RFC somewhere, but I don't
know.
> Hoping someone knows off the top of their head and can quickly rattle
off a
> citation from memory.

---

From: Scott Schmit <[email-masked]>
Date: Mon, 8 Aug 2011 09:23:46 -0400

> So in practice, I wouldn't be surprised if routers would get stacked quite

Exactly. My friend's parents have a DSL router followed by a wireless
router. Weirdly, the DSL router only has one Ethernet port and no
wireless (I find it hard to call it a router, but it does NAT rather
than bridging). Looking around at local stores, this was the available
equipment.

If you think about it, it makes sense: given a choice between selling a
WAP and getting it returned because "it doesn't work" (because ISPs will
only assign 1 IPv4 address) and selling a wireless router that "just
works" even if they're already using a router, the choice is obvious.
And there really aren't any wireless switches that I've ever seen.

Incidentally, if I did some kind of virtualization on my laptop on that
network, that would require my laptop to act as a router (using
libvirt). So now I'm 3 deep.

I can also imagine another new technology pushing to 3 deep because the
user bought something to add to their setup rather than to replace it
(didn't feel like rewiring stuff, afraid to break it, not a superset of
required functions, whatever).

-- 
Scott Schmit