Subject: [homenet] WG adoption of draft-stenberg-homenet-hncp-00

From: Ray Bellis <[email-masked]>
Date: Tue, 25 Mar 2014 10:07:00 +0000

At IETF 89 in London we took three hums:

1. On use of OSPF vs HNCP for configuration - strong consensus for HNCP

2. On how many routing protocols we should support in Homenet -
  strong consensus that it should be zero or one, but no consensus yet
  on which.

3. On adoption of HNCP as a WG item - good consensus for, a few undecided,
  none against.

On this basis the Chairs wish to proceed with the formal call for adoption of draft-stenberg-homenet-hncp-00, with a two week response window.

Please therefore send your comments on adoption of this draft to the list before 23:59 UTC on Tuesday 1st April.

thanks,

Ray and Mark

---

From: Ray Hunter <[email-masked]>
Date: Wed, 26 Mar 2014 21:57:53 +0100

Support adoption of HNCP as a WG item.

I am interested to read more information on how Homenet would/could work 
with zero routing protocol.

I presumed exactly one common Homenet interworking routing protocol.

-- 
Regards,
RayH

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Mar 2014 17:30:29 -0400

I have read the HNCP draft, and while it is very rough, and lacks greatly in
the area of "how", being focused on the "what", I am happy with the WG
adopting it, and then improving it.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 27 Mar 2014 07:03:13 +0100 (CET)

> adopting it, and then improving it.

I agree. The mechanisms described in the HNCP documents seem good to me, 
I am not at all sure that the HNCP protocol as it stands right now is the 
best way to communicate the information the mechanisms need in order to do 
their job, but this is the kind of work the WG needs to do.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 27 Mar 2014 07:04:15 +0100 (CET)

On Wed, 26 Mar 2014, Ray Hunter wrote:

> I am interested to read more information on how Homenet would/could work with 
> zero routing protocol.
>

HNCP as it stands right now has a "routing protocol" of it's own that is 
extremely rudimentary, but it gets the job done. I think this is what is 
referred to as "zero routing protcol" because people don't really want to 
call it a routing protocol (my interpretation).

---

From: Ray Hunter <[email-masked]>
Date: Thu, 27 Mar 2014 08:19:52 +0100

> Mikael Abrahamsson <mailto:[email-masked]>
> 27 March 2014 07:04
> HNCP as it stands right now has a "routing protocol" of it's own that 
> is extremely rudimentary, but it gets the job done. I think this is 
> what is referred to as "zero routing protcol" because people don't 
> really want to call it a routing protocol (my interpretation).
>
>
Right, but the way I see it:

If you have an arbitrary topology then you probably need to carry 
metrics to prefer one link type over another.
If you want to be able to determine which prefixes to delete from the 
FIB and RA when a particular upstream provider link goes down, you 
probably need some sort of tagging.
If you want fast convergence around failures you probably need a decent 
path discovery algorithm.
If you want to differentiate between a temporary change (due to an 
incident or link failure) and a longer term permanent change (due to 
replugging or device insertion or removal) then you probably need two 
different sets of timers and problem diagnostics.

In other words; we definitely need a routing protocol, and probably a 
configuration protocol too.

So isn't the danger than HNCP starts off being very simple, and ends up 
duplicating a lot of previous work and experience?

I'm interested to hear the contrarian view.

-- 
Regards,
RayH

---

From: Pierre Pfister <[email-masked]>
Date: Thu, 27 Mar 2014 08:50:05 +0100

Le 27 mars 2014 à 08:19, Ray Hunter <[email-masked]> a écrit :

>> HNCP as it stands right now has a "routing protocol" of it's own that is extremely rudimentary, but it gets the job done. I think this is what is referred to as "zero routing protcol" because people don't really want to call it a routing protocol (my interpretation).
>> 
>> 

That is my understanding of the "zero routing protocol » too.

> If you have an arbitrary topology then you probably need to carry metrics to prefer one link type over another.
> If you want to be able to determine which prefixes to delete from the FIB and RA when a particular upstream provider link goes down, you probably need some sort of tagging.
> If you want fast convergence around failures you probably need a decent path discovery algorithm.
> If you want to differentiate between a temporary change (due to an incident or link failure) and a longer term permanent change (due to replugging or device insertion or removal) then you probably need two different sets of timers and problem diagnostics.
> 
> In other words; we definitely need a routing protocol, and probably a configuration protocol too.
> 
> So isn't the danger than HNCP starts off being very simple, and ends up duplicating a lot of previous work and experience?
> 

Except the second point (determine which prefix to delete…), which is done by the prefix assignment algorithm on top of HNCP, all other points will have to be answered to decide which routing protocol to use. The current draft doesn’t intend to answer the routing protocol issue. It was not left blank for the simple reason we  needed to implement it and make it run.

I dont think we want to run a complex routing protocol in HNCP. It’s more like either we want to make something very simple, and we use HNCP for this, or we want all what you said, and we use another existing protocol. The point of the draft is just to let you know that it is *possible* to route packets, in a very simple way, by using just HNCP as it is, with no extra information.

Regards,
Pierre

> 
> -- 
> Regards,
> RayH
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Ole Troan <[email-masked]>
Date: Thu, 27 Mar 2014 09:29:56 +0100

> On this basis the Chairs wish to proceed with the formal call for adoption of draft-stenberg-homenet-hncp-00, with a two week response window.

I'm in favour of adopting this document, with the premise that HNCP is not going to be yet another routing protocol.
that is restricted to bootstrapping / configuring the home network.

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Thu, 27 Mar 2014 07:34:03 -0500

> So isn't the danger than HNCP starts off being very simple, and ends up duplicating a lot of previous work and experience?

If the working group submits HNCP for publication and it's morphed into a full-blown routing protocol, I will send it back (assuming I'm still AD at that point, and also in the unlikely event that I didn't intervene when someone proposed adding the ful-blown routing stuff).   I don't think anybody intends for this to happen, and if it does happen it will prevent the spec getting published, so I think we're pretty safe... :)

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 27 Mar 2014 14:03:05 +0100

> So isn't the danger than HNCP starts off being very simple, and ends
> up duplicating a lot of previous work and experience?

I agree, and I'd like to put that in stronger terms.

Homenet has just avoided committing suicide by not requiring an
unimplementable, undebuggable monster of an OSPF+configuration
protocol.

Are we now going to require an unimplementable, undebuggable monster
of an HCNP+routing protocol?

-- Juliusz

---

From: Ray Bellis <[email-masked]>
Date: Thu, 27 Mar 2014 13:10:44 +0000

> of an HCNP+routing protocol?

That is clearly not the plan.

Could we please reserve this thread for discussion around the _adoption_ of this draft.  If you have thoughts about HNCP's specification and future implementation, please start a new thread.

Ray

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 27 Mar 2014 09:15:13 -0400

> adopting it, and then improving it.
After reading the draft again, I agree the WG should adopt this, with 
the knowledge the draft is rough and needs some iterations to make whole.

tim

---

From: Ray Hunter <[email-masked]>
Date: Thu, 27 Mar 2014 19:36:52 +0100

> Pierre Pfister <mailto:[email-masked]>
> 27 March 2014 08:50
> Le 27 mars 2014 à 08:19, Ray Hunter<[email-masked]>  a écrit :
>
>>> Mikael Abrahamsson<mailto:[email-masked]>
>>> 27 March 2014 07:04

I think that's still an open question "(determine which prefix to 
delete…)", and an interesting side effect of a decision to split routing 
and prefix assignment.

e.g. looking at 
http://tools.ietf.org/html/draft-ietf-v6ops-ipv6-multihoming-without-ipv6nat-06 
section 5.2

and especially considering any end hosts that do not understand 
http://tools.ietf.org/html/draft-troan-homenet-sadr-00,

do you want RA to start or stop advertising a prefix (hat has been 
derived from an upstream neighbor) on a local interface as a candidate 
default routeto locally connected end systems because the path to that 
ISP is down (routing), or because of a configuration timeout (DHCPv6 PD 
+ HNCP), or both, or neither?

> ------------------------------------------------------------------------

-- 
Regards,
RayH

---

From: Dave Taht <[email-masked]>
Date: Thu, 27 Mar 2014 11:48:59 -0700

On Thu, Mar 27, 2014 at 6:15 AM, Tim Wicinski <[email-masked]> wrote:
> After reading the draft again, I agree the WG should adopt this, with the
> knowledge the draft is rough and needs some iterations to make whole.

I agree the WG should adopt this, with the knowledge that the code is rough,
and needs some more people working on it so that the ideas can be fully explored
and  tested and then the draft made whole.

Code in progress is at:

https://github.com/sbyx/hnetd/

for anyone that cares to look/contribute.

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 28 Mar 2014 08:55:57 +0100 (CET)

> for anyone that cares to look/contribute.

I have been testing the code the guys have made available in OpenWRT 
trunk. Yes, the code is very rough, but there are quite a lot of things 
that work (and some that don't).

Very nice to see running code!

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 28 Mar 2014 09:02:28 +0100 (CET)

> that work (and some that don't).

Btw, the package is called "hnet-full" which installs everything one 
needs. Then there is interface configuration needed. The authors pointed 
me to an interface configuration script at:

<https://raw.github.com/fingon/hnet-openwrt-feed/master/hnet/files/setup-network/ar71xx.sh>

Depending on platform you might have to change interface identifiers and 
vlan setup options.

---

From: Hans Liu <[email-masked]>
Date: Fri, 28 Mar 2014 20:13:27 +0800

Just read the draft and would like to support the adoption of HNCP as a WG
item.

Thanks,
Hans

On Tue, Mar 25, 2014 at 6:07 PM, Ray Bellis <[email-masked]>wrote:

> On this basis the Chairs wish to proceed with the formal call for adoption
> of draft-stenberg-homenet-hncp-00, with a two week response window.
>

-- 
Instead of following the fashion, we lead it through.

---

From: Ray Bellis <[email-masked]>
Date: Fri, 28 Mar 2014 12:27:03 +0000

> Please therefore send your comments on adoption of this draft to the list before 23:59 UTC on Tuesday 1st April.

Oops, where did March go?!

That should, of course, have read Tuesday *8th* April.

Ray

---

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Tue, 1 Apr 2014 02:31:40 +0000

I have read and support adoption of this draft.

Thanks,
Shwetha

On 3/25/14 3:37 PM, "Ray Bellis" <[email-masked]> wrote:

>On this basis the Chairs wish to proceed with the formal call for
>adoption of draft-stenberg-homenet-hncp-00, with a two week response
>window.
>