Subject: [homenet] Simple Naming and DNS Privacy

From: "Border, John" <[email-masked]>
Date: Fri, 23 Mar 2018 09:54:43 +0000

Does the simple naming architecture need to deal with DNS privacy using port 853?  Subject to the success of the security boundaries, the home network can be considered as already being private to some extent.  But, my devices are mobile and will move in and out of the home network and may have DNS privacy use enabled for outside use.

John

---

From: Ted Lemon <[email-masked]>
Date: Fri, 23 Mar 2018 11:41:11 +0000

I think the right way to approach this question is to try to write a
security model.

On Fri, Mar 23, 2018, 09:54 Border, John <[email-masked]> wrote:

>
>      Does the simple naming architecture need to deal with DNS privacy
> using port 853?  Subject to the success of the security boundaries, the
> home network can be considered as already being private to some extent.
> But, my devices are mobile and will move in and out of the home network and
> may have DNS privacy use enabled for outside use.
>
>
> John
>
>
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>

---

From: "Border, John" <[email-masked]>
Date: Wed, 28 Mar 2018 19:07:09 +0000

Makes sense to me…

From: Ted Lemon [mailto:[email-masked]]
Sent: Friday, March 23, 2018 7:41 AM
To: Border, John <[email-masked]>
Cc: HOMENET <[email-masked]>
Subject: Re: [homenet] Simple Naming and DNS Privacy

WARNING: The sender of this email could not be validated and may not match the person in the "From" field.
CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

I think the right way to approach this question is to try to write a security model.

On Fri, Mar 23, 2018, 09:54 Border, John <[email-masked]<mailto:[email-masked]>> wrote:

John

_______________________________________________
homenet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/homenet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_homenet&d=DwMFaQ&c=dIKa1mMv92xhhFzVXv5A3Q&r=9F44ji63_2hvW5HufmlpP-DFKXuFy4jDtL5PXwKlTqg&m=wURh4Aew7ytCmqHZSHliUoRRqENshjEMp6P1bgiTm70&s=CIso4XJsQKCZtK-IokzCXcuZeyKqaVu8KudmE7wJPDc&e=>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Mar 2018 15:19:07 -0400

> Makes sense to me…

OK.   Doesn't have to be anything fancy—just enumerate the attacks that you think we would be protecting against.   Does that sound like something you'd be willing to do?

---

From: "Border, John" <[email-masked]>
Date: Thu, 29 Mar 2018 21:40:09 +0000

I’ll give it a shot…

Sent: Wednesday, March 28, 2018 3:19 PM

On Mar 28, 2018, at 3:07 PM, Border, John <[email-masked]<mailto:[email-masked]>> wrote:
Makes sense to me…

---

From: Ted Lemon <[email-masked]>
Date: Thu, 29 Mar 2018 21:47:39 -0400

> I’ll give it a shot…

Great, thanks!